Reporting Services Add in for SharePoint - Installation Interrupted
I am trying to install the 'Reporting Services Add-In for SharePoint'. And for some strange reason, its rolling back the installation at the last step and showing me the message saying 'The Reporting Services Add in set up was interrupted. Your system was not modified, please run the set up again'. I tried googling for any solutions, but everyone is saying I should look in the 'Documents and Settings -> temp' folder for the installation log filewhich would tell me the cause of the error, but as luck would have it, im not able to find that file as well (there are no files in temp, and the log is not getting created there).. I tried the 'msiexec *i' option, but was not able to find anything useful there. Any pointers towardssolvingthis issue would be greatly appreciated.
June 28th, 2008 1:20pm

What happens when you run it again? Try it with nothing running. What do you see in event viewer?
Free Windows Admin Tool Kit Click here and download it now
June 28th, 2008 4:55pm

If i run it again,I get the same error over and overagain, and this is a new server, only MOSS is installed on it, along with Reporting Services and SP2 for SQL Server 2005. The event viewer says : "Product: Microsoft SQL Server 2005 Reporting Services Add-in for Microsoft SharePoint Technologies -- Installation failed." There is no other information available in the event viewer. I am following the same steps mentioned in Microsoft SQL Server Reporting Services (SSRS) - Installation/Configuration Guide for SharePoint Integration Mode, Published via the SharePoint Team Blog. What could be wrong?
June 30th, 2008 9:52am

Hi Manesh,Id like to give some details about installing the Reporting Services Add-in for you. You must be a SharePoint farm administrator to install the Reporting Services Add-in. SharePoint product or technology must be Windows SharePoint Services 3.0 or Office SharePoint Server 2007. You cannot install the Reporting Services Add-in on a pre-release version of the software. You can use the Premium or Standard edition. When you install the Reporting Services Add-in, the setup checks whether the computer is running the x86 or x64 version of Microsoft Windows Server 2003 or later. The Itanium platform is not supported. Before installing the Reporting Services Add-in, it is necessary to configure Reporting Services for SharePoint Integration Mode. In addition, here is an article that supports installing Reporting Services Add-in. this helps.Thanks.
Free Windows Admin Tool Kit Click here and download it now
July 1st, 2008 12:16pm

Good afternoon Xiao, I too recently installed an evaluation copy of SharePoint 2007 and SQL Server 2005 and ran into the same error when installing the Add In for Reporting Services. I ran through the list of items provided and was wondering if an evaluation copied is preventing the install. Reporting Services is configured for SharePoint Integration, anonymous is unchecked on the web site and it's not a x64 system. Any other thought on the roll back issue? Thanks
July 7th, 2008 9:49pm

Manesh, Did you resolve the roll back issue when trying to install the Add In for SharePoint?
Free Windows Admin Tool Kit Click here and download it now
July 8th, 2008 2:08pm

No for me the issue is still persisting.. No clue what is causing it. Please let me know how u solved it -if you solve it somehow.
July 8th, 2008 2:18pm

I sure will. Thanks
Free Windows Admin Tool Kit Click here and download it now
July 9th, 2008 7:16pm

Hi, Please check the log file. When Setup runs, it logs information to a log file in the %temp% folder for the user who is installed the Reporting Services Add-in. The file name is RS_SP_<number>.log. Hopefull this helps. Thanks.
July 10th, 2008 2:09pm

Solved it finally, What you need to solve this isto first run the installer from the commandline without enabling the Custom Actions and then go ahead and run the custom actions tool seperately. Follow the steps given below. 1. Open the commad window (Start>Run type cmd and press enter) 2. Navigate to the path where the installer(SharePointRS.msi) is stored 3. Execute SharePointRS.msi SKIPCA=1 This will doa files only installation of Reporting Services Plug-In 4. CD to %temp% 5. Execute rsCustomAction.exe /i to auto-configure the installed files. PS: If even this fails, check if your webconfig file is write protected, remove the write protection if it is enabled.
Free Windows Admin Tool Kit Click here and download it now
July 10th, 2008 3:21pm

Hi Manesh, Im glad to hear you have been able to resolve the issue. Thank you for sharing your post here that can help other community members facing similar problems. Thanks again.
July 11th, 2008 4:38am

Manesh, Iwas finallyable to load the ADD-IN without it rolling back. This link was very helpful. It talks about the error log located under the local settings\temp directory. The error log is called RS_SP_0.log. The 0 is how many times you try to install. My number was up to 12. I had the same error but after pausing the web severs, and then running the install from a DOS prompt using the documented command the ADD IN installed. I have not done anything else at this point so there still may be unknown issues. I wanted to share this part; however,since I know how frusting this can be. Thanks and good luck
Free Windows Admin Tool Kit Click here and download it now
July 11th, 2008 1:02pm

I have gone through this article and tried everything but I am still not coming up with a solution. I have a sample error log that says access denied but I am a farm admin and I double checked sysadmin on the db. I even double checked the specific MOSS_Config db and permissions are set as db_owner/sysadmin. The ssrs is running with integration mode, the CA moss is running, the default moss is running, the ssrs web service is running, the db's look, what I'm I missing?Any ideas?Submitted a MS help desk ticket as well:SRZ090325000490 User: SYSTEMInstalling Report Server feature.Calling copyappbincontents command. copyappbincontents command completed successfully.Adding Report Server feature to farm.Install error: The EXECUTE permission was denied on the object 'proc_putObject', database 'MOSS_Config', schema 'dbo'.Error details: System.Data.SqlClient.SqlException: The EXECUTE permission was denied on the object 'proc_putObject', database 'MOSS_Config', schema 'dbo'. at System.Data.SqlClient.SqlConnection.OnError(SqlException exception, Boolean breakConnection) at System.Data.SqlClient.TdsParser.ThrowExceptionAndWarning(TdsParserStateObject stateObj) at System.Data.SqlClient.TdsParser.Run(RunBehavior runBehavior, SqlCommand cmdHandler, SqlDataReader dataStream, BulkCopySimpleResultSet bulkCopyHandler, TdsParserStateObject stateObj) at System.Data.SqlClient.SqlCommand.FinishExecuteReader(SqlDataReader ds, RunBehavior runBehavior, String resetOptionsString) at System.Data.SqlClient.SqlCommand.RunExecuteReaderTds(CommandBehavior cmdBehavior, RunBehavior runBehavior, Boolean returnStream, Boolean async) at System.Data.SqlClient.SqlCommand.RunExecuteReader(CommandBehavior cmdBehavior, RunBehavior runBehavior, Boolean returnStream, String method, DbAsyncResult result) at System.Data.SqlClient.SqlCommand.InternalExecuteNonQuery(DbAsyncResult result, String methodName, Boolean sendToPipe) at System.Data.SqlClient.SqlCommand.ExecuteNonQuery() at Microsoft.SharePoint.Utilities.SqlSession.ExecuteNonQuery(SqlCommand command) at Microsoft.SharePoint.Administration.SPConfigurationDatabase.StoreObject(SPPersistedObject obj, Boolean storeClassIfNecessary, Boolean ensure) at Microsoft.SharePoint.Administration.SPConfigurationDatabase.PutObject(SPPersistedObject obj, Boolean ensure) at Microsoft.SharePoint.Administration.SPPersistedObject.Update() at Microsoft.SharePoint.Administration.SPPersistedObject.Update(Boolean ensure) at Microsoft.SharePoint.Administration.SPPersistedChildCollection`1.Add(T newObj, Boolean ensure) at Microsoft.SharePoint.Administration.SPPersistedChildCollection`1.Add(T newObj) at Microsoft.SharePoint.Administration.SPFeatureDefinitionCollection.Add(String relativePathToFeatureManifest, Guid solutionId, Boolean force) at Microsoft.SharePoint.Administration.SPFeatureDefinitionCollection.Add(String relativePathToFeatureManifest, Guid solutionId) at RSCustomAction.ReportServerFeature.<AddToFarm>b__1() at RSCustomAction.ReportServerFeature.RetryFailedOperation(RetryFunction function, Int32 numTries) at RSCustomAction.ReportServerFeature.AddToFarm(Int32 numTries) at RSCustomAction.RSFeatureSetup.Install(Boolean repair, Int32 addRetries)Uninstalling Report Server feature.Uninstalling Report Server feature.Report Server feature was uninstalled.Stopping W3SVC service.fsugeiger
March 26th, 2009 12:18am

1. I've downloaded and installed Sharepoint Server 3.0 onto Windows Server 2003.2. I've downloadedSharePointRS.msiand manually executed SharePointRS.msi SKIPCA=13. The next step indicates I need to manually execute the file rsCustomAction.exe but what could be the problem if it doesn't exist on my server?Thanks,-Bruce
Free Windows Admin Tool Kit Click here and download it now
April 14th, 2009 2:46am

Could you help, I am having the same problems. I have already followed these instructions: 1. Open the commad window (Start>Run type cmd and press enter) 2. Navigate to the path where the installer (SharePointRS.msi) is stored 3. Execute SharePointRS.msi SKIPCA=1 This will do a files only installation of Reporting Services Plug-In 4. CD to %temp% 5. Execute rsCustomAction.exe /i to auto-configure the installed files. And added my logged on user as site collection administrator and farm administrator. However, I am still getting an error when activating features in web app '' (User does not have permission to add feature to site collection:) Would appreciate any help. Thanks, Kwasi
January 8th, 2010 1:37pm

Hey Kwasi,Is the site collection SSP-related (either the SSPAdmin site collection or MySites) ? Also anothr thing to note is that simply going to %temp% didnt do it for me. I actually had to navigate up one folder to get to rsCustomAction.exe (so just C:\..\..\..\temp as opposed to C:\..\..\..\temp\<number>) .Maxim
Free Windows Admin Tool Kit Click here and download it now
February 23rd, 2010 7:31pm

Make sure you start the command prompt as Administrator. I saw an error when I did not do this that indicated that SYSTEM account didn't have permissions to the sql config database. Rick Stokes
April 2nd, 2010 10:51pm

Hi All, Is there any other way to resolve the issue? I tried this command line approach and it worked (appearantly). What actually happened was the reporting services add in inserted some httphandlers in each and every web.config file of the MOSS server farm, resulting in the whole environment crashing down and giving 'Server Error' The problem was later solved by removing all such http handlers which was added by the customactions.exe. regards, adnan shamim.Adnan Shamim
Free Windows Admin Tool Kit Click here and download it now
May 17th, 2010 10:45am

Hi all, i am revisiting the problem as i still am not able to resolve it yet. please anyone confirm one thing first i have 2 web front ends and a database server. reporting services is configred on this database server in sharepoint integrated mode. the reporting services add in : is it required to be installed on BOTH front ends, starting from the one which is hosting the central administration? this link suggests that i should run complete setup on one of the web front ends, and a FILE MODE installation (from command line) from other web front ends (skipping the customactions.exe) the link is now modified with sharepoint 2010. if anyone has integrated reporting services with MOSS 2007 in a farm environment, please confirm me on which servers exactly is the reporting server 2008 add in is required to be installed and which order. Adnan Shamim
June 10th, 2010 7:27am

I found a very good link: solved all my issues, still haven't tested the server yet. can anyone tell me whether BI Studio 2008 is freely available as a redistributable package? i do not want to give sql server 2008 setup to every business analyst as this is practically impossible in my case. any help would be appreciated.Adnan Shamim
Free Windows Admin Tool Kit Click here and download it now
October 11th, 2010 1:38pm

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics