Report Parameter value not changing
I have a report (that I will use as a sub report later) with a parameter declared like this: Name: MyID Prompt: My ID Data Type: Integer Select parameter visibility: Hidden I then insert a sub report onto my report and point it to my 'sub' report above. My question is, how do I setup a parameter in the main report that passes my ID form the report to the MyID parameter of the sub report? I have tried setting up the report parameter like this: Name: LinkToSubReport Data Type: Integer Select Parameter Visibility: Internal Now, in the Availbale Values and Default Values tabs, I have set teh Dataset to my dataset, and the value fields to my ID field, but when I run the report and flick through the pages of result, my sub report values do not change.
October 20th, 2010 2:51pm

When you right-click on the sub report and select properties isn't their a tab along the top that has parameters. From here you should be able to take a parameter in your report and match it to a parameter in the sub report. I have done this but I don't have access to Visual Studio right this second to check Seth
Free Windows Admin Tool Kit Click here and download it now
October 20th, 2010 4:27pm

Thanks Seth, I'm building the report in report builder not VS. I have added a new parameter with a name that corresponds with my sub report parameter, and a value that corresponds with my report parameter. I'm not entirely sure though if my report parameter is set correctly (ie, Available Values, Default Values etc)
October 20th, 2010 6:44pm

Hi, In the Subreport properties window, click Parameters to go to the Parameters page, click Add to add one row, then type the Parameter name of the subreport and choose an expression from the main report which will be passed to the subreprot. I assume that you are using Report Builder 2.0 / 3.0. thanks, Jerry
Free Windows Admin Tool Kit Click here and download it now
October 21st, 2010 9:18am

Ok - I got it sorted. On my sub report my parameter visibility was set to Internal. I set it to Hidden, set the Prompt to equal the parameter name, and presto!
October 21st, 2010 2:32pm

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics