Report Builder 3.0 unable to access SharePoint Foundation 2010 Report Server
I am having a terrrible time getting this to work. I have configured the SharePoint site and the SQL Servers involved to use Kerberos. That has been confirmed working. I then configured the SharePoint site's Reporting Services integration (trusted account), enabled anonymous access and enabled report builder. I can launch report builder without any issues at all. The problem comes when I try to save my report. When Report Builder is started Items->New-ReportBuilder Report it opens and display in the lower left hand corner "No current report server." When I close the Wizard dialog and click connect I enter http://server.fqdn.net and I receive the following error: Connection failed: Unable to connect to the server that is specified in the URL, 'http://servername.fqdn.net/'. Make sure that the server is running, the URL is correct, and you have permission to use the server. I have also tried http://servername.fqdn.net/reportsserver/. When I try that I receive a login prompt. When I enter my credentials it tries for a few seconds and then sends another login prompt. I installed the report server using default settings. The reporting services db is on the same server as sharepoint. The configuration and other databases are on a remote SQL Server.
October 6th, 2010 11:09pm

Just to add some new information. When I upload a report to the site it works under the account I used to install sharepoint and sql server. When I try to access the report under another account, which is a site collection admin, I get this error: ---- An error has occurred during report processing. (rsProcessingAborted) Cannot create a connection to data source 'DataSource1'. (rsErrorOpeningConnection) The connection either timed out or was lost. Unable to read data from the transport connection: An existing connection was forcibly closed by the remote host. An existing connection was forcibly closed by the remote host When I try to access it using any account from any other machine I get this: Error The Web application at <<URL>>/Reports/Untitled.rdl could not be found. Verify that you have typed the URL correctly. If the URL should be serving existing content, the system administrator may need to add a new request URL mapping to the intended application. Troubleshoot issues with Microsoft SharePoint Foundation. Correlation ID: 32a4ae22-6785-49e7-8a7c-095ca515307a Date and Time: 10/7/2010 9:09:00 AM ---- When I try to deploy a report from BIDS I get multiple login prompts. I have tried setting the authentication levels manually. <RSWindowsNegotiate /> <RSWindowsKerberos /> <RSWindowsNTLM /> Nothing is working... I may need to be placed on a 72 hour hold soon. :-s
Free Windows Admin Tool Kit Click here and download it now
October 7th, 2010 4:07pm

Here is how this progressed to an answer: 1. The initial installation must have been bad because it would not let us download report builder. 2. We turned on anonymous access based on a few articles we found online. This allowed us to download report builder. 3. Report builder, however, was unable to access the report server. This was the ultimate issue. 4. I reinstalled but continued to enable anonymous access assuming it was required, even though I had not done it on the initial test deployment (which did work). 5. I continued to get the error that the report server did not exist. 6. I reinstalled again and tried another fix. 7. I reinstalled a third time but did not enable anonymous access, because that was the only thing I could think that was different between the test site that worked and this one.
October 7th, 2010 10:36pm

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics