Remote server returned an error: (403) Forbidden
Found the answer. Don't know why but simply had to apply default settings to virtual server. Thanks!!!!
May 26th, 2012 9:58am

What a frustrating situation. At least 4 servers and 3 of my PCs continually kept giving me MS Updates for .NET Framework 2.0 and 3.5. I would apply and it would come back 5 minutes later. I got everything fixed using the .NET cleanup tool. I finally used this on my production SQL Server that has SQL Server 2005. After hours I found out that .NET 1.0 and 1.1 was wiped out. That caused big problems but I was able to fix it in IIS by referencing the 2.0 folder in the extensions. I would have been clueless but I was able to find it by Binging around. Now I'm getting Remote server returned an error: (403) Forbidden. It's a bit disconcerting that Microsoft Updates would cause this conundrum.
Free Windows Admin Tool Kit Click here and download it now
May 26th, 2012 1:28pm

Hello Gary, Based on my experience, this issue have many possible causes. One is that the server, which contains reporting service, has port conflict with the other server. Please try to check all the sites on the server to ensure that the port is only available on reporting service server. The another possible cause is that the application pool was not granted enough read/write permission on the reportserver and reports virtual directory on IIS. Please grant the user group ReportServer$<instancename> R/W permission on both virtual directories. In addition, please ensure that the execution permission is set as "script only" on both reportserver and reports virtual directory. If the value is set as none, it will lead 403 issue. Also, you can go to the reporting service configuration and apply default settings to the report server virtual directory to see whether the issue is solved. Hope it is useful to you. Regards, EdwardEdward Zhu TechNet Community Support
May 27th, 2012 3:25am

The problem I have with a couple of the above possibilies is that my the Reporting server was working fine ever since I've been using it (years) until I ran the .NET cleanup tool. How would that affect the port? Also, read/write permissions were fine for all my reports. How would changing the extensions to point to .NET Framework 2.0 change the permissions? I'm also curious why SQL Server 2005 was using .NET Framework 1.0, furthermore why my server kept looping the Microsoft Updates for .NET Framework 2.0 and 3.5 and why it only started now. Thanks for your input and I'll continue to investigate this.
Free Windows Admin Tool Kit Click here and download it now
May 27th, 2012 6:33am

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics