Remote Control Service on clients is disabled

Hello everyone,

I have a deployment of SCCM 2012 setup, a big improvement over 2007 so far, and everything was working great.  For whatever reason when I push the client installation to PC's or the client is installed during a OSD, everything appears to work perfectly except the Remote Control doesn't work.  Further investigation lead me to the Configuration Manger Remote Control Service which was disabled.  If i manually enable it Remote Control works like expected.

In the Client Settings Policy for  the site I have the remote control configured and setup for access.  If I go to the client and look at the remote control settings under the options in the System Center app my policy settings are applied correctly there, yet the service is disabled.

I am wondering if I am missing something or if anybody would know why this is happening.  I have ruled out Group Policy disabling this service.  As far as i know this is a new service to SCCM 2012.

Any help is appreciated.

June 7th, 2012 1:40am

In the Remote tools settings, click Configure and enable the remote tools. That will configure the service to start automatically.

Free Windows Admin Tool Kit Click here and download it now
June 7th, 2012 6:14am

I already have that check marked to be enabled.

I am wondering if this is somehow related to the client policy polling interval?  Right now it is set at the default of 60 minutes.  I'm going to do some testing on lowering the interval just to see if it has any effect.

June 7th, 2012 11:17am

Check the CmRcService.log on the client to gain a further understand of the issue.  If the Default Client Settings have Remote Control enabled, then is should be enabled by default.  I really can't comment without you first providing and looking at the logs to gain a better understanding.  You can also use ClientSpy to check to ensure policy is being applied to the system properly. 

Free Windows Admin Tool Kit Click here and download it now
June 7th, 2012 4:00pm

The CmRcSerivce.log doesn't exist.  I'm assuming that is because the service has never started?  Is ClientSpy part of the old sccm tools or is it a new utility to download?  Does the PolicySpy from the sccm 2007 tools pack work still?
June 7th, 2012 6:02pm

Toolkit for ConfigMgr 2012 can be downloaded here: http://www.microsoft.com/en-us/download/details.aspx?id=29265
Free Windows Admin Tool Kit Click here and download it now
June 7th, 2012 6:11pm

Thanks for the link.

To give a little more background on what I'm doing.  I am deploying an OS (win7 & winXP) to a PC(s).  After the OSD completes, client policies seem to be applied, but the remote control service is still set to disabled and the remote control session fails.  I have manually ran the policy retrievals on the clients, rebooted them multiple times but the service remains disabled.  I have noticed though, if I just let the PC's on over night the next day the remote control service is enabled and running and the remote control sessions work as expeced.

Is this normal functionality?  Does the client just need to be installed on a PC and left running for a certian amount of time before the compliancy of the remote control service is checked?  I am perfectly fine with this, if this is how it was designed to work.  We haven't pushed the client out company wide yet, and I would just like to know if this is how its intended to work.  I just want to be sure that the remote service will start at some point that way we have access to manage the PCs.   

June 8th, 2012 11:29am

mobius01,

That is a very interesting observation and something that we have not observed before, in short, the service should begin rather immediately as part of the client installation.  Are you observing this same behavior on all your systems after an OS deployment?  Also, do you observe the same issue regarding remote control service delayed installation when installing a client on a system not within a OS deployment? 

Free Windows Admin Tool Kit Click here and download it now
June 8th, 2012 3:27pm

Eric,

In short yes, I have done a few client push installations to PC's that had the SCCM 2007 client on them and everything seems to go fine except the remote control service remains disabled.  One was a Windows XP PC that we are going to leave alone and see if the service starts on its own.  We have installed software and updates through the new client already on this machine so I know the 2012 client was installed correctly and is getting policies.  I did push the client install to two Win7 PC's and the remote control service did not start right away, however when I checked them a few hours later the service was running and remote control sessions were successful.  So I'm not sure if I just wasn't patient enough or if something else was going on.

Testing to see if stuff is working after an OSD build is just easier for me.  I can image a PC, log in, make sure everything is working correctly, if not, I'll make changes, and then just re-image again. So far deployments of both WinXP and Win7 seem to exhibit this behavior of the service not starting.  Could it be something to do with the WIM files I am using for the OSD's?  I had just made copies of the WIM files we used in SCCM 2007.

If you want me to provide some screenshots or log files I'll do what I can, however I will be out of the office for the weekend so I can't post them right away.

June 9th, 2012 1:54am

I am seeing the same thing on some clients here.

Client is installed OK, Configuration Manager show component "Remote Tools Agent" is installed, I even checked the registry setting HKLM\SOFTWARE\Microsoft\SMS\Client\Client Components\Remote Control\Enabled is set to 1, but when I check services, "Configuration Manager Remote Control" is set to Disabled.

Client has been installed for several days.

There is no CmRcService.log file before I manually start the service.

Free Windows Admin Tool Kit Click here and download it now
June 10th, 2012 7:59pm

Anders,

Good information, thank you.  Can you confirm WMI, specifically

Wmi Namespace :  \root\ccm\Policy\Machine\ActualConfig

Class:  CCM_RemoteToolsConfig

Also, could you open a feedback item on Microsoft Connect ConfigMgr 2012 OpenBeta program for this issue?  Include a full set of log files.

June 11th, 2012 9:31pm

Eric,

I wasn't sure if you were just talking to Anders to open that feedback item or both of us.  I'm not going to submit anything till I know for sure, no sense in opening two items for the same thing unless that's what you want.  Also I'm assume you mean a full set of logs from the client PC, not the servers.

A little more information on the issue.  After digging around a bit more, and really I should have noticed this sooner, there seems to be some sort of self remediation that runs on the clients in the form of a scheduled task that executes a little after 12:00am every day.  Whatever runs during this task seems to fix the issue on most clients.  There have been a few were it hasn't.  I didn't have time today to look into it much further than that.

Free Windows Admin Tool Kit Click here and download it now
June 12th, 2012 1:32am

Yes, that schedule task is for the Client health remediation task, aka ccmeval.  This task runs daily by default.  If only after this task runs the client is working then that indicates something is wrong with the clients in the first place--there could be a couple of things.   I'd check the log files to see more information. 

Both of you can submit a feedback item.

June 12th, 2012 5:41pm

Eric,

I have created a feedback item on the connect site and uploaded a log set from a Win7 client with this issue.  I also used this account instead of my personal account to create the feedback tiicket.  Sorry if that causes any confusion.  I should have used this account from the start for this thread.

Free Windows Admin Tool Kit Click here and download it now
June 14th, 2012 7:47pm

Big Kudo's to JasonSTB for his assistance and opening a feedback item.  We have got root cause on the issue.  Let me explain.

If the Windows Firewall service is disabled the remote control service will fail to install because it cannot create the firewall exception rule. 

Thank you again JasonSTB for diligence with opening a feedback item and working with our beta support team.

June 21st, 2012 4:46pm

is there a workaround for this... On a number of clients we have deployed, they are not remotely accessible, even if we start the service, so some other component is failing. Do I need to rerun some installation in order to get the remote control functionality to work again..

Thanks..

Free Windows Admin Tool Kit Click here and download it now
November 11th, 2012 7:26am

I've just run into this same problem today.  I've got the SCCM2012 client installed and Remote Control is enabled in the default client settings.  But the Configuration Manager Remote Control service is Disabled.  If I manually enable it, it is immediately set to Disabled again.

Here is my CmRcService.log:

====== Starting service CmRcService ====== CmRcService 7/11/2013 1:11:25 PM 5676 (0x162C)
The ConfigMgr administrator has disabled the Remote Control feature for this machine, Remote Control Service will be disabled now. CmRcService 7/11/2013 1:11:30 PM 3224 (0x0C98)
The service has stopped. CmRcService 7/11/2013 1:11:30 PM 3224 (0x0C98)

I don't get it.. if it is enabled in the Default Client Settings, and I don't have any other Client Settings objects, where is it set to Disabled?

July 11th, 2013 6:15pm

I am having a similar problem to Jonathan Matthews.  Remote control policy is on, firewall is on, registry settings on the remote computer show the client is enabled, but the Configuration Manager Remote Control service disables itself and I get that message in CmRcService.log.

Help?

Free Windows Admin Tool Kit Click here and download it now
October 23rd, 2013 5:52pm

Hi,

As of today, I am also having the same issue as difuktonhowrad and Jonathan Matthews.

On SCCM 2012R2, with client parameters set to authorize my support team to remote control users workstation working just fine last week, I now have the same lines in CmRcService.log stating that I somehow disabled this feature.

On the services console, I see the service as disabled and even if I change that to manual and start the service, I reverts immediatly to Disabled.

Worst, I have a test group with its own client parameters (only differences are on schedules to get quick reaction and logging from those computers but remote control is strictly the same) which works just fine, I still can remote control those workstations (will keep my fingers crossed).

Has anyone some insights on that issue?

Thanks in advance.

April 7th, 2014 5:05pm

I got the same thing here as well.  I've also tried turning off the settings to change the domain firewall settings for remote control.  Is there a way to repair the 1000+ machines all ready deployed?  This worked in all the older versions as far as I know.
Free Windows Admin Tool Kit Click here and download it now
May 28th, 2014 3:51pm

I had the same issue, but only to discover that I forgot to deploy the client settings.
July 10th, 2014 7:36am

I had the same issue with CmRcService always being disabled. We ran "control smscfgrc" on one of the affected workstations to see if the certificate was signed...it was listed as "None". 

We removed the MP role on the SCCM server, restarted it then re-added the MP role. After another restart, all the clients began the CmRcService.exe process. We now have Remote Control capability on all the clients.

Free Windows Admin Tool Kit Click here and download it now
August 22nd, 2015 2:04pm

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics