REPORT VIEWER  DOES NOT RENDER CHARTS WHEN ASYNCRENDERING="TRUE"
CONFIGURATION- WINDOW SERVER 2003 IIS 6 VS-2010 REPORT VIEWER 8.0.0.0 REPORT VIEWER DOES NOT RENDER CHARTS WHEN ASYNCRENDERING="TRUE", IF I SET ASYNCRENDERING ="FALSE" THEN CHARTS APEARS PERFECTLY BUT IN OTHER REPORTS REPORT VIEWER SHOWS EXTRA WHITE SPACE ROW BETWEEN RECORDS OF DETAILS SECTION OF SSRS 2008 R2 REPORTS. THESE PROBLEMS OCCUR ONLY AFTER MIGRATION INTO FROM SSRS 2008 TO SSRS 2008 R2 REPORTS. EVEN IF I USE THE REPORT VIEWER 10.0.0.0 THE SAME PROBLEM FOR SPACING BETWEEN RECORDS IS EXISTS. I ALREADY SPENT LOT OF TIME ON THIS ISSUE BUT DID'NT FIND ANY SOLUTION SO, IF ANYONE HAS SOLUTION PLA REPLY ASAP...
April 19th, 2012 12:09am

Hi Devendra, According to your description, i have tested the issue in local environment, however, everything goes well. Could you elaborate the issue for further analysis? Do the reports display well on report server 2008 r2? Which version of internet explorer are you using? Whats the version of your visual studio 2010? There will be behavior changes after upgrading from SQL server 2008 to SQL server 2008 r2. The RDL 2008 reports will be upgraded to RDL 2008 r2 schema the first time you open them in business intelligence development studio or on the Report Server. If the reports render properly on the Report Server, it indicates that the reports are upgraded without problems. The AsyncRendering property determines whether the report is rendered asynchronously from the rest of the Web page when the Web page is being loaded. In Visual Studio 2010, after the report is rendered on page load, this AsyncRendering property no longer determines the report rendering behavior. By default, all subsequent report renderings are accomplished with AJAX partial-page updates through asynchronous postbacks, and changing this property has no effect. At this time, if you have installed Visual Studio 2010 Service Pack 1, I Suggest that you install the following hotfix for Report Viewer 2010 SP1 in your test environment: Update fixes several Report Viewer issues after you install Visual Studio 2010 Service Pack 1 In addition, I recommend that you check the issue using a different version of IE. If you are using IE9, you can try the Compatibility View mode. References: ReportViewer.AsyncRendering Property If you have any questions, please feel free to let me know. Regards, Mike Yin
Free Windows Admin Tool Kit Click here and download it now
April 20th, 2012 6:11am

Hi Mike, Thanks for reply, I have two servers one for reports and another one for application and application server has configurations as below : WINDOW SERVER 2003 IIS 6 REPORT VIEWER 8.0.0.0 VISUAL STUDIO 2010 I am testing from my machine which has following configurations and using remote environment: Window 7 IIS 7 REPORT VIEWER 8.0.0.0 VISUAL STUDIO 2010 For migration of reports first i opened in SQL server 2008 r2 environment and after succesfully runing in SQL server 2008 r2 environment then deploy on SQL server 2008 r2 report server, while its working fine on SQL server 2008 r2 Report Server but only in report viewer charts are not displaying while in export to pdf or excel everything goes well. but if i change the AsyncRendering =false then charts does render on report viewer but in other reports white spaces problem occur and if change the AsyncRendering =true then charts does not render on report viewer and in other reports white spaces problem goes off. If you have any questions, please feel free to let me know.
April 23rd, 2012 12:05am

Hi Devendra, Thanks for your posting. When we run the ReportViewer control in remote processing mode, the report is processed and rendered by the report server. Since the report works well on the SQL Server 2008 R2 report server, the current issue may be the ReportViewer control related. At this time, I suggest that you install the Microsoft Report Viewer 2010 first. You can download the ReportViewer 2010 package from the following website: http://www.microsoft.com/download/en/details.aspx?id=23691 In addition, if you have installed Visual Studio 2010 Service Pack 1 (KB983509), please install the hotfix for Microsoft Visual Studio 2010 SP1 Report Viewer from the link below: http://www.microsoft.com/download/en/details.aspx?id=27231 Hopes this helps. Regards, Mike Yin
Free Windows Admin Tool Kit Click here and download it now
April 25th, 2012 11:38am

Hi Devendra, Thanks for your posting. When we run the ReportViewer control in remote processing mode, the report is processed and rendered by the report server. Since the report works well on the SQL Server 2008 R2 report server, the current issue may be the ReportViewer control related. At this time, I suggest that you install the Microsoft Report Viewer 2010 first. You can download the ReportViewer 2010 package from the following website: http://www.microsoft.com/download/en/details.aspx?id=23691 In addition, if you have installed Visual Studio 2010 Service Pack 1 (KB983509), please install the hotfix for Microsoft Visual Studio 2010 SP1 Report Viewer from the link below: http://www.microsoft.com/download/en/details.aspx?id=27231 Hopes this helps. Regards, Mike Yin
April 25th, 2012 11:38am

Hi Mike, Thanks for your reply, As i already mentioned that in Report Viewer 2010 chart work fine in both cases of Asyncrendering=true as well as Asyncrendering=false, but space problem in other report does not go. i already try the Report Viewer 2010 there is no issue of chart in Report Viewer 2010. but space between rows in other reports is the problem in Report Viewer 2010. while in Report Viewer 2008 if i set Space After and Space Before property of report then this problem is resolved if Asyncrendering=true but chart not display . and if i set Asyncrendering=false then chart problem resolved but space problem does not resolved in Report Viewer 2008. but in Report Viewer 2010 space problem between rows still remain, there is no effect of Space After and Space Before property of Reports in both cases of Asyncrendering property.
Free Windows Admin Tool Kit Click here and download it now
April 25th, 2012 11:58pm

Hi Mike, Thanks for your reply, As i already mentioned that in Report Viewer 2010 chart work fine in both cases of Asyncrendering=true as well as Asyncrendering=false, but space problem in other report does not go. i already try the Report Viewer 2010 there is no issue of chart in Report Viewer 2010. but space between rows in other reports is the problem in Report Viewer 2010. while in Report Viewer 2008 if i set Space After and Space Before property of report then this problem is resolved if Asyncrendering=true but chart not display . and if i set Asyncrendering=false then chart problem resolved but space problem does not resolved in Report Viewer 2008. but in Report Viewer 2010 space problem between rows still remain, there is no effect of Space After and Space Before property of Reports in both cases of Asyncrendering property.
April 25th, 2012 11:58pm

CONFIGURATION- WINDOW SERVER 2003 IIS 6 VS-2010 REPORT VIEWER 8.0.0.0 REPORT VIEWER DOES NOT RENDER CHARTS WHEN ASYNCRENDERING="TRUE", IF I SET ASYNCRENDERING ="FALSE" THEN CHARTS APEARS PERFECTLY BUT IN OTHER REPORTS REPORT VIEWER SHOWS EXTRA WHITE SPACE ROW BETWEEN RECORDS OF DETAILS SECTION OF SSRS 2008 R2 REPORTS. THESE PROBLEMS OCCUR ONLY AFTER MIGRATION INTO FROM SSRS 2008 TO SSRS 2008 R2 REPORTS. EVEN IF I USE THE REPORT VIEWER 10.0.0.0 THE SAME PROBLEM FOR SPACING BETWEEN RECORDS IS EXISTS. I ALREADY SPENT LOT OF TIME ON THIS ISSUE BUT DID'NT FIND ANY SOLUTION SO, IF ANYONE HAS SOLUTION PLA REPLY ASAP...
Free Windows Admin Tool Kit Click here and download it now
May 23rd, 2012 11:11pm

Hi Devendra, Based on my research, I suggest that you add the partial-page rendering to the AJAX ScriptManager as follows: <asp:ScriptManager ID="ScriptManager1" runat="server" EnablePartialRendering="false" /> You can check the results after set the EnablePartialRendering property to false and true individually. Meanwhile, I suggest that you update the Reporting Services with SQL Server updates. For the details information about SQL Server versions, please see: http://sqlserverbuilds.blogspot.com/ Regards, Mike Yin
May 24th, 2012 12:09am

Hi Mike, I don't have any ScriptManager on the page , but i did try with ScriptManager also with EnablePartialRendering="false" and EnablePartialRendering="true" , it does not have any impact on the report.
Free Windows Admin Tool Kit Click here and download it now
May 24th, 2012 4:44am

Hi Mike, The issue which i have found behind the chart not showing is that, if we keep the chart inside thae Matrix then chart does not display on the Report Viewer and if we keep outside the Matrix then chart display. So, can u help me actually what the reason behind this why chart does not dispaly inside matrix in SSRS 2008 R2 while same thing is working in SSRS 2008 R1.
May 24th, 2012 4:47am

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics