Problems with use SharePoint and SSRS 2008 R2
Hi guys, I'm installing an environment using the SharePoint 2010 and SSRS2008 in integrated mode. My environmnet have 2 servers 1. Server x have the SharePoint Farm Installed 2. Server y have the SQL 2008 R2 installed. (I install in this server the SharePoint 2010 on the same farm that the server x) All installed with success, I created the Document Library and set to show in menu the Report Builder, Report Data Source and Report Builder Model, but when I try to use appear a authentication window i input my domain user and password but nothing occrurs. ( My user is adminstrator in the two servers and i set all to use my user credential (To SQL Servers and Share Point Server)) Only to specified more follow some configuration and Troubleshoot details: - SSRS: Access the Webservice Url: By IP or Name in Server x or Server y = OK (After i provide my credentials in window authentication) - Share Point: General Application Services > Reporting Services > Reporting Services Integration Database Access = ok WSS_WPG = ok Reporting Services Activation State = ok - Share Point > Site Actions > Reporting Services > Reporting Services Site Settings = Error HTTP 401 Unauthorazed -Share Point > Librare (report) > Documents Menu > Report Builder Report > Windows Security Pop-up Resquest user and Password i put my credentials 3 times and nothing occurs (the site is redirect to: http://x:2020/_vti_bin/ReportBuilder/ReportBuilder_3_0_0_0.application?SaveLocation=http%3a%2f%2fx%3a2020%2fReports) In SharePoint Log i have the follow line: Share Point Log: 11/30/2010 15:00:53.00 w3wp.exe (0x130C) 0x13BC SQL Server Reporting Services HTTP Redirector aaaf High A WebException occured System.Net.WebException: The remote server returned an error: (401) Unauthorized. at System.Net.HttpWebRequest.EndGetResponse(IAsyncResult asyncResult) at Microsoft.ReportingServices.SharePoint.Soap.RSBaseHttpHandler.AsyncGetResponse(HttpWebRequest request, HttpContext context) at Microsoft.ReportingServices.SharePoint.Soap.RSBaseHttpHandler.ProcessRequest(HttpContext context) 12f19924-3f70-46d9-9616-3c8223efa1ef Somebody have any Idea about it? Thanks all!
November 30th, 2010 12:31pm

Hi gcardoso, In your production environment, you must use kerberos authentication, which is the solution to this issue. To know more information about how to configure kerberos authentication, see http://blogs.technet.com/b/tothesharepoint/archive/2010/07/22/whitepaper-configuring-kerberos-authentication-for-sharepoint-2010-and-sql-server-2008-r2-products.aspx . thanks, Jerry
Free Windows Admin Tool Kit Click here and download it now
December 7th, 2010 12:55am

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics