Problem with installing Workflow Services
After installing Workflowmanager I tried to execute the following command: To configure Workflow Manager on a server that is part of the SharePoint 2013 farm and on which communication takes place by using HTTP Log on to the computer in the SharePoint Server 2013 farm where Workflow Manager was installed. Open the SharePoint Management Shell as an administrator. This is accomplished by right-clicking the SharePoint 2013 Management Shell and choosing Run as administrator. Run the Register-SPWorkflowService cmdlet. Example: Register-SPWorkflowService SPSite "http://myserver/mysitecollection" WorkflowHostUri "" AllowOAuthHttp I got the following error message: PS C:\Users\p15farm> Register-SPWorkflowService -SPSite "http://project2013/" -W orkflowHostUri "http://project2013:12291" -AllowOAuthHttp Register-SPWorkflowService : Could not load file or assembly 'Microsoft.Workflow.Client, Version=, Culture=neutral, PublicKeyToken=31bf3856ad364e35' or one of its dependencies. The system cannot find the file specified. At line:1 char:1 + Register-SPWorkflowService -SPSite "http://project2013/" -WorkflowHostUri "http: ... + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ ~~~ + CategoryInfo : InvalidData: (Microsoft.Share...WorkflowService: RegisterSPWorkflowService) [Register-SPWorkflowService], FileNotFoundExcep tion + FullyQualifiedErrorId : Microsoft.SharePoint.WorkflowServices.PowerShell .RegisterSPWorkflowService Can you help me please
November 12th, 2012 4:49am

If you have the Office Tools for VS2012 RTM Preview installed on the SharePoint box, then you might try uninstalling this feature temporarily and then try the command again. Once you get the workflow service registered, you can reinstall the Office Tools. This solution worked for me when I ran into this error. Tom Brownell, MCTS, MCPD SharePoint 2010 EDIT: Just found this post which may be a solution also:
Free Windows Admin Tool Kit Click here and download it now
November 12th, 2012 10:43am

make sure you don't have any preview/beta of workflow manger, workflow client, SharePoint 2013 and visual studio 2012 tool for sharepoint. Preview/beta doesn't play nice together with rtm.
November 14th, 2012 2:30pm

Thank you dealkk, you are completely right. I found out, that the official downloadversion of Workflow manager was a beta file. I found this link which provided the RTM: Now everything is working fine.
Free Windows Admin Tool Kit Click here and download it now
November 15th, 2012 4:24am

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics