Problem with install Reporting Services 2008
Hello I'm configuring a new installation of SQL Server 2008 Express with Advanced Services, but the Reporting Services doesn't work. When I open the page http://localhost/ReportServer, show the HTTP 500 Internal Server Error. At the first time the error was: Failed to initialize the AppDomain:ReportServer_MSSQLSERVER_0 Exception: System.Web.HttpException Message: The current identity (NT AUTHORITY\NETWORK SERVICE) does not have write access to 'C:\Windows\Microsoft.NET\Framework64\v2.0.50727\Temporary ASP.NET Files'. I fixed this error givin permissions to Network Service to this directory. (http://technet.microsoft.com/en-us/library/bb418935.aspx) But now show this message: Failed to initialize the AppDomain:ReportServer_MSSQLSERVER_0 Exception: System.Configuration.ConfigurationErrorsException Message: Unrecognized element 'folderLevelBuildProviders'. (C:\Windows\Microsoft.NET\Framework64\v2.0.50727\Config\web.config line 349) StackTrace: at System.Web.HttpRuntime.HostingInit(HostingEnvironmentFlags hostingFlags) at System.Web.Hosting.HostingEnvironment.Initialize(ApplicationManager appManager, IApplicationHost appHost, IConfigMapPathFactory configMapPathFactory, HostingEnvironmentParameters hostingParameters) at System.Web.Hosting.HostingEnvironment.Initialize(ApplicationManager appManager, IApplicationHost appHost, IConfigMapPathFactory configMapPathFactory, HostingEnvironmentParameters hostingParameters) at System.Web.Hosting.ApplicationManager.CreateAppDomainWithHostingEnvironment(String appId, IApplicationHost appHost, HostingEnvironmentParameters hostingParameters) at System.Web.Hosting.ApplicationManager.CreateAppDomainWithHostingEnvironmentAndReportErrors(String appId, IApplicationHost appHost, HostingEnvironmentParameters hostingParameters) I searched by folderLevelBuildProviders but I not find anything. Anyone have one idea about this error? Thank You. Bye
November 2nd, 2010 12:54pm

Can you try running reporting services under a domain account which is permissioned on the server where you are trying to install reporting services.
Free Windows Admin Tool Kit Click here and download it now
November 2nd, 2010 1:10pm

Hello Vikran I'm using administrator account. I have another installation of SQL Server 2008 in a Windows Server 2003 and the reporting services work fine. I can open the ReportServer directly by server IP for all domains. Monitoring the event viewer I can see: - Service started successfully. - RSReportServer.config (alert) - Failed to initialize the AppDomain:ReportServer_MSSQLSERVER_0 Exception: System.Configuration.ConfigurationErrorsException Message: Unrecognized element 'folderLevelBuildProviders'. I'm using Windows Server 2008 64 bits and the asp.net v2.0.50727 also 64 bits. Does not have any application pool in the IIS of the reporting services. It is correct? Thank you.
November 2nd, 2010 1:41pm

Just so you know RS 2008 does not uses IIS anymore so thats why you do not see any application pools for it. Not sure why you are getting the ASP.Net error though.
Free Windows Admin Tool Kit Click here and download it now
November 2nd, 2010 4:28pm

Hello Vikram I try to remove the SQL Server for a complete reinstall, but I can't uninstall the SQL Server. I install using one fix to error (installshareddir), but now, on uninstall this error remains. You see any error similar or have any idea about how to fix this? Thank you
November 12th, 2010 2:22pm

I think best to raise a support request with MS if you are facing these kind of issues.
Free Windows Admin Tool Kit Click here and download it now
November 18th, 2010 4:19am

I've got the same issue. Problem was with .Net Framework I was trying to figure it out for couple of hours, but was not able, then I've tried this: 1) Backup Encryption Keys of RS. 2) Go to folder C:\Windows\Microsoft.NET\Framework64\v2.0.50727\CONFIG 3) Make a copy of current web.config 4) Rewrite web.config with web.config.default 5) Restart Reporting Services. 6) If you will get any errors regarding encryption keys (I got) try to restore encryptions keys. Should start to work.Nakladal
October 30th, 2012 9:06am

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics