Problem with flashing bios and automatic reboot

Environment: Windows 7 + MDT 2013

Dear all,

I have a problem which I hope you can help me.

In my applications deployment process, I have one for the Flash Bios Update which run the following command: 
afuwin.exe imageFE.rom /p /n /r /sp /b /defans /capsule

The problem is that the computer restart automatically. Once restarted, a popup window ask me if it's a new deployment or not.

How can I avoid either the flash bios restarting automatically (there isn't any /norestart command available) or the popup window being displayed?

Thanks in advance for your help,


May 29th, 2015 6:16am

Hi, I can't test this myself, but what I remember of afuwin.exe is that /Q is needed for a silent install without a reboot or shutdown at the end.
I assume you have made an application of this? Make sure to mark the checkbox "Reboot the computer after installing this application" on the details tab. The system will do the reboot and not ask you if it's a new deployment.

Hope it helps,

Leon

ps. I would personally do the bios update in the Windows PE phase before the installation of Windows :)

Free Windows Admin Tool Kit Click here and download it now
May 29th, 2015 7:05am

Hi,

Thank you for your answer.

I tested with and without /Q switch. The computer restart automatically with and without the switch /Q. The difference is that you can see what is going on without the /Q switch, so I prefer that way.

Yes, I did create an application but the checkbox "Reboot..." doesn't really help because the /Q switch doesn't avoid the reboot.

I don't know how to implement that update in the Windows PE phase for all my deployments. Actually, we have 3 sites, with 7 people working on it and with lots of images to deploy. I need a "mandatory" global solution.

May 29th, 2015 7:56am

You could use this Final Configuration script http://deploymentresearch.com/Research/Post/427/Final-Configuration-for-MDT-2013-Lite-Touch-now-with-Autologon-support

But if you're using BitLocker and then flash the BIOS you'll trip the system to prompt for the key after it reboots. If there's no way to keep the utility from rebooting and you want to run it before the BDE protectors are enabled, you're out of luck.

If you use the script just replace the shutdown portion with the code you need to run your file. Something like

' Reboot the client
	StatusArea.InnerHTML=StatusArea.InnerHTML & "<BR>" & "Configuration Complete, rebooting client in 30 seconds... "
	oShell.run "\\PATH\Share\afuwin.exe imageFE.rom /p /n /r /sp /b /defans /capsule",1,False

I'm not 100% sure it'll will work so you'd have to test it.

Free Windows Admin Tool Kit Click here and download it now
May 29th, 2015 7:04pm

Hi Dan_Vega,

Thank you so much for your email.

I've tried your suggestion but I have a little problem, the following command:

' Reboot the client
StatusArea.InnerHTML=StatusArea.InnerHTML & "<BR>" & "Configuration Complete, rebooting client in 30 seconds... "
'oShell.run "shutdown /f /r /t 30",1,False
' Flash M93z BIOS
oShell.Run("C:\Users\Administrator\Desktop\FEKT91AUS\Flash.cmd"),1,False

doesn't seems to run. It's like be ignored, I don't understand why.

June 2nd, 2015 3:21am

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics