Office 2013 - "Server Versions could not be retrieved"

Hi all,

is there a reason why in case of spaces in the site url the previous versions of office documents could not be retrieved in the corresponding office program under file?

It all works fine with a site that does not have spaces in the url. When renaming the site (with blank in url) it only comes up with the message "Server versions could not be retrieved".

Backstage Area without blanks in the URL

Backstage area with blanks inside the URL:

System: SharePoint 2010 Version: 14.0.7108.5000

Office 2013 Version: 15.0.4551.1509 MSO 15.0.4551.1007 32bit

Thanks for any help!


  • Edited by fluxxer Friday, February 21, 2014 6:59 AM
February 20th, 2014 8:31am

Hi fluxxer,

According to your description, my understanding is that you got an error when you used Office 2013 to open the document in a library at SharePoint 2010 site whose url contained the spaces.

I did a test as the followings:

  1. Open a site and create a new subsite named testforblank, the url is http://sp:3878/testforblank/
  2. Then upload some word and excel files to SharedDcoument library in the subsite
  3. Then open these files with Office 2013, everything was fine
  4. Change the URl to http://sp:3878/test for blank/
  5. Open these files with Office 2013, everything also was fine
  6. Then I created a new subsite , the url is http://sp:3878/test blank/
  7. Reproduced the step 2-3, everything was fine

Please clear the data cache:

  1. IE: Internet Options->Delete browsing history on exit
  2. Office: Office 2013 Upload Center, select All Cached Files after Refresh, then click on Action->Discard

After clearing data cache, test it again, compare the result.

I hope this helps.

Thanks,

Wendy

Forum Support
Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.co

February 21st, 2014 3:05am

Hi Wendy,

thanks for the answer. The problem is not that the document dosn't open. The problem is that the version history of the document is not shown in the backstage area of Word/Excel.

I will add some screenshots to my post to clarify the Problem.

Thanks!

February 21st, 2014 6:57am

Hi fluxxer,

I did a test for this issue:

  1. SharePoint 2010 and Office 2010, open documents (the url of the site contained a blank), the Versions and Check out was fine.
  2. SharePoint 2010 and Office 2013, open documents (the url of the site contained a blank), the Versions and Check out didn't work well.
  3. SharePoint 2013 and Office 2013, open documents(the url of the site contained a blank), the Versions and Check out was fine.

So, it may be related SharePoint 2010, please try to install the latest CU for SharePoint 2010, compare the result.

Thanks,

Wendy

 Forum Support
Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

Free Windows Admin Tool Kit Click here and download it now
February 24th, 2014 2:11am

Hi Wendy,

as imagined the problem was not fixed with the update to the current CU(February 2014).

Do you have any other suggestions?

The next step would be to create a ticket....

Thanks!

February 24th, 2014 1:30pm

Was this ever resolved ? and how ?
Free Windows Admin Tool Kit Click here and download it now
July 21st, 2015 11:00pm

Yes and No!

I have created a support case with Microsoft. After long discussions they have been able to reproduce  the described failure and it was accepted as a bug in this special constellation.

After that we have created a business impact. Based on that Business impact calculation the product group decided, that there is no need to create a hotfix or something else to get that working.

MS Service Request ID:  114072411646088

July 22nd, 2015 1:58am

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics