Office365: Sharepoint 2013 workflow "CreateListItem" in another list doesnt start workflow

So i have a similar situation described here:

http://sharepoint.stackexchange.com/questions/72818/create-item-task-does-not-initiate-on-creation-workflow-in-target-list

I have two lists (A & B).

I have 2 SharePoint 2013 Visual Studio Workflows on Office365. A Createlistitem activity in list A creates a new item in list B which should start the workflow in list B

This has nothing to do with System accounts etc as this is SharePoint Online and I have checked that the item created by List A in List B is in fact created with the user credentials which created the initial workflow on List A.

I have checked this post here, but it is not the same issue as its an on prem solution.

August 21st, 2013 3:17am

Hi,

Base on the description, you have two SharePoint 2013 Visual Studio Workflows on Office365 and you want the Createlistitem activity in list A to start the workflow in list B.

To trigger workflow to run when new item is added, we need to create an Event Receiver that starts the workflow once the Createlistitem activity in list A creates a new item in list B.

More information:

How to: Create an Event Receiver: http://msdn.microsoft.com/en-us/library/ee231563.aspx

Best Regards,

Linda Li

Free Windows Admin Tool Kit Click here and download it now
August 27th, 2013 8:57am

Hi Linda,

That shouldnt be the case. If a workflow in List B is triggered to run on item created, when an item is created in that list, it should run... regardless if a user creates it or a workflow creates it.

August 30th, 2013 2:02am

Hi,

An event receiver is a piece of managed code that responds to SharePoint events when specific triggering actions occur on a SharePoint object. Triggering actions include activities such as adding, updating, deleting, moving, checking in, and checking out.

We  can create an event receiver definition called ItemAdded that uses and overrides methods on the SPItemEventReceiver base class. We use this base class because we want to capture events that are raised when items have been added to a list. This event is fired every time we make a change and save list item.

Regardless if a user creates it or a workflow creates it, the list instance event receiver responds to events that occur in any instance of a list definition, then the workflow in List B will be triggered.

Best Regards,

Linda Li

Free Windows Admin Tool Kit Click here and download it now
August 30th, 2013 4:27am

Hi Linda Li,

Im fully aware of what event receivers do, but why should i have to build an event receiver to trigger a workflow if the workflow is set to run "on item created"??

August 30th, 2013 4:41am

Hi Courtenay,

Did you ever resolve this? I'm experiencing the same thing; the workflow doesn't launch on the destination list.

Thanks!

Free Windows Admin Tool Kit Click here and download it now
September 11th, 2013 5:25pm

I found the answer here: http://social.technet.microsoft.com/Forums/en-US/6ee7d704-34c0-4bda-8f2d-8a9ba17c2367/sharepoint-2013-workflow-using-create-item-to-add-an-item-to-another-list-and-have-the-workflow

Unfortunately 2013 Workflow doesn't support this directly. 

September 11th, 2013 7:09pm

Incorrect. I have an open support ticket with Microsoft on this one. Ill get back to you when i have an answer
Free Windows Admin Tool Kit Click here and download it now
September 12th, 2013 4:16am

Hi Courtenay, have you heard anything back from Microsoft yet around the logged call around the workflow not triggering on the secondary list? 

Do you have a Bug # or Case Number so I can also ask internally as to the progress as I( have an urgent requirement for this functionality, and do not want to resort to custom event listeners.

October 9th, 2013 5:33pm

Hi Courtney,

Can you please confirm if you have heard  anything back from Microsoft?

Is there a Bug / Case Number?

Thanks.

Free Windows Admin Tool Kit Click here and download it now
October 20th, 2013 8:29am

I am running in exactly the same issue. Wondering if the issue has been solved or a solution has been found. Thank you
January 28th, 2014 3:04am

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics