Object reference not set to an instance of an object.    at Microsoft.Office.Server.Administra tion.UserProfileApplicationProxy.

Hello.

 

I just installed a new farm, the wizard was succesfull in all steps.  However when I try to load the default site it created I got this exception.

 

Any idea?

 

System.NullReferenceException: Object reference not set to an instance of an object.    at Microsoft.Office.Server.Administration.UserProfileApplicationProxy.get_ApplicationProperties()     at Microsoft.Office.Server.Administration.UserProfileApplicationProxy.get_PartitionIDs()     at Microsoft.Office.Server.Administration.UserProfileApplicationProxy.IsAvailable(SPServiceContext serviceContext)     at Microsoft.Office.Server.WebControls.MyLinksRibbon.get_PortalAvailable()     at Microsoft.Office.Server.WebControls.MyLinksRibbon.EnsureMySiteUrls()     at Microsoft.Office.Server.WebControls.MyLinksRibbon.get_PortalMySiteUrlAvailable()     at Microsoft.Office.Server.WebControls.MyLinksRibbon.OnLoad(EventArgs e)     at System.Web.UI.Control.LoadRecursive()     at System.Web.UI.Control.LoadRecu...

September 26th, 2011 11:29am

I tried removing the user profile service application and creating it again, when I did that, and tried to navigate to the page to manager the user profile application it shows me an exception

 

According to the uls log viewer its;

Microsoft.Office.Server.UserProfiles.UserProfileApplicationNotAvailableException: This User Profile Application's connection is currently not available. The Application Pool or User Profile Service may not have been started. Please contact your administrator.    at Microsoft.SharePoint.Portal.UserProfiles.AdminUI.ProfileAdminPage.get_CurrentApplicationProxy()     at Microsoft.SharePoint.Portal.UserProfiles.AdminUI.ProfileAdminPage.IsProfileSynchronizationRunning()     at Microsoft.SharePoint.Portal.WebControls.UserProfileServiceImportStatisticsWebPart.RenderSectionContents(HtmlTextWriter writer)     at Microsoft.SharePoint.Portal.WebControls.UserProfileServiceImportStatisticsWebPart.RenderWebPart(HtmlTextWriter writer)     at Microsoft.SharePoint.WebPartPages.WebPart.Render(HtmlTextWriter ...

 

I checked and the sharepoint web services default was stopped, I started and still the same error,  that pool is under Local Service account.

 

Free Windows Admin Tool Kit Click here and download it now
September 26th, 2011 11:39am

Trying to deep, I went to this service:

http://localhost:32843/8a702dc5f8744143b01f9e0e38bd35ad/ProfilePropertyService.svc

 

and I got

The server was unable to process the request due to an internal error. For more information about the error, either turn on IncludeExceptionDetailInFaults (either from ServiceBehaviorAttribute or from the <serviceDebug> configuration behavior) on the server in order to send the exception information back to the client, or turn on tracing as per the Microsoft .NET Framework 3.0 SDK documentation and inspect the server trace logs.

September 26th, 2011 11:41am

I was able to fix it my self, after a little research I found this had to be done:

 

  • Expand “Sites”
  • Expand “SharePoint Web Services” and select “SecurityTokenServiceApplication”
  • Double click on “Authentication”(under IIS)
  • Disable “Forms Authentication” and ASP.NET impersonation 
  • Confirm that only Windows and Anonymous Authentication are enabled
  • IISRESET 

 

Actually the cause of the problem was on the user token service web service and not in the user profile, but as many applications use that service to issue security token, I suppose that was the problem.

 

Free Windows Admin Tool Kit Click here and download it now
September 26th, 2011 11:47am

This is not working for me and my applications are on classic mode. so its not about token!

Any help?

September 26th, 2011 1:42pm

is the application pool started?

 

Did you tried removing the UPA and adding it again?

Did you surf to the token web service and was it working?

 the same for the User Profile Property web service ? Did it work?

 

If the answer is yes to all, then I have no idea :)

Free Windows Admin Tool Kit Click here and download it now
September 26th, 2011 1:56pm

what worked for me is to reset the application pool account for tokenservice
September 30th, 2011 11:34am

Thanks alot. I followed your instructions and my problem is solved.

Just an FYI,

I have Sharepoint2010 hosted on my development box which is Win 7 64 bit.

 

Aleem

Free Windows Admin Tool Kit Click here and download it now
October 13th, 2011 6:18pm

Ensure that Application pool account has full privileges.
February 29th, 2012 8:42am

And before doing too much work around, check if the SecurityTokenServiceApplication  Pool is running under right account.. then iisrest !!! i hope this helps.
Free Windows Admin Tool Kit Click here and download it now
April 24th, 2012 11:39pm

I had similar issue, following article pointed me towards the right direction

http://www.grishbi.com/2015/04/sharepoint-2010-an-unexpected-error-has-occurred/

April 2nd, 2015 8:42pm

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics