Not able to install MP role in SCCM secondary site
Hi Team, WE have successfully installed secondary server and just trying to install MP role from primary server. When installing, we are getting the below event in the Event Viewer of secondary server. Below are the snap from MPsetup.log <03-14-2012 23:08:46> Installing G:\SCCM\bin\i386\mp.msi CCMINSTALLDIR="G:\SMS_CCM" CCMSERVERDATAROOT="G:\SCCM" USESMSPORTS=TRUE SMSPORTS=80 USESMSSSLPORTS=TRUE SMSSSLPORTS=443 USESMSSSL=TRUE SMSSSLSTATE=0 CCMENABLELOGGING=TRUE CCMLOGLEVEL=1 CCMLOGMAXSIZE=1000000 CCMLOGMAXHISTORY=1 <03-14-2012 23:09:05> mp.msi exited with return code: 1603 <03-14-2012 23:09:05> Backing up G:\SCCM\logs\mpMSI.log to G:\SCCM\logs\mpMSI.log.LastError <03-14-2012 23:09:05> Fatal MSI Error - mp.msi could not be installed. When installing, we are getting the below event in the Event Viewer of secondary server. Source : MsiInstaller Event ID : 10005 Product: SMS Management Point -- Error 25001. Setup failed due to unexpected circumstances The error code is 80040154 Please help me to resolev the issue. Thanks in Advance. Thanks & Regards, Dinesh
March 15th, 2012 2:13am

Is this something related to MSXML compoenent? Have you checked mpMSI.log.LastError file? Otherwise, you can go through the following KB article it's not very related but just in case . http://support.microsoft.com/default.aspx?scid=kb;en-us;2419559&sd=rss&spid=12769Anoop C Nair - @anoopmannur MY BLOG: http://anoopmannur.wordpress.com User Group: ConfigMgr Professionals This posting is provided AS-IS with no warranties/guarantees and confers no rights.
Free Windows Admin Tool Kit Click here and download it now
March 15th, 2012 2:53am

Hi Anoop, Thanks for your reply. I dont think so, that this issue is related to MSXML. . I have reinstalled IIS and BITS as well. I have checked the mpMSI.log.LastError file and i am seeing few errors. Below is the error. Property(S): SmsDetectColocationDowngrade_ErrorMessage = A newer version of the Configuration Manager Client is installed. Cannot continue installing this version of the management point. But i dont have any SCCM client installed in the server. Do we have any workaround to solve this issue ? Many Thanks, DInesh Thanks & Regards, Dinesh
March 15th, 2012 3:02am

try to run ccmclean.exe on the server (I know, it's not supported but will work)Anoop C Nair - @anoopmannur MY BLOG: http://anoopmannur.wordpress.com User Group: ConfigMgr Professionals This posting is provided AS-IS with no warranties/guarantees and confers no rights.
Free Windows Admin Tool Kit Click here and download it now
March 15th, 2012 3:04am

Yes, i have tried that too. but no improvement. Still getting the same error :( Thanks & Regards, Dinesh
March 15th, 2012 3:09am

can you check for some other errors in the log? Webdav is enabled ?Anoop C Nair - @anoopmannur MY BLOG: http://anoopmannur.wordpress.com User Group: ConfigMgr Professionals This posting is provided AS-IS with no warranties/guarantees and confers no rights.
Free Windows Admin Tool Kit Click here and download it now
March 15th, 2012 3:13am

NO more errors.. Below are few lines, where it says Setup aborted. Property(S): FilesInUse_Info = Setup has detected that it needs to update some files that are currently in use by other processes. To prevent having to reboot the machine, please close the following applications: Property(S): DefaultUIFont = DefaultDlgFont Property(S): DialogBox_Title = SMS Management Point Setup Property(S): WelcomeDialog_Info = This will install the Systems Management Server Management Point. Property(S): InstallDialog_Title = Install Property(S): InstallDialog_SubTitle = The product is now ready to install Property(S): InstallDialog_Info = Click Next to proceed. Property(S): ProgressDialog_Title = Please Wait Property(S): ProgressDialog_SubTitle = Setup is configuring your system. Property(S): CompleteDialog_Title = Setup Complete Property(S): CompleteDialog_SubTitle = Setup has finished updating your system. Property(S): CompleteDialog_Info = Setup was successful. Property(S): UserExitDialog_Title = Setup Aborted Property(S): UserExitDialog_SubTitle = Setup was cancelled Property(S): UserExitDialog_Info = The SMS Management Point setup was cancelled. Property(S): InstallErrorDialog_Title = Setup Aborted Property(S): InstallErrorDialog_SubTitle = Setup failedThanks & Regards, Dinesh
March 15th, 2012 3:22am

Any luck after restaring ?Anoop C Nair - @anoopmannur MY BLOG: http://anoopmannur.wordpress.com User Group: ConfigMgr Professionals This posting is provided AS-IS with no warranties/guarantees and confers no rights.
Free Windows Admin Tool Kit Click here and download it now
March 15th, 2012 3:29am

No luck, even after restarting ...Thanks & Regards, Dinesh
March 15th, 2012 3:41am

You listed msi properties only (Property(S)). They do not indicate an error at all (they are just listing properties). Search for 'return value 3' in the logfile. The actual error should be listed a few lines above it.Torsten Meringer | http://www.mssccmfaq.de
Free Windows Admin Tool Kit Click here and download it now
March 15th, 2012 7:59am

Hi Try removing BITS feature in Server Manager, restart. Add it again. And wait for Management Point role to reinstall or trigger it the Service Site Componente Manager inside the Console. Monitor MPSetup.log and MPMSI.log to get and Successfull install. Did the trick at least on one simular problem I just had. Nicolai
March 19th, 2012 7:30am

I see you flagged anoop's suggestion regarding WebDAV as the answer. Was it indeed related to webDAV? Please provide details? Thanks.
Free Windows Admin Tool Kit Click here and download it now
April 13th, 2012 2:15pm

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics