Meeting Workspace Multipage: Add Pages Not Visible By Users - how to force check-in?
Used out of box MOSS2007 Meeting Workspace Multipgae option. Added pages/"tabs" at top of workspace. Pages/tabs visible to me but not my users. Open site in SharePoint Designer (SPD) and see new pages I added are checked out. When right click to check-back-in SPD tells me can't do it? How do I force check-in of these pages?
January 29th, 2009 1:49am

Moving to Admin. It's not an SPD problem - SPD is just telling you what the problem is (not checked in). WSS FAQ sites: WSS 2.0: http://wssv2faq.mindsharp.com WSS 3.0 and MOSS 2007: http://wssv3faq.mindsharp.com Total list of WSS 3.0 and MOSS 2007 Books (including foreign language titles) http://wss.asaris.de/sites/walsh/Lists/WSSv3%20FAQ/V%20Books.aspx
Free Windows Admin Tool Kit Click here and download it now
January 29th, 2009 8:41am

Hello, Please check it via the following steps: 1. Open SharePoint Designer. 2. In the tree folder list on the left, right-click the page that other users cannot see. 3. Select Properties and switch to Security tab. 4. Click the link Manage permissions using the browser 5. Check the permissions and give proper permission to other users. 6. Check if other users could see the page or not. Please give it a try and let us know the result. Thanks. Best Regards, Lionel
February 3rd, 2009 10:55am

I have the exact same issue with a Meeting Workspace in WSS 3.0 (added Pages (aka tabs), but they are invisible to other users because they are checked out to me.)Your solution gets me to the Permissions page for Workspace Pages. But the users' permissions is not the problem. The problem is that when I make the new page, it is Checked Out to me by default, and there is no Checked In version, so others cannot see the page/tab. I don't see any way to check it in via the web interface, and in SPD, right-clicking and selecting Check In on the page results in "Cannot perform this operation. The file is no longer checked out or has been deleted."How can I Check In this page so others can use it?
Free Windows Admin Tool Kit Click here and download it now
March 5th, 2009 11:37pm

Fixed. The only solution I could find:In SPD (in the folder list), right-click on the page (the one representing the tab--the one that is checked out and cannot be checked in), and select Copy. Then right-click on the Workspace Pages folder the select Paste. The duplicated page will get a new name and will not be checked out. Then delete the problematic page.
March 6th, 2009 1:05am

I am also experiencing this problem all of a sudden. I discovered the copy method but this is an unacceptable solution, as I am not the only one who creates pages on meeting sites. I want to know how to really fix this. I never had this problem before
Free Windows Admin Tool Kit Click here and download it now
April 22nd, 2009 8:57pm

Did you ever get resolution to this issue? Copying is also unacceptable for my site. What is the true fix?Thanks.
May 29th, 2009 6:19pm

Did anyone find an answer for this issue. I am experiencing the same issue and cannot solve it. I did find the following behavior:- When creating a new site collection and creating a Meeting Workspace in this site collection, it does work fine.- When I create a new Meeting Workspace in the existing site collection, that workspace also experiences the same issue. I can create a new page, which is only visible to me. Via SPD I see that the page is checked out, but I cannot check the page in.
Free Windows Admin Tool Kit Click here and download it now
June 2nd, 2009 4:08pm

Yorick, I too am having the same problem with just one site collection...the problem exists in any newly created meeting workspace....Unable to recreate the problem in another site collection...Tabs are visible to only the person creating them...Pages are only visible to the creator from within designer and are checked out...Right-click and select Check in, and I get "Cannot perform this operation. The file is no longer checked out or has been deleted."We believe the problem is related to permissions when the publishing feature is turned on...Also noticed the site / system master pages invalid for this site...Not sure if it's related though....Hoping a fix will be posted soon...
June 2nd, 2009 5:45pm

Hi Tman22, I also thought that the publishing feature was causing this issue, but after checking the activated solutions both site collections had the Publishing Infrastructure feature activated and the sites themselves had exactly the same features activates. One thing I did notice was that the site collection that was broken did have some hidden features of the CKS Enhanced Wiki activated. Do you have this solution installed? And if so are these features also activated on your environment? You can check hidden features using the stsadm commands of Gary Lapointe (stsadm.blogspot.com and use the operation gl-enumfeatures including -showhiddenafter installing).
Free Windows Admin Tool Kit Click here and download it now
June 2nd, 2009 5:51pm

Yorick, just checked with our farm admin who stated we do not have the CKS Enhanced Wiki solution installed. I am escalatingmy ticket up to my local SP lead engineer and will repost if a solution is found on my end.
June 2nd, 2009 9:18pm

Yorick, just checked with our farm admin who stated we do not have the CKS Enhanced Wiki solution installed. I am escalatingmy ticket up to my local SP lead engineer and will repost if a solution is found on my end. Hi Tman22, I was able to resolve the issue. Description of the issue========================1.When a user creates/Adds a page in Multipage meeting workspace, the page gets automatically checked out to the user and other users cannot view it. This is in all case including admins You cannot even checkin the page through SPD and from Site Actions>Site settings>content and structure views options as well. Resolution==========1.Open the problematic meeting workspace in SPD, go to the properties of Pages(workspace pages)> settings and uncheck hide from browsers and click ok. 2.Now go the All Site content of the meeting workspace site, and you'll be able to see Workspace pages. 3.Go to the settings of this Workspace pages and under columns you'll find Title column set to as required. 4.Change the settings to not required and save it. Now if a user creates/adds pages in the workspace, all of the users would be able to view it. 5.For pages which are already checked out, every individual user (to whom the page is checked out) has to checkin the page manually so that others can view it as well. 6.To checkin pages admins can use SPD and an end user can do it from Site Actions>Site settings>content and structure > change the default view to pages checked out to me view and then checkin the checked out page. This time it will work perfectly :) Hope this works for you as well :) Susmit
Free Windows Admin Tool Kit Click here and download it now
June 12th, 2009 4:44pm

Susmit, I've been having the same problem for the past two days. Thank you for your post - this resolved the issue of the documents being checked out to me. Thanks to all.
March 29th, 2011 11:38am

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics