Management Point created using Powershell will error CM Console when viewing properties


We have an established ConfigMgr 2012 R2 CU3 environment with several Primaries and management points already active. These were all installed manually using the CM Console.

I am now trying to add additional Management Points using Powershell using the command:

Add-CMManagementPoint -enablessl -sitecode "ABC" -sitesystemservername "" -allowdevice -clientconnectiontype internetandintranet -generatealert -verbose
  • The PS completes without error, the MPSetup.log and MPControl.log indicate all is well once the setup completes
  • The MP appears as a component under the Server when viewing in the console
  • The IIS logs show clients communicating fine and the CM component Status monitor is all green with no errors showing in the status message
  • A Get-CMManagementPoint returns fine showing all the same details as other working MP's

However if I try to view the properties of the Management Point from the console, the console will error

If I click Continue it will open the properties but they don't appear correctly. The "sitedatabase" tab is missing and the mobile device and generate alert boxes aren't selected. If I click Quit the then console crashes.

So everything appears to be working, except for being able to view the actual properties through the console.

November 28th, 2014 6:05am

Thanks Adam,

Well that will certainly save me the effort of having to raise a support case :) As for functionality, yes I had already noticed everything appears to be working fine and that it was just a UI issue.

I tried running that work-around script on the Primary for this site and while it completed without error, it doesn't appear to have fixed anything. I still get the UI crash. Does it need some time to take effect?

Some additional info in case it's relevant: Hierarchy is a CAS with SMS Providers located on dedicated servers. Multiple Primary legs, each Primary is a site server only (no other roles) with local SMS Provider. In each Site there are multiple MP's each located on dedicated servers for the MP role.

Free Windows Admin Tool Kit Click here and download it now
December 2nd, 2014 12:11am

Yes, it is an issue with CU3. The workaround suggested by Adam did not work for me with CU3.

CU4 has just been released, but I can't test if it is fixed in CU4 at the moment. I haven't looked to see if it is mentioned as fixed or not so I don't know myself.

If you have tried with CU4 and found it is still a problem, then that leaves this as an open issue unless Adam or someone else from MSFT can suggest another fix.

February 5th, 2015 11:10am

Hi Guys


Installing Mp's using the cmdlet also broke client push in my environment.

Fix was to remove then readd MP using GUI.


Free Windows Admin Tool Kit Click here and download it now
February 10th, 2015 12:28am

Yes, I know this is an old post, but Im trying to clean them up. Did you solve this problem, if so what was the solution?

Since no one has answer this post, I recommend opening  a support case with Microsoft Customer Support Services (CSS) as they can work with you to solve this problem.

August 22nd, 2015 11:42am

I haven't needed to (re)build an MP for a while now and haven't checked to see if this is fixed in SP1 or SP1-CU1. I'll test it when I'm back in the office next week and post an update.
Free Windows Admin Tool Kit Click here and download it now
August 22nd, 2015 12:04pm

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics