MP Installation fails - MP Control Manager detected MPsetup has failed to create the CCM_Incoming Virtual Directory.
Win2k3 R2 StandardEdition SP 2 - R2. It's a new installation with SQL 2005.IIS is installed with WebDAV and BITS installed and allowed. SCCM installed and default web site on port 80. The AD schema was extended using the extadsch.exe file and site data successfully publishing to AD.The problem is that the MP will not install. <10-30-2009 10:31:42> Enabling MSI logging. mp.msi will log to C:\Program Files\Microsoft Configuration Manager\logs\mpMSI.log<10-30-2009 10:31:42> Installing C:\Program Files\Microsoft Configuration Manager\bin\i386\mp.msi CCMINSTALLDIR="C:\Program Files\SMS_CCM" CCMSERVERDATAROOT="C:\Program Files\Microsoft Configuration Manager" USESMSPORTS=TRUE SMSPORTS=80 USESMSSSLPORTS=TRUE SMSSSLPORTS=443 USESMSSSL=TRUE SMSSSLSTATE=0 CCMENABLELOGGING=TRUE CCMLOGLEVEL=1 CCMLOGMAXSIZE=1000000 CCMLOGMAXHISTORY=1<10-30-2009 10:33:01> mp.msi exited with return code: 1603<10-30-2009 10:33:01> Backing up C:\Program Files\Microsoft Configuration Manager\logs\mpMSI.log to C:\Program Files\Microsoft Configuration Manager\logs\mpMSI.log.LastError<10-30-2009 10:33:01> Fatal MSI Error - mp.msi could not be installed.The messages say to check the IUSR and IWAM accounts and I have quadrupled checked them for problems but they are fine.I have found that when I remove IIS and the inetpub folder, I can't just re-install it. I need to first change the registry key: HKLM\Software\Microsoft\Windows NT\CurrentVersion\SvcHost and grant permissions to this folder other wise the World Wide Web Publishing Service fails to load and IIS default web sitedoesn't start up without that service. I have re-installed IIS a couple of times and done quite a few things that I found on this forum but my MP doesn't want to install. It gives me an error of:MP Installation fails - MP Control Manager detected MPsetup has failed to create the CCM_Incoming Virtual Directory.I've been struggling for a couple of days now, I also tried the the following: 1. Check if the Protected Storage Service is started. If not, start it, then retry the MP installation. 2. Verify the permission on machine key folder as per 3. Check for the Crypto subsystem under HKEY_USERS\.Default\Software\Microsoft\Cryptography\Providers\Type 001 Note: If this registry key does not exist, proceed to the next step. 4. Retry the MP installation.. If not successful then go to the next step. 5. Take a backup and Delete all of the files in the "C:\Documents and Settings\All Users\Application Data\Microsoft\Crypto\RSA\S-1-5-18" folder. 6. Restart your computer. 7. Retry the MP installation.And in IIS the folder it points to doesn't exist..... C:\Program Files\Microsoft Configuration Manager\CCM\IncomingI am not sure what else to try. Please help!
October 30th, 2009 12:38pm

Just maybe a note of interest, something I just found out. My reporting works, but as soon as I add the management point the reporting point gives me a message of page cannot be displayed.
Free Windows Admin Tool Kit Click here and download it now
October 30th, 2009 2:52pm

Ok. I've come to the verdictthat this server is screwed. Server 2003 SP2 fails when trying to re-install and I am a little bit fed up with this server. Reloading from scratch on Monday.
October 30th, 2009 4:28pm

I had this exact sam issue upgrading my test lab, it was on a Windows 2008 site server however. I tracked it down to a BITS issue and did the following things:1. Removed the MP2. Diabled BITS on my DP3. Removed BITS4. Rebooted5. Reinstalled BITS6. Added MP back7. Enabled BITS on the DP8. Happy Happy, Joy JoyNot sure if I needed to do all of this, but it worked in the end. You can try by just removing and readding BITS and see what happens. Based on some very limited info, this is not a unique SP2 upgrade issue and is the result of some corruption in the IIS metabase that is resolved by reinstalling BITS.Jason | | | Twitter @JasonSandys
Free Windows Admin Tool Kit Click here and download it now
October 30th, 2009 4:36pm

Ok. So I formatted the server. And before even installing SCCM I started getting problems. I can't install SP2 for windows. So after some further investigation, I found that our Security "specialist" disabled the rights to a couple of registry keys via GPO's which is causing havoc now. This is one of the keysHKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\SvcHost.He also disabled any access to create scheduled tasks.This was all done due to a recent virus outbreak we had. I don't think I will have an issue anymore once all this has been sorted out. 3 weeks of my life. Gone. Down the drain. At least I know SCCM better now.Just thought i'd post this in case any of you other people have a Hitler for a security specialist.Cheers people.
November 2nd, 2009 4:54pm

....and since I had the exact same problem I can now confirm parts of Jason Sandys solution... You only need to do as follows:1. Remove BITS2. Reboot3. Add BITS4. Trigger installation (Stop and Start SMS_SITE_COMPONENT_MANAGER using the ConfigMgr Service Manager)5. Me so happy to!!!That's it, easy and straight forward!
Free Windows Admin Tool Kit Click here and download it now
February 4th, 2010 2:48am

Hey,I had the same problem, and I followed the same steps that Sundin has listed.It worked :)Thanks a lot.Keep it up Guys !!!!!!
March 3rd, 2010 4:54pm

this happened to me as well while upgrading to R3 beta. i had to throw in a couple extra reboots than you did, but the MP finally re-installed for the upgrade. nice one guys.
Free Windows Admin Tool Kit Click here and download it now
June 10th, 2010 12:51am

This worked for me as well. This is a big relief. Thank you very much.
June 9th, 2011 12:59pm

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics