MOSS native backup slow performance after start of daylight saving time.
The backup for my MOSS farm have gone from 40 minutes to 7 hours, since the daylight savings time change. There appears to be a pause for 1 or 2 hours at certain points during the backup. Note times below. I have seen discussions about this on google groups, but no real solution. Just work arounds like uninstalling the DST patch 931836 and changing the MOSS servers timezone to a location that has the same time as DST. I'm hoping for a real fix. [3/13/2007 9:30:45 PM]: Progress: [UserProfileApplication] 50 percent complete.[3/13/2007 9:30:45 PM]: Verbose: Starting object: SessionStateSharedApplication.[3/13/2007 9:30:45 PM]: Verbose: Starting object: Shared Search Index.[3/13/2007 9:30:45 PM]: Progress: [Shared Search Index] 50 percent complete.[3/13/2007 10:31:01 PM]: Verbose: Starting object: SharedServices1_Search_DB. [3/13/2007 10:31:39 PM]: Verbose: Starting object: Windows SharePoint Services Help Search.[3/13/2007 10:31:39 PM]: Progress: [Windows SharePoint Services Help Search] 50 percent complete.[3/13/2007 10:31:39 PM]: Verbose: Starting object: Search instance.[3/13/2007 10:31:39 PM]: Progress: [Search instance] 50 percent complete.[3/14/2007 12:32:01 AM]: Verbose: Starting object: WSS_Search_FFEUSPLMSAP212. [3/14/2007 12:32:09 AM]: Verbose: [WSS_Search_FFEUSPLMSAP212] SQL command completed at: 3/14/2007 12:32:09 AM.[3/14/2007 12:32:09 AM]: Verbose: Starting object: Search instance.[3/14/2007 12:32:09 AM]: Progress: [Search instance] 50 percent complete.[3/14/2007 2:32:31 AM]: Verbose: Starting object: WSS_Search_FFEUSPLMSAP211. [3/14/2007 2:32:38 AM]: Progress: [Windows SharePoint Services Help Search] 100 percent complete.[3/14/2007 2:32:39 AM]: Verbose: Starting object: Search instance.[3/14/2007 3:32:41 AM]: Progress: [Search instance] 100 percent complete.[3/14/2007 3:32:42 AM]: Verbose: Starting object: WSS_Search_FFEUSPLMSAP212.[3/14/2007 3:32:42 AM]: Verbose: Starting object: Search instance.[3/14/2007 4:32:48 AM]: Progress: [Search instance] 100 percent complete.
March 22nd, 2007 11:44pm

In Cologne (Germany) we are experiencing the same problems since we switched to DST saturday night. We found this KB article, but at first sight it does not seem to fix the problem:
Free Windows Admin Tool Kit Click here and download it now
March 26th, 2007 5:19pm

yea this is happening alot. I will try to get some more info on this but for now this will help. Try this. STSADM.EXE o execadmsvcjobs
March 28th, 2007 5:37am

OK, we will integrate it in our scripts for now. Thnx for the info.
Free Windows Admin Tool Kit Click here and download it now
March 28th, 2007 10:56pm

I am running my backupby using STSADM, from the command prompt. I started my backup, waited until the job"hung" on the Shared Search Index, and then tried executing the command "stsadm -o execadmsvcjobs" command. Nothing happened. When the backup job hangs, I go to Central Admin | Operations | Timer Job Definitions. Look for the Search Backup and Restore item under the Title column. Select the link, on the Edit Timer Job page click delete button. This will allow the job to proceed to the next hang point. Repeat the procedure until the backup job completes. This works, but who is going to login at night to delete timer jobs. Bernard
March 28th, 2007 11:45pm

Two other methods to try: Run the backup via a script. No need to exectute the previous fix stsadm -0 backup -directory \\servername\backup_FolderName -backupmethod Full Fire this off in a Scheduled task or manually and you will be fine... Or What i found that was interesting is leaving the GUI sit there for an hour... or simply go home In an hour it eventually will kick off with no intervention needed. HTH
Free Windows Admin Tool Kit Click here and download it now
March 29th, 2007 4:35am

Hi, The issue still occurs when executing through a script, here at least. My backup seems to be taking longer than 1 hour, more like 2-4 hours. I'm in GMT 0 (with DST/BST). If I change to a GMT0 zone without DST, sharepoint backup works fine, but causes Symantec BE to fail (presumably because it's out of synch with the other servers). Anyone know whether MS plan to fix this any time soon? Thanks
March 29th, 2007 7:57pm

Hey Michael, I saw a thread last evening that a fix was being worked on. I will post back when this does go out but im sure the Sharepoint Team Blog will have this information out before anyone else. Keep that site on your radar.
Free Windows Admin Tool Kit Click here and download it now
March 30th, 2007 4:21pm

Yes, post when the fix is available. I am executing the backup via a script and my backup is still running 6-7 hours, when it was taking 45 minutes.
March 30th, 2007 6:36pm

Ok thanks Bob, will do.
Free Windows Admin Tool Kit Click here and download it now
March 30th, 2007 11:45pm

I was experiencing similar problems (backups would hang). In my case it was because WSS 2.0 and 3.0 were installed on the same server. The problems went away once I disabled the WSS 2.0 "SharePoint Timer Service". (Don't confuse that service with the WSS 3.0 "Windows SharePoint Services Timer" service.) After that (and possibly a reboot), I no longer experience the problem. I can start a farm backup and it runs immediately and completes in a matter of minutes, not hours.
March 31st, 2007 1:16am

Just curious to all that were experiencing this problem... does it still exist?
Free Windows Admin Tool Kit Click here and download it now
April 14th, 2007 4:14pm

Hi Bob, The problem seems to have resolved itself here. Thanks Mike
April 16th, 2007 10:34am

Since the beginning of april we don't have the problem anymore. Tom
Free Windows Admin Tool Kit Click here and download it now
April 16th, 2007 2:19pm

Ah that old Microsoft Easy Button comes back into play Glad all are back working normally again.
April 16th, 2007 2:53pm

Yes, my backups are back to running in 10-15 minutes.
Free Windows Admin Tool Kit Click here and download it now
April 16th, 2007 5:52pm

We still have that issue here... I tried every workaround I read about, but nothing helps... For some reason, the backup now does not only take 3 hours longer that usual, but THREE DAYS! 1) I tried the trick with STSADM.EXE o execadmsvcjobs, it had no effect. 2) I did already start the backups via a script before I had that problem... so that is not the solution. 3) I changed my timezone one hour ahead of my actual timezone on all the servers in the farm, but no change... (from +1 to +2) 4) I uninstalled the DST (daylight savings time) patch (931836) on all the servers in the farm, with the clocks set as in 3), but the backupstill doesnt run through! The only thing that does make the backup not take 3 days is deleting the "Search Backup and Restore" timer job definitions manually... but I cannot as an administrator log into the server every night at 3AM to delete those job definitions... And I cannot change the start time of those timer jobs one day ahead as described in the article microsoft because the sharepoint backup adds those jobs automatically... I think it is a insolence that microsoft does not see the need for a real fix here and puts out such a dilettantish workaround... And now since for some users the problem seems to have magically disappeared that seems to be their solution to the problem.
April 23rd, 2007 2:58pm

Hi, sorry to resurrect this- but I'm having this exact problem both through GUI and script. None of the above fixes seem to have any effect for me. I'm in the UK (GMT+1 with BST). Does anyone else have any suggestions before I tear MS a new one? Thanks
Free Windows Admin Tool Kit Click here and download it now
May 11th, 2007 12:45pm

finally someone else now... i already started to think that i am the only one who still has the issue. timezone here, in Germany, is Central European Time (GMT+1), with daylight saving time comes to GMT+2
May 11th, 2007 7:01pm

Sorry to drag up an old thread, but I'm still having this problem. I have had it since moving to British Summer Time (GMT+1), and none of the fixes I have tried have worked. I tried rolling forward the time, and all of the other fixes I've so far found on the web - but no joy! Can anyone help me to diagnose?
Free Windows Admin Tool Kit Click here and download it now
June 6th, 2007 11:24am

hello daryll, i thought i was the only one who still had that problem, but you gave me some hope since you also had it. but microsoft seems not to care about it any more since it magically disappeared at most installations... i guess i can also give you some hope now: the problem has disappeared at our installation now, too. i am so relieved because it was really getting crazy since my one-time-jobs did not finish at all any more. so, to tell you what i did: since everyone else had noproblem anymore, i thought maybe i give it a try and reinstall the DST patch that i had previously uninstalled. but still no effect. then I set my clocks to normal time zone again with daylight saving enabled... still didnt change anything. but i had notrebooted my machinesafter the time zone change until today... also, i deleted every one-time-jobfrom the job definitions list before the reboot. starting the machines up again and trying the backup resulted in SUCCESS!!! i am really relieved since it was not just the backups that depend on the one-time-timer jobs. so i hope this information will help you resolve your problem, too. tell me if it worked! huby
June 11th, 2007 5:20pm

Just one more possibility for solve this problem. I had the same backup job not finish problem after the DST change. After looking around the jobs, I found out all the jobs did not run after March 30th. I deleted all the One-time jobs first. Then I disabled and enabled the following two jobs, 'Application Server Administration Service Timer job' and 'Application Server Timer Job'. That restart all the jobs in the backup and that fix my backup problem.
Free Windows Admin Tool Kit Click here and download it now
June 12th, 2007 11:34pm

Any other workaround or patch for this ? Since 2 days ago backups worked fine for me but noe it's very slow. Sorin
June 14th, 2007 9:53am

Hi allDoes anyone know of a proper fix for this? We're not even using daylight savings time. We're in South Africa - GMT +2 - (Harare, Pretoria) and stsadmin backup hangs on "Shared Search Index". If i go into Central Admin console and kill the timer job then it carries on, but the whole point of using stsadmin was to get an automated scheduled backup going.Any ideas anyone?ThanksRay
Free Windows Admin Tool Kit Click here and download it now
July 4th, 2007 4:15pm

It seems to me now that only for GMT + 2 appears this problem Anyone from MS is reading this ?
July 30th, 2007 4:17pm

Hi - I logged a call with PSS for this about 10 days ago - unfortunately their queue of SharePoint calls is very busy so they said it will take a while to get a response. As soon as I hear anything helpful, I'll post back here.ThanksRay
Free Windows Admin Tool Kit Click here and download it now
July 30th, 2007 4:24pm

Thank's Raymond I will wait for your response.
July 31st, 2007 2:41pm

Hi thereWe finally heard back from PSS, and they gave us a hotfix - KB939592 - which has solved the issue for us. Our backups with stsadmin are now going through fine, without the 1hr delay for the Search components.After installing the hotfix, do this as well:-1. Click Start, click Run, type cmd in the Open box, and then click OK. 2. Change to the following directory: system drive \Program Files\Common Files\Microsoft Shared\Web Server Extensions\12\Bin 3. Run the following command: psconfig -cmd upgrade -inplace b2bTo install and to run this syntax please use your SPS service account who have also the DB owner permission on the SQL DBThanksRay
Free Windows Admin Tool Kit Click here and download it now
August 28th, 2007 9:26am

Hi, Another solution ( well it worked for me anyway...): I had the same problem - backups would hang at 50% of the search service backup whether it was Full or Differential backups usingSTSADM. My solution was : (1) I took the server off daylight savings time ( and disabled the automatic daylight savings option ) and set thetime manually on the server. (2) I went then to C:\Documents and Settings\All users\Application Data\Microsft\Sharepoint\Config\<your_SharePoint_GUID> where<your_SharePoint_GUID> is some 32 digit string of numbers and letters. (3) Ideleted anything filesin the GUID directory that was more than24 hours old. This seems to fix a multitude of issues with SharePoint. Cheers W.
November 13th, 2007 8:00am

Surprisingly (or maybe not?), I am experiencing this issue a year after the original problem was reported! Am going through several of the ideas posted to try and fix this, but if anyone knows a definite fix then I would really appreciate it. Thanks.Jason.
Free Windows Admin Tool Kit Click here and download it now
April 2nd, 2008 1:35pm

Hi Jason,6 months after your post I'm experiencing same problem... did you end up finding a solutions and/or why was it happening ?Any hintsappreciated.-luis
December 15th, 2008 8:37am

It is now 2009 and I am having the same issue at one of my customers... It's really frustrating that this is not fixed by now through an update.We are in the Central Time Zone, GMT -6. I am going to try disabling DST for tonights backup, but that cannot be the final fix.Does anyone have an update?-jim
Free Windows Admin Tool Kit Click here and download it now
January 28th, 2010 6:37pm

Well, we're into 2012 now, and after switching the clocks last week. the problem returns! Doesn't anyone have a fix for this? Any help would be greatly appreciated!
March 15th, 2012 10:01am

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics