MOSS error 'An indexer is not assigned to the Shared Services Provider'
I am getting this error when trying to go to Shared Services Administration - Search Settings. Under the error is 'Configure an indexer and a search database for this Shared Services Providerbut whenI click on this it gives another error 'An unhandled exception occurred in the user interface.Exception Information: The specified account name is invalid. Parameter name: account'.What happened is I noticed in the event logs we were getting loads of event ID 6482 - Application Server Administration job failed for service instance Microsoft.Office.Server.Search.Administration.SearchAdminSharedWebServiceInstance (517bc4c5-f28b-4c41-96c8-e939643b31b3). Reason: The specified account name is invalid.Parameter name: accountI then re-entered credentials for search services and thats when started receiving the error above. To fix, do I need to re-create the SSP and if so, what is the best way to do this?Thanks
September 15th, 2009 12:41pm

Try the following:1. Make sure that your SSP service account is enabled, unlocked, and the password you're using is correct. 2. Login to your Central Administration site > Operations > Service Accounts. Select Web application pool radio button, under "Web service" select your web application, and under "Application pool" select your SSP application pool.3. Re-enter the username and password, click OK.4. Restart IIS.If you decide to re-create your SSP, you'll need to create a second SSP, change associations for all your web applications to the new SSP, make the new SSP the default shared services provider, and then delete the old SSP. See this Technet article for a reference on creating an SSP: Galitsky, MCTS, Lexington, KY -- My SharePoint Blog:
Free Windows Admin Tool Kit Click here and download it now
September 15th, 2009 2:25pm

Thanks. I tried what you suggested but still same issue. I will look at that article
September 15th, 2009 3:51pm

Hi, Except for the error 6482, did you get error 6398, 7076 in the event viewer as well? If so, please try to install KB 946517. If this is not the issue, its possibly a permission issue based on the error messages. You could try to synchronize the service accounts password following KB 934838: Hope this helps. Lu Zou
Free Windows Admin Tool Kit Click here and download it now
September 17th, 2009 12:32pm

It seems weird that the moderator is able to mark his own responses as the answers, rather than allowing the person that actually asked the question to respond as to the success or failure of the information provided. This prevents other users with the same query to actually find answers.Joel Cade, MCSD MCT Senior Software Developer, Master SME MicroLink LLC,
September 29th, 2009 6:06pm

There was a gap of over a week. This was not the all-too-typical case of someone posting a message and then marking it at once as an answer. The Microsoft support people are allowed to close threads in this way if the user does not respond in a reasonable time frame. (Non-MS Moderator who never marks his own posts) FAQ sites: (SP 2010); (v3) and (WSS 2.0) Complete Book Lists (incl. foreign language) on each site.
Free Windows Admin Tool Kit Click here and download it now
February 12th, 2010 2:57pm

Hi, I had similar problem on our Test Environment. Make sure you've done everything by the book asper Microsoft's Guide in creating SSP. Now: Check the Services on your "Server" and make sure "Windows SharePoint Services Administration" is Started. Start> Administrative Tools> Services> and look for Windows SharePoint Services Administration. Start it. Go back to your SSP, and refresh the Page. That should do the trick. This has worked for our environment. Many thanks Ayo Adeniba(MCITP/ MCTS)
March 1st, 2011 11:39am

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics