MOSS 2007 - Suddenly Cannot Edit Files In Place/My Network Places No Longer Work
I am updating the description to provide more information about the problem. Any suggestions for resolution are welcome. The Problem When attempting to update a Microsoft Office file in place on either SharePoint or merely using an IIS website, the save operation returns a user-visible Unable to connect to the web server message in a dialogue box. The underlying network trace indicates an error 500 with a supplemental error description of %1 is not a valid Win32 application. This network trace error is consistent across all manifestations (see below). This problem did not exist until approximately November 2007. We had been running without incident with MOSS 2007 Enterprise edition, fully licensed since approximately May 2007. We upgraded to MOSS 2007 SP1 about a month ago, which exposed Manifestations 7 and 8 (did not occur pre-SP1). This problem does NOT occur with text files edited by Notepad. This problem does NOT occur on a WSS 3.0 server we have installed, using the same clients and client software. We have confirmed this behavior in the following environments across a random sampling of 1000 people in the company: Client: Windows XP SP2, Office 2003 Client: Windows XP SP2, Office 2007 (upgrade from Office 2003) Client Office Server 2003 R2, Office 2007 Our server environment is a small farm: 1 web server running MOSS 2007 Enterprise SP1 1 database server running SQL Server 2000 SP4 Windows Server 2003 R2, IIS 6.0, latest service packs Manifestations 1. When attempting to edit a file in place, the system returns an error on save Unable to connect to the web server. Variant 1. a. Open a browser window in any document library on any site collection. b. Hover over a Microsoft Office file (any type) until the context menu appears. c. Select Edit in Microsoft xxx. d. Make any changes desired to the file. e. Click Save. f. The error occurs. 2. When attempting to edit a file in place, the system returns an error on save Unable to connect to the web server. Variant 2. a. Open a browser window in any document library on any site collection. b. Click on the file in question. i. In Office 2007, users are prompted to either open for read only or edit. Select Edit. ii. In Office 2003, users are not prompted but the file is opened in read-only mode. c. Make any changes desired to the file. d. Click Save. i. In Office 2007, the error occurs. ii. In Office 2003, because it is a read-only file now, the system requests users to save the file to a new name. 3. When attempting to edit a file in place, the system returns an error on save Unable to connect to the web server. Variant 3. a. Open a browser window in any document library on any site collection. b. Click Actions->Open in Windows Explorer. c. Open any Microsoft Office file. d. Make any changes desired to the file. e. Click Save. f. The error occurs. 4. When attempting to edit a file in place, the system returns an error on save Unable to connect to the web server. Variant 4. a. Map a drive to any document library on any site collection. b. Navigate to the mapped drive and open any Microsoft Office file. c. Make any changes desired to the file. d. Click Save. e. The error occurs. 5. Cannot save files in My Network Places that point to SharePoint document libraries. a. Open My Network Places. b. Click Add a network place. c. Click Next. d. Select Choose another network location and click Next. e. Type in the URL of a any document library on SharePoint and click Next. f. Name the network place and click Next. g. Click Finish. h. Open the network place just created. i. Open any Microsoft Office file. j. Make any changes desired to the file. k. Click Save. l. The error occurs. 6. Check-in/check-out does not work when using local drafts folder. a. Open a browser window in any document library on any site collection. b. Hover over a Microsoft Office file (any type) until the context menu appears. c. Select Check-out. d. Make sure the Use my local drafts folder is enabled and click OK. e. The file is correctly checked out and copied to the local drafts folder. f. Open the file and make any changes desired to the file. g. Click Save. h. Notice that no check-in option is available from the Microsoft Office client. i. Close the application. j. Return to the browser and locate the checked out file. k. Hover over the file until the context menu appears. l. Select Check-in. m. At the check-in screen, click OK. n. When prompted you are about to upload a file, click Yes. o. The system returns an error: This document was checked out to your local drafts folder but the local copy could not be checked in to the site. Close any application that is editing the document and try to check in again, or discard the checkout. There really is no option but to discard the checkout. When the checkout is discarded, the file is deleted along with any changes made by the user. 7. When attempting to upload files using the Upload Multiple Documents interface. Variant 1. a. Open a browser window in any document library on any site collection. b. Click Upload->Upload Multiple Documents. c. Select one or more files to upload. d. Click OK. e. Click OK again to continue. f. The file(s) appear to upload, including progress indicators of bytes uploaded. g. The operation appears to complete but no file(s) are uploaded. 8. When attempting to upload files using the Upload Multiple Documents interface. Variant 2. a. Open a browser window in any document library on any site collection. b. Click Upload. c. Click Upload Multiple Files d. Select one or more files to upload. e. Click OK. f. Click OK again to continue. g. The file(s) appear to upload, including progress indicators of bytes uploaded. h. The operation appears to complete but no file(s) are uploaded. 9. Microsoft Office SharePoint Designer 2007 is unable to connect to a SharePoint site. Variant 1. a. Open Microsoft Office SharePoint Designer 2007. b. Click on File->Open Site. c. Type in the URL of any site or any site collection and press Open. d. The system returns an error: The folder xxx isnt accessible. The folder may be located in an unavailable location, protected with a password, or the filename contains a / or \. 10. Microsoft Office SharePoint Designer 2007 is unable to connect to a SharePoint site. Variant 2. a. Open Microsoft Office SharePoint Designer 2007. b. If the default site points to a SharePoint site, the system returns an error: The server could not complete your request. Contact your Internet service provider or web server administrator to make sure that the sever has the FrontPage Server Extensions or SharePoint services installed. c. Click Details. d. The system returns: Error %1 is not a valid Win32 application. Things We Have Tried update ASP.NET to the latest versions and service packs configure IIS Web Server Extensions to include ASP.NET versions and SharePoint Services 3.0 only load Microsoft Office 2007 on the server proper to verify the problem was not related to network problems or a specific client OS or software installation turned off then on the Client Integration under Authentication Providers try using different accounts to access files try variations of versioning (all manifestations above use document libraries without versioning, verified the problem still exists in versioned libraries too) run SharePoint Products and Technologies Configuration Wizard in repair mode modified home directory permissions in IIS created new site collections create an IIS-only site (no SharePoint) Conclusions This is not a network or firewall problem (ran client software locally on the server) This is not a permissions problem (running as any user, including administrators have this problem) This is not a client problem (occurs on all clients throughout the company regardless of configuration or client version) This is not an API-visible SharePoint configuration problem (nothing we changed appears to have had any effect) This is PROBABLY NOT a SharePoint problem (same behavior on IIS-only website) This is PROBABLY: o A file was renamed, deleted or moved o A file is corrupt o A registry entry is corrupt or changed o A path was reset Suggestion The likely way to correct the problem is to walk through the operations these applications perform in the manifestations above and determine what they call at these points. I do not have access to your source code to check this for myself. I imagine you do. If the error 500 is returning a valid error (%1 is not a valid Win32 application), then I imagine we will discover a single setting or file is the culprit. If the error 500 is just a default error, then we will have at least isolated the problem to what these ten manifestations have in common and can work from there.
January 12th, 2008 10:14pm

An update on this issue... The problem also appears to disable the ability topublish InfoPath forms to the server. It returns the following message: InfoPath cannot find or cannot access the following webserver: http://nameOfServer/nameOfSite Make sure that the name of the web server is valid, that your proxy settings are correct, and that you have the necessary permissions to publish to this library. If the server requires you to log on through the browser, log on there and select the option to remember your log on information, then try to publish again. (1) The name of the web server is correct and is completely accessible. (2) We do not use proxies. (3) I have administrator permissions both through SharePoint, AD and locally. (4) I do not need to log on through the browser. So this is yet another feature of SharePoint that is off-line until resolved... Vlad
Free Windows Admin Tool Kit Click here and download it now
January 18th, 2008 7:15pm

I've seen those errors before. It's kind of a bad solution, but doing an iisreset on our web frontends would make the problem go away for a while.
January 18th, 2008 7:26pm

KLeung, Thank you for the recommendation. I have tried IISRESET, rebooting the machine, comparing the IIS settings on this machine to another one that works but to no avail. Take care, Vlad
Free Windows Admin Tool Kit Click here and download it now
January 18th, 2008 7:34pm

Are you getting any particular errors in your Event Viewers, IIS logs, or SQL server logs?
January 18th, 2008 7:39pm

KLeung, I wish there were something in the logs. Unfortunately, even with tracing turned on, there appears to be no correlated log event for this failure. This suggests to me (and I will admit vast ignorance in this area), that the problem occurs between the client and some level of IIS rather than touching SharePoint proper. Take care, Vlad
Free Windows Admin Tool Kit Click here and download it now
January 18th, 2008 7:53pm

Actually, your problem may be related but it is not quite the same. The problem exists for XP/Office 2003, XP/Office 2007 as well. We have only an handful of Vista users in the company and I imagine the problem exists for them as well. I seem to recall Microsoft writing up something about difficulties with Vista and this combination but it was in relation to form-based authentication I think. I am not sure this will be of any value but here is the link: http://msdn2.microsoft.com/en-us/library/bb977430.aspx Vlad
January 21st, 2008 2:35pm

We have been working with Microsoft support on this for over two weeks now. It is not yet resolved. The good news is that we have practically eliminated SharePoint itself and any client configurations from the problem. It appears that something on the server orin ISS has changed that causes this behaviour.
Free Windows Admin Tool Kit Click here and download it now
February 1st, 2008 8:25pm

I just experienced this for the fist time. I am running Vista Ultimate with Office 2007. I also have an XP laptop with Office 2003 and the latest office updates - I amable to check out, edit, and check in normally on it.
February 4th, 2008 5:25pm

JSPadea, We have determined our particular problem is not client-related, but there some issues related to Vista and client integration if I am not mistaken. I am not clear on the details, however. Take care, Vlad
Free Windows Admin Tool Kit Click here and download it now
February 4th, 2008 5:31pm

We encountered this error last week. We tried several steps but to no avail. Yesterday, we re-installed MS Office and the problem no longer occurs. This solves the problem in our side. Hope this helps.
February 5th, 2008 1:21am

I am glad you resolved the problem. Unfortunately ours is different. We have approximately 800 clients who all started experiencing the problem simultaneously. This suggested a server-based problem rather than a client issue. Further, we installed a fresh copy of MS Office on a clean machine and were still unable to do make progress. This suggests to me the problem is something in IIS.
Free Windows Admin Tool Kit Click here and download it now
February 5th, 2008 11:20am

Into week 7 of having placed a paid support call into Microsoft, the problem still persists. I am underwhelmed by the technical acumen of the case engineer, the responsiveness of Microsoft or the ability to even get a simple, pre-arranged callback. Microsoft really needs to up their technical support game.
February 27th, 2008 11:08am

Now into week eight and no resolution. I did confirm that the engineer who was assigned the case hadn't worked on it for weeks despite my persistent pinging. I guess the only way to get anything fixed is to hire a consultant...
Free Windows Admin Tool Kit Click here and download it now
March 5th, 2008 11:56am

Thanks for the updates, even if MS isn't making any headway.
March 5th, 2008 3:43pm

Burghthing, It is frustrating since I have about 900 people waiting for the system to roll out. There are rumblings we should move document management to Oracle at this stage, since Microsoft seems unable to support their own product. I am trying to convince them otherwise but it is difficult. Can anyone recommend a diagnostic consultant for SharePoint who might be able to look into this? Take care, Vlad
Free Windows Admin Tool Kit Click here and download it now
March 5th, 2008 3:49pm

Are you doing anything with offline files? I'm starting to think my problem might be caused by Vista's issues with offline files. We have our SharePoint Drafts folder pointing to a mapped network drive. I have the folder setup for offline file sync. Turns out Vista's having known problems with offline files. I'm thinking that might be causing my issue, though I think you mentioned only a small % of your users are on Vista. You might want to contact these folks: Allin Consulting - Pittsburgh Office, WebPitt@allin.com 381 Mansfield Avenue, Suite 400, Pittsburgh, PA 15220Phone: (412) 928-8800 Best of luck...
March 6th, 2008 4:37pm

Burghthing, Thank you for the reference. I will look them up. The problem is not OS-related. We have tried using Windows XP, Windows Server 2003 and Vista, all with the same results. What we do know is that the problem only occurs with Microsoft Office applications and files (text files work fine for example), so the problem is somehow related to an handshake the server makes with Office: Office does not recognize the server as being available. The problem also manifests itself in Windows SharePoint Designer, which is frustrating since I haven't been able to edit any pages or workflows in two months. Take care, Vlad
Free Windows Admin Tool Kit Click here and download it now
March 6th, 2008 4:48pm

Week 11 and no resolution. I did discover something in the network activity capture monitor which I think points to the problem, however. When I attempt to save a file in place (or access a page for editingvia SharePoint Designer) or upload multiple documents, I receive an error code 500, with the description: Error%1 is not a valid Win32 application. I have no idea what Win32 application it is attempting to call, but I suspect if I knew we could correct the problem quickly. Any ideas? Vlad
March 19th, 2008 4:58pm

I finally spoke to a member of Microsoft SharePoint's Advanced Support organization today. He was able to resolve my problem in about an hour. This, after about three and an half months being bounced around the regular support organization with people who did not know what they were doing. Microsoft regular support knows only to look into knowledgebases, not really exercise much in the way of diagnostic or debugging ability. Here was the actual problem: On the front-end web server, somehow the C:\Program Files\Common Files\Microsoft Shared\web server extensions\12\ISAPI\_VTI_AUT directory and its contents had gone missing. Fortunately I had another server running WSS 3.0 and we were able to copy the files across. It also turned out that one of the files an earlier support engineer had given me to debug the problem (SHTML.DLL) was faulty, so we replaced this file as well. I have tested all my use cases and everything appears to work fine! I wish I had been able to speak with this fellow in January when I first filed the problem.
Free Windows Admin Tool Kit Click here and download it now
April 4th, 2008 1:45pm

Is it possible that javascript functions that were altered with the service pack have somehow not been refreshed in people's browsers?
April 8th, 2008 12:41pm

FergusB, Thank you for responding. No, this was not the problem. It turned out that some of the files on my web server had gone missing. I do not know why, but when these were replaced, everything started to work again. Vlad
Free Windows Admin Tool Kit Click here and download it now
April 8th, 2008 12:45pm

Experaincing a similar problem here, my symptoms were exactly as described.Vlad. Thanks for posting your resolution, I'd never have managed to get to the bottom of this ortherwise.In my case the'_VTI_AUT' folder (and its contents) still existed ok but tried restoring SHTML.dll from an older copy as suggested. After running an iisreset, everything picked up as normal, check in/out from both Office2007 and 2003 are now working perfectly.Once again, thanks for the info, very much appreciated.QZ
January 18th, 2009 1:05pm

Hi,We are having a similar kind of problem as well but a bit different in the same time as well.What happen is that our MOSS server will work for a while, but sometimes when a person check-in a document, it will hang the whole server and then complain that the document is not checked-out or checked-out by another person when in fact, the person checking in is the same as the person who checked it out!This will happen once a while.Any ideas? Also I'm interested in knowing what contents do you have under the '_VTI_AUT' folder?Currently I can only see AUTHOR.DLL and SHTML.DLL is in the folder one level up. Is this still corrent?Cheers,DePatrick
Free Windows Admin Tool Kit Click here and download it now
February 24th, 2009 12:05am

I am having the same issue as DePatrick:It seems when XP users with Office 07 try to modify a document in MOSS 07, the document is opened in read only. I have tried the RegEdit Microsoft suggests and also applying a recent patch. Still a no go.When a any user (XP/Vista) tries uploading an infopath form they recieve the error: The form template cannot be opened, because the system administrator has disabled opening form templates that require full trust.As far as the '_VTI_AUT' folder, I can only see AUTHOR.DLL and SHTML.DLL is in the folder one level up, just like DePatrick.
April 22nd, 2009 10:23am

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics