MDT Task sequences error with OS Packages
Hello everybody, I got a strange problem in some of my OS deployment. indeed, each time i use a MDT Task OS Deployment (MDT2010 Update 1, integrated to SCCM2007 R3), of Windows 7 or Windows Server 2008R2, i got an error, if i choose to deployed other editions than the first one (HOME BASIC for windows7, and STANDARD for Win2008R2). I mean, i use my OS Package (this is the DVD source install os WIndows 7 or WIndows Server 2008 R2), and in the TS part "Apply operating system image" if i choose HOMEBASIC for an deployment of Win7, or Standard for an win2008R2 Deployment, it works very well. if i change to "Ultimate" or "Professionnal" , or for WIndows Server 2008R2 "Enterprise" ,for the same TS, the TS failed with an "Unknow Error". here is an extract of my SMSTSlog.log : Failed to run the action: Error in the task sequence. Unknown error (Error: 80004005; Source: Unknown) TSManager 14/01/2011 11:57:52 1188 (0x04A4) ….. Let the parent group (Gather Logs and StateStore on Failure) decides whether to continue execution TSManager 14/01/2011 11:57:52 1188 (0x04A4) The execution of the group (Gather Logs and StateStore on Failure) has failed and the execution has been aborted. An action failed. Unknown error (Error: 80004004; Source: Unknown) TSManager 14/01/2011 11:57:52 1188 (0x04A4) Failed to run the last action: Error in the task sequence. Execution of task sequence failed. Unknown error (Error: 80004005; Source: Unknown) TSManager 14/01/2011 11:57:52 1188 (0x04A4) Sending status message . . . TSManager 14/01/2011 11:57:52 1188 (0x04A4) Send a task execution status message SMS_TSExecution_TaskSequenceFailError TSManager 14/01/2011 11:57:52 1188 (0x04A4) ….. Execution::enExecutionFail != m_eExecutionResult, HRESULT=80004005 (e:\nts_sms_fre\sms\client\tasksequence\tsmanager\tsmanager.cpp,767) TSManager 14/01/2011 11:58:15 1188 (0x04A4) Task Sequence Engine failed! Code: enExecutionFail TSManager 14/01/2011 11:58:15 1188 (0x04A4) **************************************************************************** TSManager 14/01/2011 11:58:15 1188 (0x04A4) Task sequence execution failed with error code 80004005 TSManager 14/01/2011 11:58:15 1188 (0x04A4) Cleaning Up. Removing Authenticator TSManager 14/01/2011 11:58:15 1188 (0x04A4) Cleaning up task sequence folder TSManager 14/01/2011 11:58:15 1188 (0x04A4) Here is some Screenshot to understand the prob : http://img4.imageshack.us/i/screenhunter01jan141301.jpg/ http://img12.imageshack.us/i/screenhunter02jan141301.jpg/ http://img826.imageshack.us/i/screenhunter03jan141302.jpg/ i really don't understand... if you got an idea :) Regards,
February 28th, 2011 12:15pm

are you specifying a key or any settings in the unattend.xml file ? can you remove it and try again My step by step SCCM Guides I'm on Twitter > ncbrady
Free Windows Admin Tool Kit Click here and download it now
February 28th, 2011 3:19pm

Hello - Are you trying to install 32 or 64 bit? Check the boot image associated with these installations?Anoop C Nair
February 28th, 2011 4:35pm

Hello, I deploy x64 System. and i use an x64 WinPE boot image of course :) . Niall, indeed i know this "bug" about Key entered when we deployed Win7 Enterprise, i got it :), but here i don't have any key in my Unattend.xlm. and i leave blank in Apply Windows Setting in "Key" Part. here is my Unattend.xml used for ms MDT TS : <?xml version="1.0" encoding="utf-8" ?> - <unattend xmlns="urn:schemas-microsoft-com:unattend"> - <settings pass="windowsPE"> - <component name="Microsoft-Windows-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State"> - <ImageInstall> - <OSImage> <WillShowUI>OnError</WillShowUI> - <InstallTo> <DiskID>0</DiskID> <PartitionID>1</PartitionID> </InstallTo> - <InstallFrom> <Path>Install.wim</Path> - <MetaData> <Key>/image/index</Key> <Value>1</Value> </MetaData> </InstallFrom> </OSImage> </ImageInstall> - <UpgradeData> <Upgrade>false</Upgrade> </UpgradeData> - <Display> <ColorDepth>16</ColorDepth> <HorizontalResolution>1024</HorizontalResolution> <RefreshRate>60</RefreshRate> <VerticalResolution>768</VerticalResolution> </Display> - <ComplianceCheck> <DisplayReport>OnError</DisplayReport> </ComplianceCheck> - <UserData> <AcceptEula>true</AcceptEula> - <ProductKey> <Key /> </ProductKey> </UserData> </component> - <component name="Microsoft-Windows-International-Core-WinPE" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"> - <SetupUILanguage> <UILanguage>fr-FR</UILanguage> </SetupUILanguage> <InputLocale>040c:0000040c</InputLocale> <SystemLocale>fr-FR</SystemLocale> <UILanguage>fr-FR</UILanguage> <UserLocale>fr-FR</UserLocale> </component> </settings> - <settings pass="generalize"> - <component name="Microsoft-Windows-Shell-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"> <DoNotCleanTaskBar>true</DoNotCleanTaskBar> </component> </settings> - <settings pass="specialize"> - <component name="Microsoft-Windows-UnattendedJoin" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State"> - <Identification> - <Credentials> <Username /> <Domain /> <Password /> </Credentials> <JoinDomain /> <JoinWorkgroup /> <MachineObjectOU /> </Identification> </component> - <component name="Microsoft-Windows-Shell-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State"> <ComputerName /> <ProductKey /> <RegisteredOrganization /> <RegisteredOwner /> <DoNotCleanTaskBar>true</DoNotCleanTaskBar> <TimeZone>Romance Standard Time</TimeZone> </component> - <component name="Microsoft-Windows-IE-InternetExplorer" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"> <Home_Page>http://www.microsoft.com/</Home_Page> <IEWelcomeMsg>false</IEWelcomeMsg> </component> - <component name="Microsoft-Windows-Deployment" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"> - <RunSynchronous> - <RunSynchronousCommand wcm:action="add"> <Description>EnableAdmin</Description> <Order>1</Order> <Path>cmd /c net user Administrator /active:yes</Path> </RunSynchronousCommand> - <RunSynchronousCommand wcm:action="add"> <Description>UnfilterAdministratorToken</Description> <Order>2</Order> <Path>cmd /c reg add HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System /v FilterAdministratorToken /t REG_DWORD /d 0 /f</Path> </RunSynchronousCommand> </RunSynchronous> </component> - <component name="Microsoft-Windows-International-Core" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"> <InputLocale>040c:0000040c</InputLocale> <SystemLocale>fr-FR</SystemLocale> <UILanguage>fr-FR</UILanguage> <UserLocale>fr-FR</UserLocale> </component> - <component name="Microsoft-Windows-TapiSetup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"> <TapiConfigured>0</TapiConfigured> - <TapiUnattendLocation> <AreaCode>""</AreaCode> <CountryOrRegion>1</CountryOrRegion> <LongDistanceAccess>9</LongDistanceAccess> <OutsideAccess>9</OutsideAccess> <PulseOrToneDialing>1</PulseOrToneDialing> <DisableCallWaiting>""</DisableCallWaiting> <InternationalCarrierCode>""</InternationalCarrierCode> <LongDistanceCarrierCode>""</LongDistanceCarrierCode> <Name>Default</Name> </TapiUnattendLocation> </component> - <component name="Microsoft-Windows-SystemRestore-Main" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"> <DisableSR>1</DisableSR> </component> </settings> - <settings pass="oobeSystem"> - <component name="Microsoft-Windows-Shell-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State"> - <UserAccounts> - <AdministratorPassword> <Value /> <PlainText>true</PlainText> </AdministratorPassword> - <LocalAccounts> - <LocalAccount wcm:action="add"> <Description>Temp account</Description> <DisplayName>Temp account</DisplayName> <Group>Users</Group> <Name>TempAccount</Name> </LocalAccount> </LocalAccounts> </UserAccounts> - <AutoLogon> <Enabled>true</Enabled> <Username>Administrator</Username> <Domain>.</Domain> - <Password> <Value /> <PlainText>true</PlainText> </Password> <LogonCount>999</LogonCount> </AutoLogon> - <Display> <ColorDepth>32</ColorDepth> <HorizontalResolution>1024</HorizontalResolution> <RefreshRate>60</RefreshRate> <VerticalResolution>768</VerticalResolution> </Display> - <FirstLogonCommands> - <SynchronousCommand wcm:action="add"> <CommandLine>cscript.exe C:\MININT\Scripts\LiteTouch.wsf /start</CommandLine> <Description>Lite Touch new OS</Description> <Order>1</Order> </SynchronousCommand> - <SynchronousCommand wcm:action="add"> <CommandLine>cscript.exe D:\MININT\Scripts\LiteTouch.wsf /start</CommandLine> <Description>Lite Touch new OS</Description> <Order>2</Order> </SynchronousCommand> - <SynchronousCommand wcm:action="add"> <CommandLine>cscript.exe E:\MININT\Scripts\LiteTouch.wsf /start</CommandLine> <Description>Lite Touch new OS</Description> <Order>3</Order> </SynchronousCommand> - <SynchronousCommand wcm:action="add"> <CommandLine>cscript.exe F:\MININT\Scripts\LiteTouch.wsf /start</CommandLine> <Description>Lite Touch new OS</Description> <Order>4</Order> </SynchronousCommand> </FirstLogonCommands> - <OOBE> <HideEULAPage>true</HideEULAPage> <NetworkLocation>Work</NetworkLocation> <ProtectYourPC>1</ProtectYourPC> <SkipUserOOBE>true</SkipUserOOBE> </OOBE> <RegisteredOrganization /> <RegisteredOwner /> <TimeZone /> </component> - <component name="Microsoft-Windows-International-Core" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"> <InputLocale>040c:0000040c</InputLocale> <SystemLocale>fr-FR</SystemLocale> <UILanguage>fr-FR</UILanguage> <UserLocale>fr-FR</UserLocale> </component> </settings> - <settings pass="offlineServicing"> - <component name="Microsoft-Windows-PnpCustomizationsNonWinPE" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"> - <DriverPaths> - <PathAndCredentials wcm:keyValue="1" wcm:action="add"> <Path>\Drivers</Path> </PathAndCredentials> </DriverPaths> </component> </settings> <cpi:offlineImage cpi:source="" xmlns:cpi="urn:schemas-microsoft-com:cpi" /> </unattend> why STANDARD editions works and not ENTERPRISE OR DATACENTER...for the same TS, this is awesome !
Free Windows Admin Tool Kit Click here and download it now
March 2nd, 2011 7:16am

Hi, Actually, this issue is more MDT related, in order to get the answer effectively, it is recommended to post a new thread in Microsoft Deployment Toolkit Forum for discussion. The reason why we recommend posting appropriately is you will get the most qualified pool of respondents, and other partners who read the forums regularly can either share their knowledge or learn from your interaction with us. Thank you for your understanding. Regards, Sabrina This posting is provided "AS IS" with no warranties or guarantees, and confers no rights. |Please remember to click Mark as Answer on the post that helps you, and to click Unmark as Answer if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
March 3rd, 2011 10:12pm

Ok done! Thanks! Marc.
Free Windows Admin Tool Kit Click here and download it now
March 4th, 2011 6:48pm

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics