List Filter Not displaying all records it should
We have a SharePoint List that we recently migrated from SharePoint 2003 to MOSS 2007. This list has several views. The default view lists all items with an Open Status and where the assigned to field equals the Logged in user. This worked in 2003 but is inaccurate in MOSS 2007. When I say inaccurate, I mean it doesn't display every record it should. For example, I currently have 4 open projects in the list but when I use this view, only an issue that was recently added is showing up. This behavior is inconsistent. For example the owner of the list reported that in the morning, all of his issues were showing up correctly but in the afternoon, none of them were showing up. We have another view that uses 2 of the 3 filters. It groups by assigned to instead of filters on it. We use it right now so we can really see what items are assigned to us.The filter on the default view is set to Assigned to (Indexed) is equal to [Me] and Current is equal to yes and Status begins with (.The filter on the similar view that is working is Current is equal to Yes and Status begins with (. (groups on Assigned to)Let me know if you can think of anything I can try. Nancy Forbes
December 28th, 2009 9:02pm

I believe we have resolved this issue. I tried exporting the list but several of the columns didn't export. I researched reasons for that and found out several other users had experienced the same problem and had fixed it by changing their date fields to single line of text and then changed them back to date fields. We also had an index assigned to our date field which I had to remove before changing the column type to single line of text. To me, it didn't make sense to even index this field as the date field was not a required field and the majority of the content was null. So this may have been an issue as well.Nancy Forbes
Free Windows Admin Tool Kit Click here and download it now
December 29th, 2009 6:34pm

Lambert (anyone?),I am currently having a similar issue. Simply put, when I remove the "Current = Yes" filter I expect to see all items (current and not). I can see the "Current" field is being set properly when I compare versions of the same item. The latest "Current = Yes" and all other versions "Current = NULL/Empty" are visable when looking at the version history. So why when I remove the "Current" filter do I not see all items. I have also tried to create new lists (both tasks and issues) as tests and neither of those work as well. The task list filter description in settings was even missing the Current is = yes verbage.This sounds like a bug. If there a fix? I tried Nancy's recommendation above and I am still having the same issue.Thanks,greg
February 24th, 2010 8:34am

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics