Libraries in SharePoint ~ Send To -> Email a Link ~ Ignores all attempts to click it
This has been a very frustrating issue. I noticed that this was not working before I put SP2 in for our 4 environments. You could click the menu item but then we would see a "Bad Request" error.I was hoping that installing SP2 would firm things up.I installed SP2 in dev-servername.net, stage-servername.net, and test-servername.net and sure enough this did fix the problem. I noticed that the core.js file in 12 hive was now the correct file dated 2-12-09 with a259KB size with a date modifiedtime of 11:34 a.m.I went into the SP2 installation in production (servername.net) with every expectation that our problem would be fixed in the production environment and I could put this issue behind me.FAILURE!After the SP2 install, the link when clicked does....nothing. The thing throws no error to the user client, logs no error in SP logs (with logging set to the most verbose possible), no error in app logs, no error in IIS logs. It just acts like you never asked for the action. I have tried Fiddler, it shows no IE errors. I tried the sysinternals process monitor and saw no errors in that either.The Core.js file is dated 2-12-09 w/ 259 KB and compares perfectly with that in the other three environments when using a compare files tool. The time stamp on that file was 12:34 p.m. however even though it was the same set of install files as I used with the other three environments. No idea why that happened.I have found a few things online about this issue, but none of the problems seems just like what I am seeing. This environment is the only one without a dash in the name, and the only one with a core.js with a different date modified time. That is about all I have in the way of clues other than the fact that no clues at all is sort of a clue in itself.Can anyone offer me a shred of hope? I would love tobe able to fixthis problem.
December 1st, 2009 10:33pm

Hi. I am having the same exact issue with my Production version of MOSS 2007 - I click on Send To > Email a Link and absolutely NOTHING happens. No error, no launch of my mail client or New Memo (Lotus Notes), nothing. It is as if I did not even click on anything, although the other context menu items work perfectly. And it works perfect in DEV and TEST...very bizarre. Did you ever find a fix for this?
Free Windows Admin Tool Kit Click here and download it now
February 10th, 2010 9:46pm

For us the problem was our core.js file. We installed SP2 and that fixed it in all our environments but one. Go figure. In the case of the one environment that did not get fixed by replacing that file by installing SP2, we found one other JS file that needed to get replaced. It was INIT.js in the \12\template\layouts\1033 folder The correct dates and sizes of these files are as follows:\12\template\layouts\1033\core.js 259 kb 2/12/2009\12\template\layouts\1033\INIT.js 68 kb 11/21/2008
February 11th, 2010 3:59pm

Hi all. One question regarding the core.js file - can I just take that from any other Sharepoint server and copy - paste it to the server having the issue? All of them are running SP2, but I am wondering if the files are identical between any given Sharepoint installation? How did you "replace" the one JS file that was not fixed by SP2?Thanks!
Free Windows Admin Tool Kit Click here and download it now
February 17th, 2010 7:54pm

Hello again. In addition to my post below, I did check my size and date stamps for core and INIT. My core files match exactly to what you have above on both my DEV (working) and PROD (not working). However, my INIT.js on DEV matches above, but the file on PROD (not working) is only 67 kb with a date of 9/21/2008. Perhaps this is the issue?Same question applies, though - can I just copy the one from DEV onto the PROD server without fear?Thanks!
February 17th, 2010 8:02pm

And finally (my replies are in reverse order), I ran a compare tool against the two INIT.js files and it found zero differences. So other than size and date, what is the difference? Wierd that one reports as 67 kb and the other as 68 kb, though...Confused...
Free Windows Admin Tool Kit Click here and download it now
February 17th, 2010 8:14pm

Yes you can copy and paste from one server to the other and that is how we did it. Of course we took the precaution of first making a copy of the file that we were going to replace (Call it INIT.js.old) and then pasted the good file in the directory on all web front end servers. That was all it took. Let me know if this works for you. I was certainly relieved when it fixed our installation.
February 24th, 2010 4:42pm

I have no idea what the difference could be, but rest assured there must be something as obviously it is being reported out as being different by the file system. Some things I cannot wonder too much about or I will go crazy. I am happy when I just put in the fix and it works. If someone else can explain this anomaly then that will be icing on the cake.
Free Windows Admin Tool Kit Click here and download it now
February 24th, 2010 4:49pm

Well...so I copied the INIT.js file from my DEV environment to my TEST (previously not working) and my PROD (also not working) and now they both work with the Send To > Email a Link function. Super! IIS did hang on a restart (probably unrelated), so I ended up just rebooting all WFE servers, but after they came back up all functions are normal! Thank you for your help! Now I just have to find that fix for the silly URL when it creates the hyperlink in my mail system (I use Lotus Notes). My link appears as: http://sharepoint.kendle.com/IT/ITIC/EIPS/enterpriseadmin/Knowledge%20Base/Kendle%20AD%20Replication%20and%20Sites%20Audit%20-%20Proposed%20Replication%20Topology.vsd And even though it will work internally, it looks ugly and is bound to get some questions from users. I think I have seen a fix to strip out the %20 (they represent spaces in the URL)... Thanks again!
February 26th, 2010 12:53am

No problem, wish this post had been here when I ran into this LOL.I found one more helpful link that is sort of related and it gives a list of how all of the files should look apfter a SP2 update.http://sharepointdevwiki.com/display/SharePointAdministrationWiki/SharePoint+12+Hive+File+Differences+from+SP1+to+SP2
Free Windows Admin Tool Kit Click here and download it now
February 26th, 2010 4:46pm

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics