Interactive Sort does not work with SubReports
Hello All, I have a subreport that has interactive sort on one of the columns in a table. The interactive sort works well when i run the subreport. But when i run the parent report that contains the subreport then the interactive sorting does not work. Has anyone come across this issue, any help will be greatly appreciated. Thanks a lot! Mohit
November 19th, 2007 8:29pm

I suppose you are running this on the report server. What is the exact version of the report server? Is SP2 installed? -- Robert
Free Windows Admin Tool Kit Click here and download it now
November 19th, 2007 10:16pm

I have created these reports using VS 2005. I am testing these reports from Visual Studio 2005. Let me know if you need anything further info. Thanks, Mohit
November 20th, 2007 12:44am

What is the version shown for SQL Server Reporting Services when you go to Help -> About and scroll down the list of installed products? Is it at least 9.00.3042.00 or later? -- Robert
Free Windows Admin Tool Kit Click here and download it now
November 20th, 2007 3:46am

Hello Robert, I am using " Microsoft SQL Server Reporting Services Designers Version 9.00.1399.00 ". Will upgrading to "9.00.3042.00 " resolve this issue? Where can i find this version of " SQL Server Reporting Services " Your help is greatly appreciated. Thanks, Mohit
November 20th, 2007 5:31pm

Download SQL Server 2005 Service Pack 2 from here: http://www.microsoft.com/downloads/details.aspx?displaylang=en&FamilyID=D07219B2-1E23-49C8-8F0C-63FA18F26D3A Install it on your client machine and your report server. -- Robert
Free Windows Admin Tool Kit Click here and download it now
November 20th, 2007 7:46pm

Robert, I have installed SP2 on the server as well as the client machine. My machine now has SSRS version 9.00.3042.00, but this has not resolved my issue. Any ideas what could be causing this issue. Appreciate your help. Thanks, Mohit
November 26th, 2007 11:08pm

We would need more information to further look into this. One option you can try is to put together a small repro based onsimple main/sub reports and AdventureWorks or Northwind as data source, andfile a bug via http://connect.microsoft.com -- Robert
Free Windows Admin Tool Kit Click here and download it now
November 28th, 2007 6:28am

Has this been fixed? I'm getting the same issue with SP2 installed.
February 21st, 2008 10:05pm

Our company is also experiencing this problem. The interactive sort does not work with subreports. SQL Server 2005 Service Pack 2 has been installed as recommended in a previous response. Reports are created on the local side within a Windows application. Does a workaround exist? Is there a hot fix, update, etc. available?
Free Windows Admin Tool Kit Click here and download it now
March 14th, 2008 9:53pm

Make sure you set the "data region" or "grouping" properly for the sort expression. Go to the interactive sort tab of the Colum which you have the issue. Then go to the "scope" section and select the option Chose data region or grouping then select the group from the drop down. In order to make sure if you have any groupings.... do this. In the design view of the report, go to the report table properties, and then go to the groups tab, here you will see the list of groups if you have defined. I had similar kind of issue and it resolved doing this. hope this will help to some one. thanks
July 9th, 2008 2:11am

Hi, I am facing the same issue. I am using MS SQL Server 2008 R2. Still it looks this issue has not been resolved. I have lot of sub reports added in main report. When I run the sub report individually, the interactive sort works fine. But when we use the same reports as a sub report, the interactive sort doesn't work on main report. Could anyone help?
Free Windows Admin Tool Kit Click here and download it now
April 4th, 2012 6:38am

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics