Installation throws up UAC permissions dialogue box

Hi,

I am using SCCM 2012 sp1 cu2, and my clients are Windows 7 sp1 x64.

I am trying to install MS Project 2010 sp1 standard x86 version as an application from a vbscript since I have custom settings in the xml file, so it just runs as setup.exe /config installproj.xml and it also runs a security.inf for permissioning.

It is also available to install for the user, but when I kick off the install the UAC box comes up and asks for admin credentials. Is there a setting which says run as administrator, like there is for packages?

If I run this as a package and select the run as adminstrator it all works.

How do I get passed this problem so I can install it as an applic

January 13th, 2014 1:53pm

Check your deployment type:

Properties > User Experience > Installation behavior. Install for system / Install for user.

http://www.niallbrady.com/2012/10/16/using-system-center-2012-configuration-manager-part-8-deploying-applications/

  • Proposed as answer by Jason SandysMVP 15 hours 54 minutes ago
  • Unproposed as answer by JazK 13 hours 54 minutes ago
Free Windows Admin Tool Kit Click here and download it now
January 13th, 2014 2:19pm

I have already checked the user experience and I have the Microsoft Project Install in the user context, (since everything we deploy is targeted at a user) as this particular deployment is a scripted application since it is running a vbs script. If it runs in the user context then it needs elevated permissions. If I try to run the install manually it as the user it also asks for permissions, which is fair enough, but SCCM has always been clever to run with administrative permissions.

Do I have to leave this application as a package which works, rather than as an application? If I do then I miss out on the benefits of running these deployments as applications.

January 13th, 2014 5:52pm

The point is that you must set it to "Install for system"; doing this will cause it to elevate the permissions and thus avoid UAC. "Install for User" using the user's permissions.

Don't confuse this setting with targeting systems or users with the deployment; they are different things.

Free Windows Admin Tool Kit Click here and download it now
January 13th, 2014 6:08pm

Check your deployment type:

Properties > User Experience > Installation behavior. Install for system / Install for user.

http://www.niallbrady.com/2012/10/16/using-system-center-2012-configuration-manager-part-8-deploying-applications/

  • Proposed as answer by Jason SandysMVP Monday, January 13, 2014 8:28 PM
  • Unproposed as answer by JazK Monday, January 13, 2014 10:27 PM
January 13th, 2014 10:15pm

ah I see.

Thanks

Free Windows Admin Tool Kit Click here and download it now
January 14th, 2014 5:05pm

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics