Installation of ConfigMgr 2012 R2 SP1 in installation with MP/DP's in untrusted domains

Hi,

I have an ConfigMgr 2012 R2 installation with one primary server (In trusted domain) and two servers with MP/DP in untrusted domains.

When I try to install SP1 I get the following warnings for the servers in the untrusted domains.

Prequisite check warnings

Because they are only warnings I can continue the installation but do I dare that?

If I continue how can I then later check that the DP/MP's in the untrusted domains indeed got updated? The normal "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\SMS\Setup\CULevel" does not exist on the servers that are only MP/DP's.

May 27th, 2015 3:25am

Hi Thomas,

If you select each warning or check the ConfigMgrPrereg.log, you should get more info on each warning.

During (and after) the installation I recommend that you monitor the sitecomp.log to verify that all roles are upgraded successfully. If you have a lot of remote servers it might take some time to com

Free Windows Admin Tool Kit Click here and download it now
May 27th, 2015 3:43am

Since the account you are running setup or the pre-req checker probably doesn't have permissions to access the systems in that untrusted forest/domain, neither can the pre-req checker so it gives off these false errors.

Without knowing the details of your hierarchy, I can't suggest a way around this specifically although you could try running setup or the pre-req checker using runas from the command-line and the netonly switch to specify alternate credentials for checking the systems in the other untrusted domain.

Ultimately, your credentials are not used to actually perform the upgrade on remote site systems though so if that is indeed the issue here, then its a non-issue although an unnerving one at that.

May 27th, 2015 8:58am

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics