Install Software that requires "Allow User Interaction" during Task Sequence deployment
I think you mis-interpreted Niall's suggestion. The purpose of ServiceUI.exe is to make the UI visible to the interactive session during a TS. If your setup is already silent, then ServiceUI.exe doesn't get you anything. What Niall is suggesting is that the setup doesn't like being installed as the local SYSTEM account which is what the TS is using. The only way to simulate this is to kick off the installation using psexec -s (not inside a TS, just for testing from within an already installed system). Running as local SYSTEM has peculiarities all its own especially when (bad) setup programs try to do user specific things. This will verify that this is indeed the issue -- based on your description above, it sounds like it may be. If it fails the same way using psexec -s, then you can try running it in the TS using a command-line task with the alternate credentials option enabled.Jason | | Twitter @JasonSandys
November 19th, 2011 10:12am
Free Windows Admin Tool Kit Click here and download it now
November 19th, 2011 11:24am

Thanks Sandy, I retried within the psexec -si cmd.exe command (note: I used interactive switch), and this time it completed successfully. If I only used psexec -s cmd.exe (non-interactive) then the install did not start until I ended the cmd window. By the way please disregard the error as I saw earlier (see my second post) when I mistakenly ran the install twice at the same time. So does using psexec -si cmd.exe successfully eliminate the local system account as the possible cause? By the way this application does install via GPO Startup Script (using local system account) which doubly comfirms the local system account does not cause the problem.
November 19th, 2011 7:22pm

Who's Sandy? I do think that eliminates the bad installatio behaviors due to being installed as the SYSTEM account but does not leave much else to go on. It does sound like the program is doing something interactive though and thus requires access to the interactive desktop which isn't present during the TS. At this point, I would try repacking the app and/or tell the vendor to repackage it for me.Jason | | Twitter @JasonSandys
Free Windows Admin Tool Kit Click here and download it now
November 19th, 2011 8:16pm

My apologies Jason - that was what I was afraid of, ie using Wise, at which point I lose any vendor support for the installation whereby they can point the finger at future glitch at the wise install.. It would be nice if TS had some debug or logging mechanism as I am entirely dependant on the vendor on this - is there a way to somehow run Process Monitor for TS?
November 19th, 2011 8:47pm

Hi Bob, unfortunately your answer refers to what I was trying in my initial post ("%ToolRoot%\ServiceUI.exe) The installation I am trying to put into Task Sequence spawns multiple other exe's which themselves do not interact with the task sequence session and hang. I have given up on pursuing this and decided the simplest solution is to advertise the Package/Program seperately and run it straight after the TS. This is a bit disappointing but I hve to accept defeat and live with a workaround.
Free Windows Admin Tool Kit Click here and download it now
November 20th, 2011 12:08am

I have a corporate finance application which I need to deploy via Task Sequence as part of an OSD build. The application succeeds if I run "Allow user interaction" but this is not help as Task Sequences do not allow. I have discovered an alternative has been posted is to use a command line with the MDT 2010 and run "%ToolRoot%\ServiceUI.exe -process:tsprogressui.exe MyCustomApplication.exe". This alternative method allows my setup.exe to virtually complete the installation but I cannot determine what is stopping it. The vendor can only give limited support and are trying to help but due to my short deadlines this may be too late, if at all. The software provides limited logging but all it shows me no errors/warnings and the vendor cannot isolate the cause. The logging does show that the install reaches near completion and during dome "file associations" checks it stops logging (it has stopped in a couple of different places very close to each other) Do I have any way to debug the problem as I am solely relying on the software's logging due to the install being silently run inside a Task Sequence? The softwares setup.exe has properties of being a VBAUI installer - if that helps?
November 20th, 2011 1:16am

try using psexec (from sysinternals) to debug the situation, by running a command prompt as System (local system) and installing the software via that command prompt, then you'll be able to mimick how the task sequence is installing the software, it may reveal your issue My step by step SCCM Guides I'm on Twitter > ncbrady
Free Windows Admin Tool Kit Click here and download it now
November 20th, 2011 1:41am

Hi Niall, thanks for the quick reply.. I have tried running "psexec -s -h cmd" then running the setup.exe from there with the following results: The setup does not reach the same point I got using "%ToolRoot%\ServiceUI.exe -process:tsprogressui.exe Setup.exe" inside SCCM. This seems to show the installation fails with "invalid procedure call" but again this is earlier in the install. Perhaps I have to somehow emulate the ServiceUI within and psexec -s command? Not sure how I can do this?
November 20th, 2011 2:52am

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics