InfoPath cannot load the view. The view may have been modifed to contain unsupported HTML such as frames.


I'm running InfoPath 2013 Designer and I'm experiencing a very annoying bug. Whenever I try to open a Infopath file I get the error, "InfoPath cannot load the view. The view may have been modifed to contain unsupported HTML such as frames." Sometimes it opens without a problem but most the time I get this error message. The strange thing is that I can create a new form without any frames, save it and then when I go to open it have the same problem. I've tried reinstalling InfoPath but it didn't help.

Please help!!!

Thanks in Advance,

Mark Elliott

Windows 7 Home Premium 64 bit; Internet Explorer 11; Office 2013 Pro

April 28th, 2014 10:35pm

Hi Elliyeti,

According to your description, my understanding is that the error occurred when opening the form in InfoPath.

This issue may be due to the original form is corrupted, you can also try the steps below of the original form for troubleshooting:

  1. Renaming the .XSN to .CAB.
  2. Expanding the .CAB file and hacking either the individual xsl views and/or the manifest.xsf to remove the offending view(s).
  3. Repacking the CAB file and renaming back to .XSN.

Best regards.


Free Windows Admin Tool Kit Click here and download it now
April 30th, 2014 1:46am

Hello, I just wanted to chime in. We have the same problem in our environment. We have narrowed it down to a Microsoft update, but are not sure which one, since 30 - 40 were pushed at the same time. We are in the process of troubleshooting and will be happy to update this thread when we know more. Thanks!
May 29th, 2014 9:51pm

I eventually has to take drastic action and I started afresh, reinstalling Windows 7, Office and InfoPath. It now works without a problem. I know this isn't a great solution but I had run out of time to solve the problem by other means.
Free Windows Admin Tool Kit Click here and download it now
June 4th, 2014 10:38pm

How does unsupported HTML get in the form if you only use infopath tools to create it?

I am having the same problem, however, if I keep trying to open it, I might get that error 7-15 times and then on the 16th try, it will open, (so much for the definition of insanity).

It happens anytime I switch between any of the three views.  Deleting the view means starting the whole form over and I can speak with experience in saying it's going to happen with the new one as well so deleting views isn't an option.
  • Edited by jenwearing Monday, June 09, 2014 8:26 PM
June 9th, 2014 8:10pm

Hello... were you able to figure out which MS update caused the issue? I'm getting this error when using InfoPath 2013 but not when using 2010. In a new laptop with latest update does not works. Old laptop with 2010 and no latest updates worked perfect.

Thank you!

Free Windows Admin Tool Kit Click here and download it now
July 15th, 2014 8:20pm

I'm getting the same exact thing. Design a new 2013 form - add a couple of tables and save then try to open it in design mode again. A standard install with no third party tool (we even run security essentials).


August 7th, 2014 4:14am

I'm getting the same exact thing now too. I'm using InfoPath Designer for SharePoint 2010 forms and both InfoPath Designer 2013 and 2010 are giving the same error message when opening form templates. This is a new Windows 7 build on a new laptop, so the bad Update theory makes sense. My old laptop works just fine, but I'm sure it's a few patches behind. Please let us know if anyone finds the culprit here.
Free Windows Admin Tool Kit Click here and download it now
September 3rd, 2014 6:48pm

This post has not been answered.  I have created the forms with infopath 2013 and then saved them.  The form will then not open with the above reported error.  Why will infopath not design a form created by infopth?
November 5th, 2014 6:49pm

Has anybody figured this out? I have the same problem.  InfoPath 2013 will not open any files from one computer which all work from another computer with the same version of InfoPath so this basically rules out file corruption. (The files are in a network share).  Both computer have InfoPath 2013. If I reboot the computer in question it will sometimes work then goes back to the error. 

The only difference between this computer an all the others is that this one has a bunch of Office 2010 updates since it has SharePoint 2010 designer installed, (not office).  I did try to uninstall the updates but the problem has not been resolved.  This is the second time this happens.  Last time I had to completely remove Office 2013 & SharePoint designer then used the Windows rollback feature and finally reinstall office 2013.  Everything worked great until I installed SharePoint 2010 designer then after a few updates the problem resurfaced.

This is really annoying, I cant believe its not happening to more people.

Free Windows Admin Tool Kit Click here and download it now
December 17th, 2014 1:27pm


Voir les bonnes pratiques de DEV Sharepoint



December 17th, 2014 1:49pm

It's kind of extreme case for me. Today I installed visual  studio 2012 on my laptop because I try to write some code for the form, and I can't open any of the form template file any more. I even tried to create a blank form, save it, then close it, and reopen, boom, this error appears...

Now super frustrated as nothing can be done to fix it, probably have to re-install system...

Free Windows Admin Tool Kit Click here and download it now
February 6th, 2015 11:39pm

Same issues here with both InfoPath 2010 and 2013.  The common thread I've found is that this happens after IE 11 is installed.  What is annoying me the most is that I have one machine with IE 11 that I cannot recreate the problem on at all.  All other machines I've tried will sporadically fail to open the form in Design.  I'm creating blank forms from the Blank Form template and not modifying or adding anything and the error occurs over half of the time when I try to design the saved blank form. 

March 19th, 2015 3:17pm

Why is Microsoft not responding these posts?  I also have spent the last month dealing with this problem and have gotten no where.  The error appears intermittently with all forms I have created.  I never had this error on my old laptop but now am getting it all the time on the new one.  Same operation system and Microsoft Office version 201o as before but this laptop has IE11.  It should be a problem as all my forms are set to use InfoPath Filler, not the browser.  This is obviously a defect.

Also telling us to start unpacking system files seems a ridiculous solution for people who are not developers.  I could see if I had customized my forms but I am doing everything through the application.

  • Edited by sandyol Tuesday, July 07, 2015 4:56 PM
Free Windows Admin Tool Kit Click here and download it now
July 7th, 2015 4:53pm

I had the same problem where all my infopath forms unable to load with above error message, after I migrated the forms from old laptop to new one. Downgrade IE version of new laptop from IE11 to IE8 solved my problem. 

August 2nd, 2015 10:30pm

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics