IRM not working with MOSS
Hi all,I installed an IRM server following one of the tutorials available and after some headbagging (IIS reinstalling, root certificate server reprovisioning) I got it to work with Office clients. The problem was that after configuring MOSS to use IRM I can't get it to work.when I try to open a previously uploaded document from a IRM enabled document library I get from word: "link to the document is not a valid link"If I do "Download a copy", the browser returns: "Exception from HRESULT: 0x80041056"If I access the document link directly in the browser (using copy shortcut and using it in the address bar), the browser returns: "The IRM protector for this file encoutered an unexpected error"To try to solve it:I added the MOSS machine account, the central administration app pool account and the intranet app pool acount to the infamous c:\InetPub\wwwroot\_wmcs\Certification\ServerCertification.asmx . In despair I even added everyone fullcontrol just to be shure it wasn't a permission issue... But nothing worked and the worst part is that I get no errors in any eventviewer, and in the MOSS logs I just get:Application error when access /_layouts/download.aspx, Error=Exception from HRESULT: 0x80041056 at Microsoft.SharePoint.Library.SPRequestInternalClass.GetFileAsByteArray(String bstrUrl, String bstrWebRelativeUrl, Boolean bHonorLevel, Byte iLevel, OpenBinaryFlags grfob) at Microsoft.SharePoint.Library.SPRequest.GetFileAsByteArray(String bstrUrl, String bstrWebRelativeUrl, Boolean bHonorLevel, Byte iLevel, OpenBinaryFlags grfob)Which is useless....Is anyone has any ideas...Regards,Raul Queiroga
September 19th, 2008 9:27pm

Hi Raul, This is a known issue of SharePoint product. Our product group has investigated the issue, but they dont have an estimate for how long it will take. If this is a business critical issue, please contact Microsoft product/customer support services. Thanks for your understanding.-lambertPosting is provided "AS IS" with no warranties, and confers no rights.
Free Windows Admin Tool Kit Click here and download it now
September 22nd, 2008 12:39pm

Hi,thanks for the quick response, is there any workaround? Is this caused by something in particular?That functionality is crucial for our client, can you tell me the reference for this issue in the product group so it's easier for us to reference it with Microsoft product/customer support services.Regards,RaulQ
September 22nd, 2008 4:35pm

Hi Raul, Thanks for choosing Microsoft product/customer support services. Based on our confidential policy, I could not share the information for you. However, you could provide the thread information and my name to the support engineer if you opened a case in Microsoft product/customer support services. I will provide necessary information to the support engineer and help you solve your problem as soon as possible. Thanks for your understanding. -lambertPosting is provided "AS IS" with no warranties, and confers no rights.
Free Windows Admin Tool Kit Click here and download it now
September 23rd, 2008 6:48am

Hi, fortunately the error stopped when we tried 2 days later (after the weekend), so I assume it was something regarding RMS cache (although I thought it only afected group expansions), but don't know for sure... Regards,
October 13th, 2008 1:01pm

Hi, I am using MOSS 2007 enabled with IRM (RMS server SP2) and client WRM SP2 installed. I am having an issue while opening a document which is having "Read" permissions to a specific user. It throws an information message "Could not open 'http://server/site1/rmslib/mydoc.doc" Once I click on "OK" , I get Visual Basic Error Message box with "End", "Debug" and "Help" buttons Run-time Error '1177' The Document name or Pat is not valid.Try one or more of the follwing*Check the path to make sure it was typed correctly.*On the file menu, click Open. Search for the file using this dialogbox. By Clicking the Debug button, it opens up VBA debugmode. Private Sub TmpDDE()WordBasic.AppShowRem _DDE_ReadWriteOnSaveWordBasic.FileOpen Name "http://server/site1/rmslib/mydoc.doc", Revert:=0End Sub This happens only when I try to open in read mode and user has "Read" permission I am not able to understand exact issue. Any help is much appreciated. Thanks,Vijay
Free Windows Admin Tool Kit Click here and download it now
October 21st, 2008 10:00pm

Has anyone found a real solution for this? I have the following option enabled in the irm settings on my list: Allow users to access content programmatically I can't move or copy a file to another library, nor can i do the following operation trough code: SPFile file = otherFile.OpenBinary(); If i disable irm on my list, all operations are possible.... I really need to use irm on the list, but this way i can't execute the code i need too. Someone help?
June 18th, 2009 5:53pm

Klaas, you seem to have misunderstood the idea of "propose as answer". It is to suggest that a reply is an answer to the question, so that a Moderator sees the post and can then decide if the post really does solve the question in the thread. Here the post you proposed as an answer was from someone who was *looking* for an answer (like you). This wasn't a candidate for Propose as Answer!WSS FAQ sites: and Total list of WSS 3.0 / MOSS 2007 Books (including foreign language)
Free Windows Admin Tool Kit Click here and download it now
June 18th, 2009 6:00pm

My mistake. I clicked the wrong button.
June 18th, 2009 7:12pm

Any updates on this anyone? Thanks, Fraser
Free Windows Admin Tool Kit Click here and download it now
July 21st, 2009 12:57pm

Sorry wrong button preesed above.We had the same problem it turned out that our security ticket from the users used all the kernel memory. Raising the kernelmemory solved the problem.BestAnders
November 10th, 2009 9:32pm

hi does anybody have the answer of the error HRESULT:0x80041056 I have the same error,but can not resolve.
Free Windows Admin Tool Kit Click here and download it now
June 9th, 2010 12:00pm

Hello, We had this error... to make it short - happened after migrating from V1.SP2 to 2008R2 after not all settings were transfered. To resolve - we just followed "Integrating AD RMS and SharePoint Server 2007" on TechNet - specifically adding SPP Service account and computer accounts of the SPP farm front-ends has resolved the issue. For us it was not evident from a start as service account account was activated for one domain and then we added a federation support with AD FS - that's when downloading under a user account from another forest we saw this error. Anyway - might help you by reviewing your security settings on a ServerCertification.asmx file. All the Best
October 6th, 2010 12:20am

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics