Hyper-V guest can ping internet, but cannot browse.

I have created a Hyper-V machine with the intent of testing various OSes, but I've run into a bit of a snag.  I am able to use command prompt to ping and perform nslookup.  Both of these services work.  I am UNable to access the internet with a browser, however.  This also includes Windows Update.  They simply time out.  I have tried both with a dynamic IP from my router, a static assigned by router with automatic config within the VM and static assigned via the router with static setup via adapter properties.  I have also tried recreating the virtual switch, and reinstalling the guest OS.  My question is, what is causing the problem, and how do I go about fixing it?

Host Machine:

Intel Core i7-920 2.67 GHz

Intel DX58SO Motherboard with integrated NIC


Guest Machine:

Two Cores


Network Setup:

Modem -> Ubiquiti EdgeRouter POE -> Host Machine

all connections are on

Host Computer has static IP

Guest OS has static IP

May 24th, 2015 1:08am

can you browse on the host?

are the dns-server-settings on host and vm correct?

can you do queries with nslookup?

the firewalls are not blocking dns-queries?

Free Windows Admin Tool Kit Click here and download it now
May 24th, 2015 2:59am

Browsing on the host works fine, DNS works fine on both, nslookup works on both, and the only internal firewalls (excluding router NATs) are the integrated windows firewall, unmodified from original installation.  No rules relating to dns.  Regardless, I cannot browse via IP either, though I can ping.  I have highlighted the relevant sections from the guest in the attached screenshot.
May 24th, 2015 3:04am

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics