How do I get the TS gateway webpart in to MOSS 2007?
So I have installed Windows server 2008 with at Terminal service gateway, and I must say it work like a charm. I can hardly wait to remove my old Citrix server. But that a side, the document states that I can use the webpart from the TS web page in SharePoint. Does anyone know how to do that? All I can see in c:\windows\web\ts\bin a file called tsportalwebpart.dll, but I dont know what to do with it. Does anyone have a suggestion?
January 30th, 2008 11:58pm

Please go to: You will find this document: Step_by_Step_Guide_to_Customizing_TS_Web_Access_by_Using_Windows_SharePoint It will tell you exactly how to get remoteApp Icons into WSS or MOSS. but, I followed every step in the document, in the last part you have the ability to add a new webpart containing the icons for the programs you have published via TS\RemoteApp. When I did that I was givenan HTTP 403 error, this has to do with permissions. Most probarly I added a webpart for which I do not have the permission to see it. And if this webpart, in my case, is part of the sharepoint home page you do not see anything anymore. No more site settings, ... nothing. How am able to change webpart-permissions or remove the webpart without the possibility get into sharepoint? (Chicken and the egg) Greetz Freddy
Free Windows Admin Tool Kit Click here and download it now
February 27th, 2008 2:09pm

Finally I got time to set it up. It works like a charm, thanks again.
April 28th, 2008 12:47pm

I've installed the TS Web Access role on my MOSS server (running 2008 x64), but I get this error when I add the TS Portal Web Part to a page... The "TSPortalWebPart" Web Part appears to be causing a problem. Could not find a part of the path 'C:\inetpub\wwwroot\wss\VirtualDirectories\sharepoint80\services\_wpresources\TSPortalWebPart\\images\rapwait.gif'. I even went so far as to copy rapwait.gif from C:\Windows\Web\ts\images to C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\wpresources\TSPortalWebPart\\images directory and set permissions as needed. The thing that gets me is the "\services\" portion of the path in the error. This directorydoes not exist in the file system or when I look at the virtual directory in IIS. Anyone have any input or suggestions?
Free Windows Admin Tool Kit Click here and download it now
May 18th, 2008 7:48am

After a successful test, I tried to moveit over to the production system. There I get the exact same error as you Eric. I have tried Daniels solution but it didnt seem to help in my case.
June 23rd, 2008 10:31am

I followed all of the instructions in the Microsoft guide. However, when I go to create a new Web Part, "TSPortalwebPart" is not in the list. I have went over my steps at least 6 or 7 times and exactly recopied the code that I was supposed to add to my web.config file. I have full permission over the site.
Free Windows Admin Tool Kit Click here and download it now
June 25th, 2008 8:18pm

Jay, I suspect its the same problem with the default path not being set properly when the system first starts up. For us I created a tab on our MOSS home page so the path is set the first time someone accesses the site. I have read MOSS does some kinda of reset at night which forces the just-in-time compiler to re-compile the site. This can cause up to a 45 second delay for the first person who logs in. Ive downloaded a warm up script thats supposed to warm up the site but havent tested it yet. You may be able to use a similar script to set the path. James
December 8th, 2008 8:38pm

James,I'm pretty sure your correct. If I add the part to the main page (and only the main page), it works just fine without a problem. As soon as I add it to a subsite, it errors outon first accessafter startup with the subsitein the path. I will try your suggestion on the startup.This has to be a permissions thing, but it's got me stumped!Jay
Free Windows Admin Tool Kit Click here and download it now
December 11th, 2008 2:14pm

I have implemented some changes and the TSPortalWebPart has been stable for nearly 6 days now. The following is the process that I have gone through. This example assumes I have 2 subsites to the root SITEA and SITEB. 1. Identify the website experiencing the issue. 2. Make a backup copy of your \system32\inetsrv\config\applicationHost.config file. 3. Open the \system32\inetsrv\config\applicationHost.config file using Notepad or an XML editor. 4. Locate the <sites> section. 5. Locate your specific websites subsection within <sites> (in my case it was<site name="SharePoint - 80" id="1412019433" serverAutoStart="true"> )6. Note there are several lines beginning <virtualDirectory path= 7. After the first of these entries, add the following line: <virtualDirectory path="/SITEA/_wpresources" physicalPath="C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\wpresources" /><virtualDirectory path="/SITEB/_wpresources" physicalPath="C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\wpresources" /> 8. Save your changes to the file. 9. From a Command Prompt, run IISRESET.Then all you need to do is is change this file each time you add a new subsite.CheersPaul
January 21st, 2009 11:33am

Can this be implemented on a 2003 server running MOSS? I have 2008 server running the TS server.
Free Windows Admin Tool Kit Click here and download it now
March 20th, 2009 11:15pm

Hi Daniel, Wow, this Microsoft documentation is some of the worst I've tried to follow. It just doesn't work. It doesn't take into account RD 6.1 and Server 2008 R2 it seems like. My problem is, in IIS, I have the Default Site folder installed with the WSS folder, and the RD Web Services is configured. When I install SharePoint it takes port 80, and then the Default Site stops. So.. that breaks stuff because the WSS folder that you edit the web.config is located there right? Someone needs to revisit this documentation, and put some screen shots in. Some of the other people who posted on here are using the instead of for Server 2008 R2. In the MS docs, you'll find it either or, and listed for either or 2008/2008 R2. Just need some simple steps forward to make this work if anyone can provide them. Thanks, Rob
June 11th, 2010 12:58am

RobF- you need to add a host header to your sharepoint-80 site and then the default site for RDWeb can be restarted. but, adding a hostheader will only work if you also add a dns entry of the same name to point to that server or IP address. now i have a question to add to this discussion: can i do the same thing in sharepoint foundation 2010? i have been searching all day for documentation and can't find any, so i am going to just try the step-by-step instructions for WSS07 and see if it works. i'll post an update with results.MCITP:Enterprise Admin MCSA, MCSE, MCDBA
Free Windows Admin Tool Kit Click here and download it now
October 28th, 2010 4:07pm

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics