How do I avoid Windows login prompt?
Hello, I have SQL Server 2005 Reporting Services (SSRS) running on a Windows Server 2003 machine. Everything works fine, except every time a user attempts to view a report they get the windows login prompt. If they enter their domain credentials they can view the report no problem. The report manager security works fine as far as allowing particular users to be content managers, browser only, etc., but users should not have to enter their domain loginwhen they want to view a report...that should be handledautomatically. If I am physically logged on to the report server, I do not get prompted for a login. I don't get it, I have worked with reporting services in the past where this was never an issue? I should mention I have been looking around online to find a solution to this and found many people recommending changes to IIS. The default website is set to Enable Anonymous Login under Directory Security. Under the default website, Reports and Report Server are set to Integrated Windows Authentication. Any help would be greatly appreciated b/c I am just plain stuck!
June 30th, 2008 4:20pm

Hi Please try setting the internet explorer security setting to Automatic logon in intranet zone.. This is not prompt the user to enter domain credentials again and again Hope this helps Regards Smitha.B
Free Windows Admin Tool Kit Click here and download it now
June 30th, 2008 5:15pm

Hi Smitha, isn't that a client setting? Then you would have to have every client change their IE settings in order to login without the prompt, no? Is there a way to do this on the server side (or maybe I'm on the wrong path here), as we're experiencing similar behavior
June 30th, 2008 6:10pm

Hi Smitha,Thanks you for your quick response. However, the client is already set to Automatic Logon Only In Intranet Zone. I tried changing it to Automatic Logon With Current User Name and Password. Although this seems to work, the behavior of report manager is odd when a user tries to view a report that he/she does not have permissions to view. Instead of saying something like "You are not allowed to view this report", the browser just shows the report manager header???Is there anyway to configure the report manger or IIS instead of going around to each client?Thanks
Free Windows Admin Tool Kit Click here and download it now
June 30th, 2008 6:42pm

Hi Please try the following Steps.. This may help you Open IIS Manager. Right-click "ReportServer" virtual directory and click "Properties". Click "Directory Security". In Authentication and access control, click "Edit" to open the Authentication Methods dialog box. Clear "Enable anonymous access" check box. Check "Integrated Windows authentication". Regards Smitha.B
July 1st, 2008 6:57am

Hi,Sorry for jumping in. I am facing similar problem and my question is what UID and password you are using? Regards,Farouk Yew Abdullah
Free Windows Admin Tool Kit Click here and download it now
July 1st, 2008 8:26am

Hi Smitha, Thanks for the responses. I am using SSRS2008 and facing the same issue. It will not fair asking every client to change their browser settings to view the reports. In SSRS 2008 , In IIS there is no such Virtual Directory to set the authentication. Really its being a challenge to sort out this issue. Cab you help me on this? Thanks, Senthilselvan.D
April 29th, 2011 3:56pm

open your ssrs service configuration manager. look for the Execution menu item and set an account for execution. pcname\username or domain\username, and password then go to your http://server:port/reports and in site settings(top right links) add the previous account as user or admin finally in the folder icon(toolbar) go to his options and add the previous account with the desired privileges. tricks: if your reports have been deployed you may delete them and deploy them again. if your changes doesn´t apply stop and restart your ssrs service in the manager. i hope this helps you.me.
Free Windows Admin Tool Kit Click here and download it now
April 29th, 2011 4:09pm

Hi, Thanks for the response. As i am havind many folder icon(toolbar) , in which i hv to add the account, Nothing is asking as accounts. Thanks
April 30th, 2011 2:50am

hi again the ssrs service config is in program files/sql server xxx/config tools/ssrs service config manager. more or less. in this config manager you can set an execution account(it must be a valid domain/pc-name, user, pass) once you click apply/accept and the service tells you it´s correct you have to give the privileges for this user to your reports folders. in your http:// server uri:port/reports at first you see the home, the initial folder for your reports, here you will find the "folder settings" inside this folder you must add the user(roles must be configured to this user) you want to grant access to the reports "contained" in this folder. it´s the same for site settings, add the required roles to grant access to your site at this user. these privileges are inherited when you create new report folders, i´m not sure if the existing folders are afected by the new configured role. worst case scenario you have to delete and re-deploy your reports in new folders, or grant access to your user, item by item. i hope this is clear enough. me.
Free Windows Admin Tool Kit Click here and download it now
May 3rd, 2011 11:40am

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics