High CPU usage for the ReportingServicesService.exe process on my SCCM 2012 SP1 server

Hi,

I've noticed for probably the last year or so that the ReportingServicesService.exe process on my SCCM 2012 SP1 server is always showing a high CPU usage.  The ReportingServicesService.exe process always seems to be using up a large amount of CPU and I've never understood why.  From looking at the SRSTP.log it appears that reporting services is scanning a large number folders on a repeated basis every couple of minutes.  I see these messages logged:

Folder [/ConfigMgr_P01/User Data and Profiles Health] is kept  $$<SMS_SRS_REPORTING_POINT><05-26-2015 14:04:29.781+420><thread=4352 (0x1100)>
Folder [/ConfigMgr_P01/Users] is kept  $$<SMS_SRS_REPORTING_POINT><05-26-2015 14:04:30.128+420><thread=4352 (0x1100)>
Folder [/ConfigMgr_P01/Virtual Applications] is kept  $$<SMS_SRS_REPORTING_POINT><05-26-2015 14:04:30.737+420><thread=4352 (0x1100)>
Folder [/ConfigMgr_P01/Wake On LAN] is kept  $$<SMS_SRS_REPORTING_POINT><05-26-2015 14:04:31.407+420><thread=4352 (0x1100)>
Folder [/ConfigMgr_P01] is kept  $$<SMS_SRS_REPORTING_POINT><05-26-2015 14:04:31.418+420><thread=4352 (0x1100)>
Invalid class   $$<SMS_SRS_REPORTING_POINT><05-26-2015 14:04:31.462+420><thread=4352 (0x1100)>
Could not retrieve the reporting service name for instance 'MSSQLSERVER'  $$<SMS_SRS_REPORTING_POINT><05-26-2015 14:04:31.474+420><thread=4352 (0x1100)>
Invalid class   $$<SMS_SRS_REPORTING_POINT><05-26-2015 14:04:31.502+420><thread=4352 (0x1100)>
Could not stop the reporting service ''  $$<SMS_SRS_REPORTING_POINT><05-26-2015 14:04:31.513+420><thread=4352 (0x1100)>
Confirmed the configuration of SRS role [ConfigMgr Report Users].  $$<SMS_SRS_REPORTING_POINT><05-26-2015 14:04:32.086+420><thread=4352 (0x1100)>
Confirmed the configuration of SRS role [ConfigMgr Report Administrators].  $$<SMS_SRS_REPORTING_POINT><05-26-2015 14:04:32.106+420><thread=4352 (0x1100)>
Root Folder exists  $$<SMS_SRS_REPORTING_POINT><05-26-2015 14:04:32.118+420><thread=4352 (0x1100)>
Successfully checked that the SRS web service is healthy on server topanga.kcicorp.com~  $$<SMS_SRS_REPORTING_POINT><05-26-2015 14:04:32.128+420><thread=4352 (0x1100)>
~Waiting for changes for 1 minutes  $$<SMS_SRS_REPORTING_POINT><05-26-2015 14:04:32.139+420><thread=4352 (0x1100)>

I've found a couple of posts here regarding this problem, and one that suggested a fix to the WMI classes for SSRS as a way to resolve the issue.  Has anyone else seen this problem?  Also has anyone tried the suggest WMI fix mentioned in this post?

https://social.technet.microsoft.com/Forums/en-US/e3443e9a-a2e3-4082-b184-dd1523e7bee6/high-cpu-usage-after-sccm-sp1-cu1?forum=configmanagergeneral

Thanks,

Nick

May 26th, 2015 5:15pm

Hi,

Have you installed cumulative updates for SCCM SP1? Please update the SCCM to the latest cumulative update for SP1 to see if the problem persists.

Best Regards,

Joyce

Free Windows Admin Tool Kit Click here and download it now
May 27th, 2015 3:31am

Hi,

I have applied CU3 for SCCM SP1.  I am going to apply SP2 now that it's available but I'm going to wait a bit before doing that to see if anyone has any issues.

I was hoping there was a simple fix for this issue.

Nick

May 27th, 2015 10:54am

Just to update. 

I ran the steps to update WMI described in

https://social.technet.microsoft.com/Forums/en-US/e3443e9a-a2e3-4082-b184-dd1523e7bee6/high-cpu-usage-after-sccm-sp1-cu1?forum=configmanagergeneral

Specifically

mofcomp.exe "C:\Program Files (x86)\Microsoft SQL Server\100\Shared\sqlmgmproviderxpsp2up.mof" to register WMI class for SQL (change path following you installation path)

And my ReportingServicesService.exe process now seems to be behaving normally and in the SRSTP.log I don't see the errors I saw before.

Nick

  • Marked as answer by Nick Palmer 15 hours 56 minutes ago
Free Windows Admin Tool Kit Click here and download it now
June 2nd, 2015 11:53am

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics