Hidden column shows whitespace
Team, any inputs? Regards, Eshwar.
July 4th, 2012 9:22am

Hi Team, I have a report in which one column has to been hidden all the time this has been used for color formatting. But the report is showing white space in reportviewer and when exported to pdf. I have set the property of this column to hidden still showing up white space. Is it possible avoid this? Thanks, Eshwar.
Free Windows Admin Tool Kit Click here and download it now
July 4th, 2012 11:44am

I do not think it is possible to avoid this. I had also this problem and unfortunately did not solve it.Best Regards,Uri Dimant SQL Server MVP,http://sqlblog.com/blogs/uri_dimant/ Blog : MS SQL Development and Optimization Blog : Large scale of database and cleansing
July 4th, 2012 11:47am

Is the column part of dataset? Why you have to put it in table then? You can get the data from the dataset with expression.
Free Windows Admin Tool Kit Click here and download it now
July 4th, 2012 11:52am

Hi, There is difference between setting hidden property on cell to setting hidden property on column. So, if you have set the hidden property on cell, set the same expression on tablix column. See if if this works.- Chintak (My Blog)
July 4th, 2012 11:54am

Hi There Thanks for your posting. can you please put that column as a last column and see if it make any difference for you Many Thanks Syed
Free Windows Admin Tool Kit Click here and download it now
July 4th, 2012 4:14pm

Hi There Thanks for your posting. can you please put that column as a last column and see if it make any difference for you Many Thanks Syed
July 4th, 2012 4:36pm

Thanks, It is already have it in the last column I tried removing the column and made it as first column but when tried deploying it throws an error: The definition of the report is invalid? what is this error? My report looks like this: The expression has to hide. It is matrix report Regards, Eshwar.
Free Windows Admin Tool Kit Click here and download it now
July 5th, 2012 12:03am

Hi There Thanks for your posting. Why you are trying to set the cell please try to hide the column. One thing which I am not sure why you are creating a columns if you are hiding the column.t you can use the expression from the dataset field if you need to use that column value for other calculation. Did you get my point? I might misunderstood but I could not see any reason why would you need a column if you hide the column completely. Please give some more details why would you need that column to be hidden Please update Many thanks Syed Qazafi Anjum
July 5th, 2012 12:23am

Correct Chintak, i have set both the cell and column property as hidden "true" and made the size of the column as 0in still it showing an white space. This is how it shows i am using this column to format the column color to show alternate colors. Regards, Eshwar.
Free Windows Admin Tool Kit Click here and download it now
July 5th, 2012 12:59am

Hi Eshwar, Thank you for posting. After reading your description, I am a little confused on the issue: You said the column in question had to be hidden all the time, but you also indicated that the column visibility is based on an expression. It seems that the target column is used for formatting columns color alternately, however, in the screenshot you posted, it's rows color that change alternately.Since it is a static column, even if the values in the column are referenced when you configure the matrix color, I don't think the column is essential. I am afraid the column is not hidden at all in the current situation. So, could you elaborate the issue for further analysis? What is the visibility expression of the target column? What is the expression that formats the color of the rows or columns? This will be helpful for us to reproduce the issue and help you out. Regards, Mike Yin
July 5th, 2012 3:57am

Syed, Thanks your solution helped to resolve it temporarily but what is the reason for the column been shown up even though i made it always hidden? Regards, Eshwar.
Free Windows Admin Tool Kit Click here and download it now
July 7th, 2012 1:55am

To make the column not visible without space between them: In design time simply select the related column, click with the right mouse button, choose Visibility column, then have three options: * Show * Hide * Show or hide based on an expression If you just hide the column without the need for handling the related column and click OK Hide If you want to handle the column display, for example, as a certain condition or not display, click Show or hide based on an expression (Define your condition through the IIF (x = parameter, True, False) Jefferson.
September 7th, 2012 3:11pm

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics