HealthService Event 7022
Event Type:ErrorEvent Source:HealthServiceEvent Category:Health Service Event ID:7022Date:19/03/2008Time:2:45:07 PMUser:N/AComputer:S27-GRAFTONDescription:The Health Service has downloaded secure configuration for management group TURSAICT02_MG, and processing the configuration failed with error code Cannot find the certificate and private key for decryption.(0x8009200B). Policy modeling confirms the SCE policy containing the keys is being applied to this server. GPUPDATE /FORCE didn't resolve the problem nor did a reinstall of the client after applying SP1 to the server. The problem existed prior to SP1, was hoping that would fix it. Error repeats every 30 minutes. Found what the code means and confirm the Machine certificates do have a trusted enterprise certificate for the SCE server FQDN. Looks like it should find the cert and work. Also followed KB278381 and reset permissions on MachineCerts RSA folder. Still no joy. What else can I try?
March 19th, 2008 7:25am

Hi, Besides Stephanieinputs,please also check if theHealth Service was running under a domain user account. If this is the case,please change it to run under the Local System account and restart the service. Hope this helps.
Free Windows Admin Tool Kit Click here and download it now
March 20th, 2008 10:50am

Just would like to throw what happened to me with the same case, and hope it can give a hint... I got the exact error message after I installed OpsMgr2007 agent on a server with a package built on another server, I uninstalled the agent, deleted the installed folder on the problematic server, pushed the agent from console, all are fine from there, Best, Manjun
April 1st, 2008 5:13pm

I receive this error and if I run the Health Service under the Local System Acoount we get non stop cscript popup error messages causing an exception. Only way to stop them we could find was to run under domain account.
Free Windows Admin Tool Kit Click here and download it now
June 3rd, 2008 10:55pm

I'm recieving this same error and the service is running as a Local System account, did anybody figure out a resolution to this issue?
November 19th, 2008 8:40pm

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics