HAL.DLL missing error when imaging from stand alone media

I am getting C:\Windows\System32\HAL.DLL missing or corrupt error messages when imaging devices from Stand Alone Media (USB stick). I am attempting to deploy POSReady 2009 OS on RealPOS 50 terminals using an image I captured from a clean parent PC. The task sequence works perfectly when executed from PXE. When I export the sequence to stand alone media it will apply the image file, apply Windows Settings, Apply Network Settings, Download the SCCM Client files, and on reboot for windows setup to run it comes up to the HAL.DLL missing error. I found a couple articles that describe needing to define a variable called SMSTSLaunchMode set to UDF+FORMAT and I have tried adding that variable when creating the media but I still get the error. I have tried creating the stand alone media directly on the USB stick as well as creating an ISO file and applying that to a USB stick with the same results.

Has anyone had then error and been able to resolve it?  Any help is greatly appreciated!

T

May 23rd, 2015 5:04pm

Hi,

You can try this article

Hal.dll is missing or corrupt: Fix for Windows XP, Vista, 7, 8, 8.1

Free Windows Admin Tool Kit Click here and download it now
May 23rd, 2015 10:47pm

That has some great info on what causes these errors and how to fix them on an individual computer but I don't want to have to run a recovery process on each imaged machine.  How would I apply one of these fixes to the Stand Alone Media or Task Sequence to resolve the issue permanently?

Thanks again!

T

May 24th, 2015 7:43pm

What happens when you boot the .iso on a VM instead of trying USB? Still get the errors?

Free Windows Admin Tool Kit Click here and download it now
May 25th, 2015 8:45am

When I try the task sequence ISO on a VM it errors out earlier in the sequence during the Apply Windows Settings task.  It gives error 0x80004005 but I'm not sure that error is related to the error i get on the physical terminal.
May 28th, 2015 1:57pm

There may be an issue with your .iso creation. You might try re-creating it, locally to the server if you can to eliminate any possible network errors.
Free Windows Admin Tool Kit Click here and download it now
May 28th, 2015 2:34pm

I have recreated the ISO multiple times while troubleshooting this issue.  I have also created this without the ISO directly on a USB drive and get the same results.  I am logged directly into the SCCM server when I create this.
June 8th, 2015 10:36am

I am not sure what else could be going wrong, review CreateTSMedia.log in the Console install folder to see if you have any errors, otherwise I would open a ticket with Microsoft to investigate. 
Free Windows Admin Tool Kit Click here and download it now
June 17th, 2015 4:02pm

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics