Getting Access denied when nav to the Shared Service instance
I created a Shared Service on my server a few days ago using the local administrator account. I have since created a separate Windows account (belongs to the Administrators group) for myself to use. I'm able to do everything in the Central Administration site but accessing this instance of Shared Serviced created a few days ago. What specific access rights does it need? My windows account is in the Farm Administrators group too.
January 27th, 2007 1:57am

Bob, Log into Shared Services using the same account you used to create the SSP a few days ago with. There is a permissions seperation between Shared Services and the Central Administration. You simply need to add your account you want to access with. Hope this helps
Free Windows Admin Tool Kit Click here and download it now
January 27th, 2007 9:04am

Heyfriend im just trying to help here so please keep the tone down. :) Did you add you other Administrator to the SSP portal?
February 9th, 2007 1:14am

kiral wrote:Try adding the second admin to the site collection admins of the SSP admin site. That should help. Exactly! Thanks a lot, kiral. Ole Thomsen
Free Windows Admin Tool Kit Click here and download it now
February 25th, 2007 5:31pm

Thanks so much Kiral. I had this same issue and your fix worked perfectly. This stuff isn't very intuitive.
September 12th, 2007 4:54pm

I wrote a blog Give a user access to SSPthat should help all of you with permissions. For the person having problem logging in with any account you could try the blog link to from that post Become Administrator of the Entire Web Applicationand give yourselft access to the whole web application. Shane - SharePoint Help
Free Windows Admin Tool Kit Click here and download it now
October 6th, 2007 5:18pm

I've got a similar issue. I can't access the SSP admin site at the base url, I get access denied. If I put in http://servername/ssp/admin/_layouts/settings.aspx I can access all settings. I added additional users. Still no luck accessing main http://servername/ssp/admin. The new users can access the settings.aspx page directly.
October 15th, 2007 8:07pm

Weare having this sameproblem. We are not able to access the Shared Services Provider site with the accountI justused to create it, the sp farm account, ssp-app account, or ssp-service account. I have tried the above suggestions including adding the accounts as full application administrators, as farm administrators,and as site administrators through the _layouts/settings.aspx page which we can also get to directly. We have loaded MOSS many times in the last few weeks in our lab and come across this issue ALOT. Any other suggestions would be greatly appreciated. Thanks. Edit: I finally found the answer, it was just much further down the google tree thanI normally go. It appears to be a bug where sharepoint builds the app pool but insists on running it with the ssp service account instead of the app account that gets entered and won't let you change it. I created a new app pool by hand with the correct account and moved my ssp data to it as suggested here It worked like a charm! Hope this helps.
Free Windows Admin Tool Kit Click here and download it now
October 21st, 2007 2:58am

The bottom line is (As stated here and links referenced here) that you should not name your SSP the same as the Application Pool for the Administration site of the SSP.What I concluded and is not obvious from thedocumentation is that there are two (2) application pools associated with the SSP: One, is created automatically by the SSP creation process and it is named exactly like the SSP. This AppPool is configured to run with the SSP_SVC account we provide. The second is the AppPool that will be associated with the Administration Application (site) for the SSP.If this was made clear from the beginning, we might not be tempted to name the SSP and the Admin site's AppPool the same. Instead, I now might name things like this:SSP Name: MOSS_SSP_01AppPool Name: MOSS_SSP_01_Admin (this tells me it's the AppPool for the admin site of the SSP_01)I hope this helps.
October 6th, 2008 7:28pm

The post bykiral - Posted on Friday, February 09, 2007 5:28:30 AM worked for me. But it's easy to get confused. When you go to assign a site collection administrator, note that you can choose another web application. You need to choose the one associated with your Shared Services Provider site. Each web application can support multiple site collections. Each site collection may have both a primary and secondary site collection administrator. So, if you go to Central Admin, Application Management, Site Collection Administrators, and see your account as the secondary site collection administrator, you might be confused and think your account is assigned access to the shared svcs provider. But look carefully at the drop-down "Site Collections" and explore a bit further.
Free Windows Admin Tool Kit Click here and download it now
December 29th, 2008 11:09pm

Have been going around in circles on this one. In the end the problem was not related to any account or application pool privileges, but rather to a 'loopback security check'. Have blogged about it here. Apologies if this post shows up several times, as I am posting it as a response to several other similar threads on technet.
May 21st, 2009 11:52am

I have the same problem, i tried all posibles solutions, but the problem i can't resolve. I found a solution log me with firefox, with Internet Explorer i Cant but firefoxi don't have problem. leon
Free Windows Admin Tool Kit Click here and download it now
August 5th, 2009 11:16pm

Hi AllI have a strange one. The SSP does not allow anyone to log on. You are challenged for credentials (which are correct) and you receive the SharePoint access denied please logon as a another user. I have found a fix of some sort which is to run the SharePoint Products and Technologies Configuration Wizard which seems to work for a short time then fails again! I think this may be to do with Group Policy overiding something so if I find anything will post back.BTW its not the issue with 401 Access denied as per my blog may decide to recreate the SSP if it takes too long...Many ThanksPaul Grimley
February 2nd, 2010 12:38pm

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics