Getting "Cannot complete this action" Error message while taking backup using stsadm.exe command line tool
Dear All,I'm using WSS 3.0 with WID (WSS 3.0 Basic Mode of installation).From past few days I'm getting one problem that, one of my backup process giving "Cannot complete this action" Error Message. I'm doing this operation through stsadm.exe tool. I was done the backup through SQL Server Management Studio Express and it is giving Successful message. So I restored this backup in another server, It's telling that the restoration process is completed successfully. But If I open that Site, I unable to see any data, not only that the perticular Site collection is removing from Central admin.Any help .... Please...Thanks,Rao.
September 26th, 2009 12:32pm

how big are your Databases? first verify how many diskspaceyou have where the stsadm command is run. verify temp folder have enough space. Be carefull with this errors sharepoint when start the Backup process by default will change your database to Read Only state, and if process fail database can still in Read olny mode To verify this can run stsadm command "stsadm -o getsitelock -url" and verify status of your database http://technet.microsoft.com/en-us/library/cc262915.aspx to unlock the state of your database you can use setsitelock to "none" http://technet.microsoft.com/en-us/library/cc262811.aspx When you Detach and attach your databases on diferent server verify user have db_owner and is associated to sharepoint. Move all databases (Windows SharePoint Services 3.0) http://technet.microsoft.com/en-us/library/cc512723.aspx On Central administration verify on Web application the content databases and see if "sites=0" if this happend the the sharepoint site is not assuming the database, This stsadm will assume yhe database you migrate tou your sharepoint Site. stsadm -o addcontentdb -url http//[URL] -databasename WSS_content Addcontentdb: Stsadm operation http://technet.microsoft.com/en-us/library/cc263422.aspx Andr Lage Microsoft SharePoint and CRM Consultant Blog:http://aaclage.blogspot.com Codeplex:http://spupload.codeplex.com/http://simplecamlsearch.codeplex.com/
Free Windows Admin Tool Kit Click here and download it now
September 26th, 2009 2:32pm

Sorry for the delay in responding. The Drive is having full of free space. I removed temp folder data. I'm doing small web application backup only, which is having 400 MB of data. I'm unable to take the backup of this web application. I used stsadm.exe tool from command prompt. Getting the same error message. I searched in the net and one of the site said that it is belongs to users (Adding / Removing). I followed those articles also. But no use.(http://support.microsoft.com/kb/823278) Any Suggestion please help. Thanks.
October 7th, 2009 5:26pm

How to know what are the patches, updates done in my older server. I asked this question because some of the persons said, while doing backup both the servers have same server configurations.THanks
Free Windows Admin Tool Kit Click here and download it now
October 7th, 2009 5:35pm

I was having the same problem as this. I would attempt to backup my site collection and receive "Cannot complete this action. Please try again."I tried everything to resolve this problem, tried everything mentioned in this post, nothing worked.Finally I decided to attempt to repair the content database via SQL Management Studio as a last ditch attempt at resolving the problem.I hope this saves time whomever is having a similar issue with getting this misterious error.Here is what to do:1. Open up your SQL Management Studio.2. Select New Query from the menu bar.3. Execute the following query:ALTER DATABASE your_database_name SET SINGLE_USER WITH ROLLBACK IMMEDIATEDBCC CheckDB ('your_database_name', REPAIR_ALLOW_DATA_LOSS)ALTER DATABASE your_database_name SET MULTI_USER4. This should repair any corruptions within your Content Database5. Open up Command Prompt as an administrator.6. Navigate to the %System%\Program Files\Common Files\Microsoft Shared\Web Server Extensions\12\Bin7. Attempt to backup your site collection.8. Success!I hope this post helps!Thanks.Thank you in advance!
February 8th, 2010 8:11pm

Dear Izzo, Thanks for the reply. I'm going to test this one in my production today evening. I will get back to you after my experiment.Thanks,Rao.
Free Windows Admin Tool Kit Click here and download it now
February 9th, 2010 9:17am

Simply Excellent steps. Thanks Thanks a lot. Thanks
February 9th, 2010 9:50pm

Hi All, Is it better to use REPAIR_REBUID parameter in 2nd SQL command instead of REPAIR_ALLOW_DATA_LOSS ?. In case of data loss application might show un-predicted application results. Please correct me if i am wrong ?
Free Windows Admin Tool Kit Click here and download it now
July 16th, 2010 4:46pm

Dear Izzo, I tried this, but i am still getting the same message" Cannot complete this action please try again". Both Moss 2007 and Sql 2005 are in same server. I am getting this message after upgrading sql express(2005) to Standard edition.Please..... Regards San
December 5th, 2010 11:43pm

Dear Santosh, Previously i was getting the same error message. But after repairing the database, the problem gets resolved. Please follow the procedure as mentioned below. 1. Backup entire SharePoint Environment from SQL backup (To be on safe side use Full Recovery model). 2. Now open query analyzer (SQL Shortcut: Ctrl + N) and execute following SQL Commands one by one for every SQL database USE your_database_name ALTER DATABASE your_database_name SET SINGLE_USER WITH ROLLBACK IMMEDIATE DBCC CheckDB ('your_database_name ', REPAIR_ALLOW_DATA_LOSS) ALTER DATABASE your_database_nam e SET MULTI_USER 3. Now restart your machine and try to take backup using stsadm. Let me know if this works for you Muhammad Tariq khan
Free Windows Admin Tool Kit Click here and download it now
December 6th, 2010 12:00am

Thanks lot Tariq, Its working fine now. ur gr8 --san
December 6th, 2010 9:03pm

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics