Failed to decrypt XML node because the password...
I have been moving a package over to a new server that someone else created. I am receiving the following error: Failed to decrypt an encrypted XML node because the password was not specified or not correct. Package load will attempt to continue without the encrypted information. Warning: 0x0 at Start: Multiple-step OLE DB operation generated errors. Check each OLE DB status value, if available. No work was done. There are many packages that are inside of the parent package. I do Not have SQL Agent and I run the parent package through a bat file in the task scheduler with the saved password. I have tried running it with the password and without on all of the child-packages. With the properties of each package set to "Encrypt Sensitive With Password" and I have also tried "don't save sensitive" The child package looks like it runs fine but it fails in the Parent Package Control Flow. I know this is a password problem but I have tried the various methods, with a password and and with out one. Any ideas on what I can do to solve this problem? I am wondering if I remove all of the password how do I also remove the password that shows up in the 'Execute Package Task Editor'? I think that might help, as even when I insert a new E.P.T. the password is already in the editor.
September 26th, 2012 2:57pm

Just open the package for editing and flip its protection mode to say "save sensitive with password" and provide the new password, then use it in the batch.Arthur My Blog
Free Windows Admin Tool Kit Click here and download it now
September 27th, 2012 11:24am

Sorry still a newbie, do you mean open the master solution in Visual Studio for editing? Where do I flip the protection mode? I have changed it under the package in the properties, to encrypt sensitive with password but is there somewhere else to set it to "save sensitive with password"?
September 27th, 2012 12:53pm

Yes, I meant to open the package in the Business Intelligence Developer Studio or Visual Studio and edit the package protection level property of the package in question (example, so not the one you need, but perhaps the setting that was applied by whoever developed it): Arthur My Blog
Free Windows Admin Tool Kit Click here and download it now
September 27th, 2012 5:10pm

I have already tried that and it has not worked.
September 28th, 2012 11:21am

You may want to use BIDSHelper to reset the GUIDs of one package and see if it works. If notTry creating a new package and running it, if it runs then you may need re-create the packages done by somebody else. If this fails consider re-installing SSIS.Arthur My Blog
Free Windows Admin Tool Kit Click here and download it now
October 1st, 2012 10:00pm

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics