Failed Server Rebuild


I have had to rebuild a 2012 Server w/SC DPM2012 Sp1.  I followed this process to the tee:   In trying to do the restore command ON the remote SQL 2008R2 instance running on a Server 2008R2 physical box it immediately fails with this pop-up from CLR20r3 as well as the error indicated in the CMD prompt box


When run on DPM server this error is generated:

Even thought the error indicates login error it is NOT the case as the indicated login has no problem accessing all the other databases on the SQL server. After hours of Googling it is well know THAT same error will appear when the database itself is unavailable, which IS the case. It doesn't get restored.

I'm LOST would love a solution.................. I'm imagining restoring the db from within SQL by doing a SQL restore will NOT work??? Or it WILL restore the db it just will have problems syncing with DPM 2012SP1

December 30th, 2013 10:25pm


The backup of the DPMDB created in setup 1 outlined in the TechNet you referenced can be restored via SQL management studio. Once the DPMDB.bak is restored with success you will need to proceed to step 6 in the outlined Technet.

Also note that in step 4 once DPM install is complete you need to ensure you apply any DPM Roll Ups that were in place for the original DPMDB before you restore (step 5 in referenced technet)  the DPMDB (backup created in step 1) you ultimately wish to restore.

DPM List of Build Numbers

Please remember to click Mark as Answer on the post that helps you, and to click Unmark as Answer if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. Regards, Dwayne Jackson II. [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights."

Free Windows Admin Tool Kit Click here and download it now
January 9th, 2014 11:11pm

Dwayne, thanks for the answer.  While waiting for an answer I DID indeed do a restore from SQL but I cannot get the synch to work.  Once it runs, maybe under a minute it throws no errors but none of the replicas, restore points, or even Protected Servers are present; basically a clean DPM.  The restored Database can be viewed in SQL 2008R2 Management Studio but the correlation or syncing to DPM is not there.  I try to keep everything well patched but can only assume I was on the latest rollup of DPM before I uninstalled/re-installed.  IS there a way to get that info from the replicas??  I simply assumed (maybe wrongly) I had DPM fully patched before the problem and have brought the current re-install to the most patched level possible with current updates.  Is there a way to extract that info from my replicas??

To clarify, the screenshots were a result of running the command in step 5 PREVIOUS to manually restoring in SQL Management Studio.  As indicated I tried from the SQL server to do the restore and got the CLR20r3.  Then at the DPM Server got the "Login failed" error which for one thing there wasn't a Database there, I was trying to restore it.  Secondly DPM Server has probably too much login/share/security privileges which include "Distributed COM Users",   "DPMDBAdministrators$DPM2012SP1", "DPMDBReaders$DPM2012SP1", added to "Local Administrators" Group, user mapping under Security-->Logins the computer domain account has "dbo" privilege and under Server Roles--> as a "sysadmin"   Now that I have restored it using SQL Management Studio I get the results as stated in my opening sentence here:  the DPMSync -sync command runs for under a minute, throws no errors, but opening DPM Management Console it is a blank slate which is what I suspected would happen and put that in my first post.......

January 10th, 2014 3:03am

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics