FIM SSPR OTP Email are not getting triggered

Hi All,

I have configured this OTP Email services in one of my Test lab environment and It was working fine earlier and all of the sudden one day I tried to reset password for one test User I got error: "Unable to send OTP" contact your Admin. I looked into server event log and found below error coming up continuously:

System.Web.Services: System.Net.WebException: The request failed with HTTP status 401: Unauthorized.
   at System.Web.Services.Protocols.SoapHttpClientProtocol.ReadResponse(SoapClientMessage message, WebResponse response, Stream responseStream, Boolean asyncCall)
   at System.Web.Services.Protocols.SoapHttpClientProtocol.Invoke(String methodName, Object[] parameters)
   at Microsoft.ResourceManagement.WebServices.Mail.Exchange.ExchangeServiceBinding.FindItem(FindItemType FindItem1)
   at Microsoft.ResourceManagement.WebServices.Mail.Exchange.MailChannel.ExchangeMailChannelListener`1.ExchangeMailListener.<OnPollTimerExpired>b__0(Boolean findUnreadItems)
   at Microsoft.ResourceManagement.WebServices.Mail.Exchange.MailChannel.ExchangeMailChannelListener`1.ExchangeMailListener.OnPollTimerExpired(Object state)


The Forefront Identity Manager Service cannot connect to the Exchange Web Service.

The connection failure may be due to a network failure, firewall configuration error, or other connection issue.  Additionally, the failure may be due to incorrect Exchange Web Service configuration.

Verify that the Exchange Web Service is reachable from the Forefront Identity Manager Service computer.  Ensure that Exchange is running, that the network connection is active, and that the firewall is configured properly.  Last, ensure that the Exchange Web Service configuration is correct in the Microsoft.ResourceManagement.Service.exe.config file.

Please suggest. Thanks in ad

May 28th, 2015 8:46am

Try logging in to OWA from that box with that user.
Free Windows Admin Tool Kit Click here and download it now
May 28th, 2015 9:18am

Hi Nosh,

Just to add in my question. "Fimservice" has mailbox and I am able to access it using OWA from FIM service server.

As I said, It was working very fine earlier and I don't know what went wrong in just a week although i didn't change anything.

May 28th, 2015 9:49am

Understood all of it, still asking you to try now after "whatever happened"  Also see if the certificate has expired.
Free Windows Admin Tool Kit Click here and download it now
May 28th, 2015 9:50am

I tried and I am able to send and receive Emails from FIMService account from this server using OWA and Also checked for certificate and It is not expired,working fine.

And There events are getting generated very frequently like every minute. 

May 29th, 2015 12:28am

Hi All,

Thanks for your all help. It is finally resolved and I was able to resolve it using EWS Managed API and to test exchange Auto discover from my FIM Service server. 

Free Windows Admin Tool Kit Click here and download it now
May 29th, 2015 3:17am

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics