Excel file in doc lib opens for read-only users in Excel Services and not in Excel as read-only as I want
I'm having a problem that I have a workaround for but it's not a solution... I'm stumped.I have an Excel 2007 file in a document library.The document library is set to "Open in the client application"I've granted Read permissions to users but when they click the document it tries toopen in Excel Services.If they select the document pull-down they get "View in Browser" or "Snapshot in Excel" as their only options.I don't, however, want to view in a browser or view a snapshot... I want to open the file in Excel as read-only.The only way around this I've found is to give contribute rights to the document... but I don't want to do this either.What am I missing? Kevin
June 5th, 2009 7:14pm

Moving to Admin (as you *don't* want to open in Excel Services ...)WSS FAQ sites: http://wssv2faq.mindsharp.com and http://wssv3faq.mindsharp.com Total list of WSS 3.0 / MOSS 2007 Books (including foreign language) http://wssv3faq.mindsharp.com/Lists/v3%20WSS%20FAQ/V%20Books.aspx
Free Windows Admin Tool Kit Click here and download it now
June 5th, 2009 9:38pm

Hello, I can reproduce the same issue as you. The cause of that issue is that the document library which hosts the problematic document is just one of the Excel workbook file locations which are configured in Central Administration-> SharedServices (SSP)-> Excel Services Trusted File Locations. That means all Excel files in the document library which is listed under that location will be automatically opened with view in browser (Excel Service form). Also, Ive found that if the document is in Reports Library of Reports site under publishing site collection, then any document in it will be automatically opened with Excel Service, no matter whether it is a trusted file location for Excel Service. So the solution should be Move the specific Excel document to another document library (other than Report Library) which is not listed as trusted file location of Excel service, then grant users permissions on the new location. Regards, JerryXing-Bing Yu
June 8th, 2009 6:59am

Xing-Bing Yu,I can reproduce the same issue as well, but the scenario is slightly different. If you break permissions inheiritance on a standard document library (not a reports library) and then grant read-only access to that library to a sharepoint group that has no access to the site, then the users in that group will always experience this issue when attempting to open an Excel 2007 workbook. The same users are able to successfully open Excel 2003 workbooks stored in the same library. I have verified the following:1. The library in question is a standard document library. It is not a reports library.2. The Brower-enabled Documents setting under the Advanced Settings of the Document Library settings is configured to Open in the client application.3. No libraries or sites in the entire site collection are listed a Trusted File Location in the Excel Services settings in the SSP for the web app that hosts the site collection.4. The Office SharePoint Server Enterprise Site features for the Site and the Site Collection are both disabled.We can'tdisable Excel Services on the farm because we are using the servicein other site collections. Is this a bug in SharePoint? Or is there a fix for this issue?Thank you,Jason Cochran
Free Windows Admin Tool Kit Click here and download it now
July 8th, 2009 6:35pm

I forgot about this thread... I'm going to have to agree with Jason. It's not exclusive to the Reports Library/Trusted Site scenario.Kevin
August 20th, 2009 12:29am

I am having the same issue. Document library, users have Read access to files, inheritance has been broken at the folder, library setting is to Open in client application. Clients have Office 2007. Site is not in trusted location for excel services (I want file to open in client application).Anyone come up with a solution or explanation?thanks,Daniel
Free Windows Admin Tool Kit Click here and download it now
September 23rd, 2009 6:30pm

I ran into the same issue, and this is a bug but I have a work-around.Even though you can hit the dropdown and click edit in Excel and view the document, for some strange reason you need to make sure the user has READ access to the root of the document library on top of access to the folders/files you specify. If you specify permissions directly to the file or folder, the permission shows up as "Limited Access", you need to change this to read.Thanks,Deepak
September 24th, 2009 9:19pm

I have a folder within a library that this person needs contribute access too. If I where to go to the root of the library and give him read access like proposed, then hs is able to view the rest of the documents in that library, which is not the outcome we need. I beleive that giving them "read" access at the root will not overcome this issue. Has anyone else found a workaround to this?Thanks
Free Windows Admin Tool Kit Click here and download it now
October 1st, 2009 8:43pm

Jason, I am facing the similar issue now. Do you have a solution for this problem? Thanks, Chandrasekhar.
May 25th, 2010 10:25am

Sort of, As Deepak stated above, you can grant the users read access to the root of the library and then set more restrictive permissions on each folder/file in the library. Although this method could be difficult to administer if you have a large number of folders/files, it does prevent the spreadsheet from opening in Excel Services. Also, another work around is to have them use the drop down menu for the file and choose "Send To > Download a Copy". Hope this helps a little. Jason
Free Windows Admin Tool Kit Click here and download it now
June 8th, 2010 11:37pm

I am having a similar problem which must be related to the breaking inheritance on permissions problem. This affects the - We have a document library which User1 can contribute and all is well for this user. - In that we have created a folder which we, in addition, want User2 to be able to read. The permissions seem to work okay but the dropdown view menu is missing (and the problem with Excel files being wrongly opened in the browser using Excel services is present too)... literally the outputted code for the view menu is missing in the td tags. We can give User2 full control over this folder but the same problem exists. If we give User2 read access to the document library then all is fine for them as well - and they can see all the other documents. That's not acceptable as the remaining documents are of a sensitive nature that User2 should not be able to see. Manually (or programmatically) then breaking inheritance on each other item is not practical. Now, and this might be the clue, we are pretty sure this was all fine until we bought our Enterprise CALs and enabled Enterprise features. I also tried this on my development box with the same results. It is not client related as I've tried it on different computers running different browsers. Anyone got any bright ideas? Work-arounds aren't really acceptable in this instance. Harry.
February 2nd, 2011 12:55pm

I've found a solution for a similar case. It also had to do with the type of the library (Reports Library), which will open on the web by default, even if the "Open in the client application" setting on the library is selected. The problem is the View and you have to change it from the default: - Click to Modify the current view - Uncheck “Name (link to report with edit menu)” - Locate “Name (linked to document with edit menu)”, check it and select the order number 2 - Click OK - Do the same for the other views if you want That's it, now the Excel files will open on the client (don't forget to change the default setting too of course). Hope that helps someone.
Free Windows Admin Tool Kit Click here and download it now
May 5th, 2011 9:18am

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics