Error while uploading files on sharepoint 2013 (drag or new document)

Hi All,

When I am trying to upload file on document library I am getting the below error.

Error:

Sorry, for some reason this document couldn't upload. Try again later or contact your administrator.

N.B: this error doesn't appear with the small file starting from 1 to 300 or 400 mb and the error appears when the file size start from 600 for example to the maximum size that i have inserted in advance 2047 mb, im weird as the error appears after successful uploading operation even if the file is large! and i have checked the logs for detailed error message but couldn't get any root cause..please help



  • Edited by Zidan EG 21 hours 30 minutes ago
May 19th, 2015 6:08am

SharePoint has a hard limit of 2GB for a file upload. It's an architecture issue and not one that can be worked around or stretched at present.

The default upload size limit is 250MB, beyond that SharePoint should spit out an error saying your file is too large. If your admin has increased that limit (up to 2GB) then you are at the mercy of your network and connection quality. Both need to be very good to upload files of that size.

Further you might have limits on your SQL server, or your Site Collection Quota. Are you the Admin in this situation and if so what process have you followed to increase the upload file limit?

Free Windows Admin Tool Kit Click here and download it now
May 19th, 2015 6:39am

Thank you for your fast response,

Yes im the admin in this situation , the process that i have increased the upload size limit to 2047 the maximum allowed size and after this error appears i have modified the web.config file for the appropriate web application, this is located by default at C:\inetpub\wwwroot\wss\VirtualDirectories\web application port

i didn't make any modification in the SQL server.

If my process is deficient please help me.

May 19th, 2015 6:52am

That's two of the major points but it might not be all of them. The IIS timeout value will probably still be set to 120 seconds for example.

This blog is useful, although it was written for SharePoint 2007 it's stil more or less accurate for 2013. (I wouldn't change the SQL chunk size). 

http://blogs.technet.com/b/praveenh/archive/2012/11/16/issues-with-uploading-large-documents-on-document-library-wss-3-0-amp-moss-2007.aspx

Free Windows Admin Tool Kit Click here and download it now
May 19th, 2015 8:46am

Zidan,this issue is because of many reasons like the settings configured,web.config.please find the link below that explains all the issues and the solutions for the same issue.

http://expertsharepoint.blogspot.de/2014/02/issues-uploading-large-files-to.html

May 20th, 2015 2:08am

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics