Enable 8dot3name in a task sequence using WinPE 4.0?

Hi all,

I'm using CM2012 with SP1 to deploy Windows 7 with SP1, and I need to enable the 8.3 file & folder names in the file system.  I know I have to do this right at the beginning immediately after the format step.

I know MS have recently changed the 8.3 names to be disabled by default, as outlined here: http://scug.be/sccm/2013/01/15/configmgr-2012-sp1-the-8dot3name-settings-are-disabled-on-the-volumes-upon-partitioning-and-formatting-of-the-local-disk/

I hope my question is a simple one. 

What files do I need to create an fsutil package (or what components to I need to add to my WinPE image) in order to be able to run the "fsutil 8dot3name set 0" command. 

I've already attempted to create the package myself by copying the fsutil.dll and fsutil.exe files from C:\Windows\System32 on a Windows 8 machine, but when I execute it in WinPE 4.0, I get the error "Unable to format message for id 400002710 - 13d".  I thought I'd then get sleuthy and use procmon to monitor what dll's fsutil.exe calls from the command prompt on a fully built workstation, then I copied all those DLL's, but alas, I still get the same error.

According to that link above, "Steve' (in the comments) has created a package. My comment on there is awaiting moderation, so in lieu of that I thought I would also ask here incase someone has done this before.

Likewise, if fsutil isn't the best way to do this from WinPE 4.0, but someone has a powershell/vbscript that does the same thing - please post up here.

Any help is greatly apprec

May 14th, 2013 10:37am

Hi Noel,

You are right, facing the same problem during Windows 8 Image deployment. But there is an option in format command- 'format C: /q /s:enable' , which enables short naming feature. Try this, meanwhile me too working on this...will keep you updated...

Free Windows Admin Tool Kit Click here and download it now
May 14th, 2013 4:21pm

Thanks Praveen!  I didn't know about the /s:enable switch with the format command.  I've added that to my task sequence and it works a treat!

For anybody else that comes across this issue, this is what I've done using Praveen's method.

1. In my build & capture task sequence, I have continued to use the default "Partition Disk 0" step.  This creates the 350mb BitLocker, and 100% of remaining disk partitions.  I configured the 350mb partition with the "Do not assign a drive letter to this partition" option.  This allows the bigger partition on Disk 0 to get the C:\ drive assignment. 

2. Immediately after the "Partition Disk 0" step, I have inserted a Run Command Line task that I've named "Enable 8.3 file names".  The command here is cmd /c format c: /fs:ntfs /q /v:SYSTEM /s:enable /y

Up to you if you want to use the /v switch to give the volume a name.   No other options in the task are configured (so leave it everything else as defaults).

3. After the "Enable 8.3 files names" task, is where I have my "Apply Operating System" task.  From here on is just the normal build & capture process.

Effectively, you are formatting the C:\ drive twice.  Once when SCCM creates the partition (without the 8.3 names), and then again through the command line (but this time enabling the 8.3 short names).  The whole thing adds maybe 5 seconds to the task sequence; but best of all, you don't need to muck around with FSUTIL, scripts, or use a diskpart script to partition your drive.

Also note, to do this, it must be done using the original OS source media.  This will not work if you are trying to retrofit the 8.3 names to an existing WIM you have already captured; for reasons mentioned in the URL I posted at the top.

Hope someone finds this useful.

And thank you Praveen! :)

May 15th, 2013 8:18am

Also figured out the way to use Fsutil utility in WinPE 4.0... Copy the "fsutil.exe" & "fthsvc.dll" from c:\windows\sysWOW64 folder of 64 bit Win8. And copy "fsutil.exe.mui" from c:\windows\sysWOW64\en-us to WinPE's "windows\system32\en-us" folder. This will make the utility to work without any error... Also many options can be used with this fsutil...
  • Proposed as answer by Praveen DN Monday, May 20, 2013 9:35 AM
Free Windows Admin Tool Kit Click here and download it now
May 15th, 2013 3:09pm

OK I have a question on this, is there a way to incorporate this /s:enable into a DISKPART command? Below is my current DISKPART.txt file contents, for me to enable the 8.3 file name format I have had to strip the format part out of diskpart and add an additional step but it must be possible to do it within diskpart, mustn't it?

select disk 0
create partition primary
assign letter=C
format fs=ntfs label=Windows quick



January 7th, 2014 10:58am

Hi Parto - I looked through the diskpart options here (http://technet.microsoft.com/en-us/library/cc766465(v=ws.10).aspx), and I couldn't see anything that related to being able to change the 8.3 filenames.  I would suspect this is because the built-in "format" command in diskpart, is different to the format.com command you find in C:\Windows\System32. My guess is the capability to change the file/directory structure to enable 8dot3 names is not available in diskpart. You will more than likely have to run 2 commands to get this to work, one with your diskpart script, and another using the format.com command with the /s:enable option.


Free Windows Admin Tool Kit Click here and download it now
January 9th, 2014 2:08am

Seems bizarre to me, MS have removed 8dot3 file name support by default in PE v 4.0 but have not revised the DISKPART options to allow it to be added back  in for people who need it. I had a very nice script that performed all of my disk preparation actions in one hit and now I have to remove the format line and add an additional step to format the drive with /s:enable so 8dot3 support is turned back on. Bit short sighted IMHO

If anyone knows better I'm all ears

January 14th, 2014 3:05am

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics