Domain controllers active directory replication failure on cross-premise network

Hi all,

My domain controllers on the Azure and on-premise used to replicate the directory until few days ago. I didn't realize there was some payment problem on my Azure subscriptions and my services were disabled. After I made the payment, I recreated the removed VNet gateway and established the site-to-site VPN.

Even the domain controllers are able to ping and nslookup to each other now, the directory service has stopped replicate between two DCs. There are many Error 1863 and Warning 2089 on the event viewer.

I tried to look for solutions of Error 1863 for a day but I found very little knowledge and solution about it. I also tried to demote DC2 (on-premise) and promote it again. I got errors while demoting it. Below is the print screen of the error.

I have an idea now which is disjoin DC2 from the domain and force it to remove the AD role. Then, rejoin the domain and promote it to DC2 again. Can anyone advice if this is something do-able ? Any suggestions or advices are much appreciated.

Thanks,

Chee-Kian

July 28th, 2015 10:36am

Hi,

first make sure there are no FSMO roles on that domain controller using the below command

netdom query FSMO

If any roles exists on that Dc please get transfer or Seized the role. Once it has successfully transfer kindly go ahead and do the DCPROMO /FORCEREMOVAL command to remove the DC from AD.

Free Windows Admin Tool Kit Click here and download it now
July 29th, 2015 2:45am

Hi Purvesh,

Thanks for your reply. There is no role exists on my DC2. My DCs are running Windows Server 2012 R2. DCPROMO /FORCEREMOVAL doesn't work for my machine. So, I tried to remove the AD from server manager and I got the errors which I posted in my first post. Any idea?

Thanks,

CK

July 29th, 2015 3:45am

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics