Documents inside a library not showing

Hi All,

I need a help on this issue, as I have been google-ing for it but not solution. The issue is some of our users do not see any documents in Documents Library. As shown in the image: 

The correct view:

Wrong view: 

As you can see in the second picture, the libraries appears as if it is empty, but it is not. Some of the users it is working find, some are not. This happens in all browsers despite the version, IE, FireFox, Chrome, and Safari. Is it related to jQuery or any script, I am only using the default...?? I don't know the issue....

I am totally lost here :(

pls asist

appreciate your help.

May 26th, 2015 1:03am

This may be an issue related to permissions. Check what access permissions the user have on this library.
Free Windows Admin Tool Kit Click here and download it now
May 26th, 2015 1:31am

This might happen because of the permissons. You can check which users which have permssions on that library.
You can check permissions from ribbon action
1. Library Setting -> Permissions and Management -> Permissions for this list
2. Shared With

Please remember to mark the replies as answers if they help.
May 26th, 2015 1:44am


I'm not sure if it is related to the permissions, because even with the SharePoint Admin account, the list of documents shows in My PC, and my Windows 8 Taplet. However, it is not showing when I log in in my collegue PC with the SharePoint Admin account.


regarding the library settings, all users have a read permissions on the library.

Free Windows Admin Tool Kit Click here and download it now
May 26th, 2015 3:17am

Seems to be a strange issue.
Do one thing check if the same issue replicates in some other  list or library.
May 26th, 2015 3:21am

Same peoblem even with other lists/libraries. I also created new site, with new library, it is working fine with me and some users, but some the sames problem.

at first, I thought it is related to the version of the browser, but with me, I have tested it in IE11, Frirefox, Chrome, and Safari, working great.

in My Taplet, in IE it is not working, however it is showing good in Chrome. When I tried in my Colleuge Ipad, the problem is thier.

any idea..?

Free Windows Admin Tool Kit Click here and download it now
May 26th, 2015 3:31am

Another issue is this:

the search box is not showing as well in the browser that has the document list view issue (desctibed earlier). I believe it is something related to jQuery (may be)...

any idea???

May 26th, 2015 9:12am

Hi Barakat,

           Can you check once with the default sharepoint master page? If it is anything related to custom javascript or jquery which you had wriiten, changing to default master page should display the content correctly.

           Also you can use developer tool to see display property of the container for users to whom results are not getting displayed and compare with that of users to whom content is getting displayed. Hope this helps.



Free Windows Admin Tool Kit Click here and download it now
May 26th, 2015 9:27am

Hi Hari,

I did not custome jQuery or javascript.

It is confusing me coz it is running fine in with some users but others not. Even in other devices such as ipad or taplet, it is showing fin in some browsers, but not the rest. I cant come up with a conclusion of a reason for this... -_-

May 26th, 2015 10:44am

Let's start at your assumption.  JavaScript and jQuery as usually a client-side technology.  What this means, is that if your content was being blocked from displaying by JavaScript, it is still being transmitted from the server to the browser and is hidden from rendering in the browser.  Using a tool like Fiddler you should be able to see your data in the payload on the client.

This is not the probable cause.  Security, either SharePoint groups, AD groups, User Profiles (have you checked you Profile Synchronization Service), or Audience memberships are usually the cause of this behavior.

If a specific user has a repeatable issue with downloading the content (it's not in the payload), it is a security trimming issue related to the users access to the content.  Start with the user, analyze their group and audience membership, verify security settings on the content (list or library settings) and verify that all AD/User Profile service synchronizations are occurring without issues.  Somewhere in that effort you will stumble upon your answer.


Free Windows Admin Tool Kit Click here and download it now
June 7th, 2015 11:05am

Hello DanKline ..

Thanks for the replay.. I already tried the Fiddler.. in two different users machines.. the one where everything works find, and the document shows, also the search bar is there.. and compared it with users whome the problem occurs..the picture below shows the one with this issue..

the highlighted parts are the differences..

any ideas...?


June 7th, 2015 6:34pm

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics