DPM agent workgroup protection returns access denied

Hello everyone,

So I'm having this error while trying to attach a server on an untrusted domain:

Attach protected computer ServerName.FQDN-PN.local failed:
Error 32680: The credentials specified for server ServerName.FQDN-PN.local are invalid.
Error details: Access is denied (0x80070005)
Recommended action: Rerun the operation with the same credentials that were provided when running SetDpmServer for the target server.

DPM doesn't even thinks that much, it's a pretty quick failure pop-up.

I've tried to configure dpm agent on the untrusted server using both FQDN and NetBios only, 

SetDpmServer.exe -dpmservername ServerName.FQDN.local -isnondomainserver -username dpmusr
-productionserverdnssuffix FQDN-PN.local

SetDpmServer.exe -dpmservername srvdpmlx -isnondomainserver -username dpmusrfsmeta4

But both return the same error.

The DPM server is on the domain ServerName.FQDN.local and the untrusted computer is on the domain FQDN-PN.local. Both domains are unrelated, but are contactable with each other by network conectivity.

I found this thread (DPM 2010 - Backup domain controller of untrusted forest...), but somehow I didn't relate much to it.

I'm sure I'm providing the correct credentials.

I did have to install C++ 2008 runtime on the server, but I used the version on the dpm agent folder (AC not RA); Not sure if problematic. The system is running a server 2008 SP1 64bit.

Any help would be greatly appreciated. Please feel free to ask questions if I happened to left something unclear.

July 26th, 2013 12:50pm

Hello again,

This is probably a new bug introduced in the latest roll up (That's Roll up 3 for DPM 2012 SP1)

The agent I had installed was of a version prior to the version the DPM server was running (Version of Roll Up 2 - 4.1.3313), and because of that, the described above would happen. I just updated the agent to the latest version on the unprotected computer (that's version 4.1.3415), and the attachment wen't flawlessly with the NetBios version of the command.

If I wasn't as civilized as I am, I would begin advising Microsoft to ease on the pressure on it's engineers...

Moving on to test if I will actually be able to back up anything.

Free Windows Admin Tool Kit Click here and download it now
July 26th, 2013 1:40pm

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics