Could not find stored procedure proc_ar_BumpCacheInvalidationCount er
Hello MOSS Experts, The following message appears in the event log after initial setup and configuration of MOSS 2007. Any ideas on what this proc is for and why it can't find it? Log Windows NT (Application) Source Office SharePoint Server Category Office Server General Event 7888 Message A runtime exception was detected. Details follow. Message: Could not find stored procedure 'proc_ar_BumpCacheInvalidationCounter'.
April 19th, 2007 8:51pm

An idea ? I have the same message !
Free Windows Admin Tool Kit Click here and download it now
May 10th, 2007 7:39am

I am also receiving the same error. I began receiving this error message after scheduling a full and incremental import of Active Directory within SharePoint.
May 23rd, 2007 9:17am

I have been having this error for a long while now, everything seams to work fine beside this error in the event log every time i do an import of users. I have done another installation and seen that the installation with the error is missing lots of Stored Procedures called Proc_ar in the SharedServiceProvider Database. Im currently loocking for a good way to test to imort these missing stored procedures or finding a way to recreate them.
Free Windows Admin Tool Kit Click here and download it now
June 7th, 2007 7:36am

I'm blogging about this errorat http://chve14.spaces.live.com/blog/cns!5CCEEAA528311AA8!142.entry, i have found a way to get the error to dissapear but i don't know if that solution is good yet. Regards Christian Vesterkvist
June 12th, 2007 10:27am

Is there any offical fix for this problem yet? Adam.
Free Windows Admin Tool Kit Click here and download it now
August 12th, 2007 4:22am

I currently have two MOSS 2K7 systems set up in a Test and Development environment and this same error existson only one environment... The first system is installed with a MOSS 2K7 Enterprise license. It does not exhibit the 'prc_ar_BumpCacheInvalidationCounter' error on my index server during the profile import. It does however produce a different profile import error below, which I am still investigating (something to do with permissions for the user connecting to AD to perform the import - Access Denied). Mysecond system is installed with MOSS 2K7 Standard. It does produce the 'prc_ar_BumpCacheInvalidationCounter' error message on my index server during profile import. After investigation, I have found that the stored procedure 'prc_ar_BumpCacheInvalidationCounter', is available in SQL on my MOSS 2K7 Enterprise installation in the SSP Database, but not in my MOSS 2K7 Standard installation. My guess is that MOSS does not install the stored procedurein SQL when a Standard license is entered...but the profile import is stilllooking forit. Just my two cents. Regards, Jason
August 14th, 2007 12:33pm

I too have this problem doesn't occur in my test environment but does in my production environment. I also had the test environment setup using an eneterprise license but use only standard in production and I have come to the same conclusion as Jason. But it would be nice if someone could confirm this for us Regards David
Free Windows Admin Tool Kit Click here and download it now
October 23rd, 2007 7:59am

We have same problem, running SharePoint MOSS 2007 (standard licence) with SP1. I am surprised that I can find no confirmed solution to this problem. Leon Denmark
March 5th, 2008 7:22am

We are also having the same issue (sharepoint standard, no SP1). Does SP1 help?
Free Windows Admin Tool Kit Click here and download it now
March 28th, 2008 7:18am

Nope SP1 is not much help either. The missing stored procedures are deployed as part of the enterprise build ofMOSS from what I've seen and not the standard build. You could try exporting the stored procedures from an enterprise build SSP Databaseand then importing them into your Existing SSP. Or you could leave it as a known issue. I've not tried it myself so make sure you have full backups of your data in case it all goes horribly wrong Found this posting for exporting SQL Stored procedures here http://www.devnewsgroups.net/group/microsoft.public.sqlserver.tools/topic51151.aspx Instructions are You can right-click on a databaseChoose Tasks | Generate ScriptsWade through the various screensWhen you get to "Choose Object Types" you will want to select Stored Procedures
May 16th, 2008 11:46am

Just for your info I did try exporting just the single missng procedure and importing, which removed that error and replaced it with a AR_CacheCounters error instead. Lovely!!! I suppose we need a fix that puts the stored procedures in place and then updates any other information as required.
Free Windows Admin Tool Kit Click here and download it now
May 16th, 2008 11:56am

Final Solution: http://vladco.blogspot.com/
June 23rd, 2008 12:16pm

I'm having the same problem too. This have an impact on the mail alert service as the import fail to capture email address.
Free Windows Admin Tool Kit Click here and download it now
September 2nd, 2008 6:47am

Maybe you can find solution from this blog http://blogs.msdn.com/b/echarran/archive/2007/03/06/office-sharepoint-server-eventid-7888.aspx
July 10th, 2012 10:06am

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics