Control Adapter
Our solution currently uses a WebControlAdapter to run various tasks before selected events like OnInit and OnLoad are processed. On deployment, our solution creates a .browser file in the app_browser folder of the site and the adapter works as expected. This has worked well up until converting the solution to SharePoint 2010. The deployment appears to run fine and the .browser file is created, but when the site is first accessed by the browser, the adapter defined in the .browser file is not loaded (it does not show in the list of current adapters i.e. System.Web.HttpContext.current.Request.Browser.Adapters). The curious thing to point out here is that the adapter will start to work and the adapter will show as loaded (again in System.Web.HttpContext.current.Request.Browser.Adapters), if a Dll in the bin folder of the site is removed from the site then replaced with the same DLL. Other tasks will also cause the adapter to start working, like running "UpgradeSolution" on the original solution. I've tried just about everything imaginable, but the only change that seems to work is to place the .browser file in the SharePoint browser folder (Program files\common files\microsoft shared\web server extensions\14\config\browsers) before the site is created. When this is done, everything works as expected and the .browser file is loaded. If anyone has any ideas, I'd appreciate any input on the problem.. Thanks
October 27th, 2010 10:26am

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics