Content search webpart (also recently changed items, etc) No results on page, while testresults in query builder look just fine.


Recently my company made the swith to SharePoint 2013 (office 365) Entrepriser licence.

Now I'm trying to build a Collaboration site on a top level that shows me all the recently changed items.

Now when I use a content Search or Recently changed Items webpart, it always gives me the correct result in the query builder but when I save the page I get no results back from my webpart. (not ever)

We are still running IE8 but I also tried Chrome and the result is the same (empty webpart!) (On wikipage, webpart page, with or without publishing activated)

I've been trying and looking for days but can't seem to figger out what I am missing or forgetting. Are there maybe features that need to be actived or search settings that need be  modified?

Thanks in advance



January 14th, 2014 8:56am

Hi Linda,

According to your description, my understanding is that when you tested query result for Content Search or Recently changed items web parts, it worked well, however, afte saving the page, the web part display nothing.

Whether this issue occurred on other computers.

I did a test with Content Search and Recently changed items web parts, everything worked well. I am using IE 10 32-bit.

Please do a test using IE 10 32-bit, compare the result.

Note that , after you test the result for the web parts, please make sure you click on OK or Apply, then save the page.

In addition, as this issue is about SharePoint Online, you can also create a new thread on SharePoint Online forum:  . More experts will assist you with SharePoint Online.

I hope this helps.



Free Windows Admin Tool Kit Click here and download it now
January 15th, 2014 4:02am

Hi Wendy,

I'm getting a test PC today to try out the IE 10. I'll get back to you on this.

Your assumption is correct, when having tested my query (wich gives me 4 results of the correct contenttype), clicked Apply and ok for my webpart, saved and published my page I get a blank space where the results are supposed to be.

I'll post the exact question in the online forum. Thanks for the tip!



January 15th, 2014 4:12am

It won't be the browser.

Content By Search Web Parts started working from October last year so they should have updated your site to the latest version by now.

Given that you can see the results in the query builder that means that your content has been indexed so that isn't relevant either.

You are using the same account to test the query as to view the page so it's not permissions based either.

The instructions on how to configure them for O365 are here:

I would roll the test back, try to find out if you can get any content, any at all, working in the CSWP. That then allows you to narrow the scope of your investigations.

Free Windows Admin Tool Kit Click here and download it now
January 15th, 2014 4:13am

Hi Alex,

I've followed these instruction about 7 times now, but still the same result. My query builder works fine, but on the page I get nothing. When looking at video's on youtube I see that when inserting the Recently changed items webpart you chould instantly get result in the output sceen of your webpart, grey squares with questionmarks in them. I don't get any of this, it just stays blanc.

And when saving the page the webpart is hidden, as if there are no results.



January 15th, 2014 4:40am

The only thing i can think of is if you're on E1 or E2 i don't think it's available.
Free Windows Admin Tool Kit Click here and download it now
January 15th, 2014 4:48am

We are on IE1
January 15th, 2014 4:52am

Sorry E1 licence
Free Windows Admin Tool Kit Click here and download it now
January 15th, 2014 4:52am I found this other forum, t seems to me that if the webpart is not functioning within a certain Licence plan then it just isn't present in the galery.

I can add the webpart and configure it but I just don't get any results. I checked the SharePoint Online Service Description but there is no specific mention of the CSWP.

January 15th, 2014 5:50am

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics